]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
- add support for recording user's login uid to the process attribute
[packages/cronie.git] / cronie.spec
CommitLineData
955f0d7d
ER
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
64e4eafc
ER
4# - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5# Mar 3 09:30:01 ravenous CROND[2528]: 4ÿ
9088c091
AM
6#
7# Conditional build:
946518b7 8%bcond_without inotify # without inotify support
0d2f2c46 9%if "%{pld_release}" == "ac"
2bd551be
ER
10%bcond_with selinux # with SELinux support
11%bcond_with audit # with audit support
0d2f2c46
ER
12%else
13%bcond_without selinux # without SELinux support
828712ad 14%bcond_without audit # without audit support
701f4590
ER
15%endif
16
9088c091
AM
17Summary: Cron daemon for executing programs at set times
18Name: cronie
6f54bc3d 19Version: 1.4.9
5b4e8f01 20Release: 2
fd39f74d 21License: MIT and BSD and GPL v2
9088c091 22Group: Daemons
fd39f74d 23Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
6f54bc3d 24# Source0-md5: 9133195e5e6f824ef460f5ccc533f1b7
9088c091
AM
25Source1: %{name}.init
26Source2: cron.logrotate
27Source3: cron.sysconfig
28Source4: %{name}.crontab
29Source5: %{name}.pam
bb090c53 30Source6: %{name}.upstart
6dd99ede 31Source7: crond.service
f440f0d0 32Patch0: inotify-nosys.patch
6f54bc3d 33Patch1: sendmail-path.patch
9088c091 34URL: https://fedorahosted.org/cronie/
828712ad
ER
35%{?with_audit:BuildRequires: audit-libs-devel}
36BuildRequires: autoconf
37BuildRequires: automake
9088c091
AM
38%{?with_selinux:BuildRequires: libselinux-devel}
39BuildRequires: pam-devel
0d2f2c46 40BuildRequires: rpm >= 4.4.9-56
cd632288 41BuildRequires: rpmbuild(macros) >= 1.647
9088c091
AM
42Requires(post): fileutils
43Requires(post,preun): /sbin/chkconfig
9088c091
AM
44Requires(postun): /usr/sbin/groupdel
45Requires(pre): /usr/bin/getgid
46Requires(pre): /usr/sbin/groupadd
47Requires: /bin/run-parts
9088c091 48Requires: psmisc >= 20.1
bb090c53 49Requires: rc-scripts >= 0.4.3.0
6f54bc3d 50%if "%{pld_release}" != "ac"
1580d998
JR
51Requires(post,preun,postun): systemd-units >= 38
52Requires: systemd-units >= 38}
cd632288 53%endif
f440f0d0 54%{?with_inotify:Requires: uname(release) >= 2.6.13}
9088c091
AM
55Provides: crondaemon
56Provides: crontabs = 1.7
57Provides: group(crontab)
0d2f2c46 58%if "%{pld_release}" == "th"
bf8f51cd 59Provides: vixie-cron = 4.3-1
daf76cdc 60%endif
9088c091 61Obsoletes: crondaemon
f497321d 62Obsoletes: cronie-systemd
9088c091 63Obsoletes: crontabs
0d2f2c46 64%if "%{pld_release}" == "th"
bf8f51cd 65Obsoletes: vixie-cron < 4.3-1
daf76cdc 66%endif
9088c091
AM
67BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69%description
84a870a4
AM
70Cronie contains the standard UNIX daemon crond that runs specified
71programs at scheduled times and related tools. It is based on the
72original cron and has security and configuration enhancements like the
73ability to use pam and SELinux.
9088c091
AM
74
75%package anacron
84a870a4
AM
76Summary: Utility for running regular jobs
77Group: Base
78Provides: anacron = 2.4
79Obsoletes: anacron <= 2.3
9088c091
AM
80
81%description anacron
84a870a4
AM
82Anacron becames part of cronie. Anacron is used only for running
83regular jobs. The default settings execute regular jobs by anacron,
84however this could be overloaded in settings.
9088c091 85
bb090c53
JK
86%package upstart
87Summary: Upstart job description for Cronie
88Summary(pl.UTF-8): Opis zadania Upstart dla Cronie
89Group: Daemons
90Requires: %{name} = %{version}-%{release}
91Requires: upstart >= 0.6
92
93%description upstart
94Upstart job description for Cronie.
95
96%description upstart -l pl.UTF-8
97Opis zadania Upstart dla Cronie.
98
9088c091
AM
99%prep
100%setup -q
f440f0d0 101%patch0 -p1
9c2aa177 102%patch1 -p1
9088c091
AM
103
104%build
828712ad
ER
105%{__aclocal}
106%{__autoconf}
107%{__autoheader}
108%{__automake}
9088c091 109%configure \
d39ca4fd 110 SYSCRONTAB=/etc/crontab \
695ed2ed 111 SYS_CROND_DIR=/etc/cron.d \
72768a3d 112 --sysconfdir=/etc/cron \
9088c091 113 --with-pam \
45b0067d 114 --with%{!?with_selinux:out}-selinux \
828712ad 115 --with%{!?with_audit:out}-audit \
946518b7 116 --with%{!?with_inotify:out}-inotify \
6f54bc3d 117 --without-syscrontab \
a66962af 118%if "%{cc_version}" >= "3.4"
5ab1b510 119 --enable-pie \
a66962af 120%endif
5ab1b510 121 --enable-relro \
9088c091
AM
122 --enable-anacron
123
124%{__make}
125
126%install
127rm -rf $RPM_BUILD_ROOT
acc567ec 128install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitdir}}\
bb090c53 129 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
9088c091
AM
130 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
131
132%{__make} install \
0d2f2c46 133 pamdir=/etc/pam.d \
9088c091
AM
134 DESTDIR=$RPM_BUILD_ROOT
135
5b4e8f01
AZ
136cp -p %{SOURCE5} crond.pam
137
138%if %{without audit}
139# remove recording user's login uid to the process attribute
140%{__sed} -i -e '/pam_loginuid.so/d' crond.pam
141%endif
142
fd39f74d
ER
143install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
144cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
145cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
146cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
147cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
5b4e8f01 148cp -a crond.pam $RPM_BUILD_ROOT/etc/pam.d/crond
bb090c53 149cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
fdd909fe 150cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
9088c091
AM
151
152touch $RPM_BUILD_ROOT/var/log/cron
153
154cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
155# cron.allow This file describes the names of the users which are
156# allowed to use the local cron daemon
157root
158EOF
159
160cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
161# cron.deny This file describes the names of the users which are
162# NOT allowed to use the local cron daemon
163EOF
164
165%clean
166rm -rf $RPM_BUILD_ROOT
167
168%pre
169%groupadd -g 117 -r -f crontab
170
171%post
fd39f74d 172if [ ! -f /var/log/cron ]; then
7ff8f944 173 install -m 660 -g crontab /dev/null /var/log/cron
fd39f74d 174fi
9088c091 175/sbin/chkconfig --add crond
9088c091 176%service crond restart "Cron Daemon"
fdd909fe 177%systemd_post crond.service
9088c091
AM
178
179%preun
180if [ "$1" = "0" ]; then
181 %service crond stop
182 /sbin/chkconfig --del crond
183fi
fdd909fe 184%systemd_preun crond.service
9088c091
AM
185
186%postun
187if [ "$1" = "0" ]; then
188 %groupremove crontab
189fi
38b3aba9
JR
190%systemd_reload
191
ac14407c 192%triggerpostun -- cronie < 1.4.8-13
0a59c82c
JR
193if [ -f /etc/sysconfig/cron ]; then
194 . /etc/sysconfig/cron
195 __CROND_ARGS=
196 [ "$CROND_SYSLOG_RESULT" = "yes" ] && __CROND_ARGS="-s"
197 [ -n "$CROND_MAIL_PROG" ] && __CROND_ARGS="$__CROND_ARGS -m $CROND_MAIL_PROG"
ac14407c 198 if [ -n "$__CROND_ARGS" ]; then
8455c8ac 199 %{__cp} -f /etc/sysconfig/cron{,.rpmsave}
ac14407c
JR
200 echo >>/etc/sysconfig/cron
201 echo "# Added by rpm trigger" >>/etc/sysconfig/cron
202 echo "CROND_ARGS=\"$CROND_ARGS $__CROND_ARGS\"" >>/etc/sysconfig/cron
203 fi
0a59c82c 204fi
fdd909fe 205%systemd_trigger crond.service
9088c091 206
dd40ae0a 207%triggerun -- hc-cron,fcron,vixie-cron < 4.3-1
77af6cfd
AM
208# Prevent preun from crond from working
209chmod a-x /etc/rc.d/init.d/crond
210
dd40ae0a 211%triggerpostun -- hc-cron,fcron,vixie-cron < 4.3-1
77af6cfd
AM
212# Restore what triggerun removed
213chmod 754 /etc/rc.d/init.d/crond
8609ee66
ER
214# reinstall crond init.d links, which could be different
215/sbin/chkconfig --del crond
77af6cfd
AM
216/sbin/chkconfig --add crond
217
bb090c53
JK
218%post upstart
219%upstart_post crond
220
221%postun upstart
222%upstart_postun crond
223
9088c091
AM
224%files
225%defattr(644,root,root,755)
226%doc AUTHORS ChangeLog README
227%attr(750,root,crontab) %dir %{_sysconfdir}/cron*
228%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
229%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
230%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
231%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
232%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
233%attr(754,root,root) /etc/rc.d/init.d/crond
234%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
cd632288 235%{systemdunitdir}/crond.service
9088c091
AM
236%attr(755,root,root) %{_sbindir}/crond
237%attr(2755,root,crontab) %{_bindir}/crontab
238
239%{_mandir}/man8/crond.8*
240%{_mandir}/man8/cron.8*
241%{_mandir}/man5/crontab.5*
242%{_mandir}/man1/crontab.1*
243
244%attr(1730,root,crontab) /var/spool/cron
245%attr(660,root,crontab) %ghost /var/log/cron
246
247%files anacron
248%defattr(644,root,root,755)
249%attr(755,root,root) %{_sbindir}/anacron
84a870a4 250%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
9088c091
AM
251%{_mandir}/man5/anacrontab.5*
252%{_mandir}/man8/anacron.8*
d07a95b8
AM
253
254%attr(1730,root,crontab) /var/spool/anacron
bb090c53 255
2bd551be 256%if "%{pld_release}" == "th"
bb090c53
JK
257%files upstart
258%defattr(644,root,root,755)
259%config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
c69c0f5a 260%endif
This page took 0.097432 seconds and 4 git commands to generate.