]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
- use newer systemd macros
[packages/cronie.git] / cronie.spec
CommitLineData
955f0d7d
ER
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
64e4eafc
ER
4# - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5# Mar 3 09:30:01 ravenous CROND[2528]: 4ÿ
9088c091
AM
6#
7# Conditional build:
946518b7 8%bcond_without inotify # without inotify support
0d2f2c46
ER
9%if "%{pld_release}" == "ac"
10%bcond_with selinux # without SELinux support
11%bcond_with audit # without audit support
12%else
13%bcond_without selinux # without SELinux support
828712ad 14%bcond_without audit # without audit support
0d2f2c46
ER
15%endif
16
9088c091
AM
17Summary: Cron daemon for executing programs at set times
18Name: cronie
eb52456a 19Version: 1.4.8
526108d0 20Release: 8
fd39f74d 21License: MIT and BSD and GPL v2
9088c091 22Group: Daemons
fd39f74d 23Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
eb52456a 24# Source0-md5: 9b1d2ce6db8d1883e06635f437170657
9088c091
AM
25Source1: %{name}.init
26Source2: cron.logrotate
27Source3: cron.sysconfig
28Source4: %{name}.crontab
29Source5: %{name}.pam
bb090c53 30Source6: %{name}.upstart
6dd99ede 31Source7: crond.service
f440f0d0 32Patch0: inotify-nosys.patch
9c2aa177 33Patch1: %{name}-nosyscrontab.patch
cb620710 34Patch2: sendmail-path.patch
9088c091 35URL: https://fedorahosted.org/cronie/
828712ad
ER
36%{?with_audit:BuildRequires: audit-libs-devel}
37BuildRequires: autoconf
38BuildRequires: automake
9088c091
AM
39%{?with_selinux:BuildRequires: libselinux-devel}
40BuildRequires: pam-devel
0d2f2c46 41BuildRequires: rpm >= 4.4.9-56
526108d0 42BuildRequires: rpmbuild(macros) >= 1.626
9088c091
AM
43Requires(post): fileutils
44Requires(post,preun): /sbin/chkconfig
9088c091
AM
45Requires(postun): /usr/sbin/groupdel
46Requires(pre): /usr/bin/getgid
47Requires(pre): /usr/sbin/groupadd
48Requires: /bin/run-parts
9088c091 49Requires: psmisc >= 20.1
bb090c53 50Requires: rc-scripts >= 0.4.3.0
f440f0d0 51%{?with_inotify:Requires: uname(release) >= 2.6.13}
9088c091
AM
52Provides: crondaemon
53Provides: crontabs = 1.7
54Provides: group(crontab)
0d2f2c46 55%if "%{pld_release}" == "th"
bf8f51cd 56Provides: vixie-cron = 4.3-1
daf76cdc 57%endif
9088c091
AM
58Obsoletes: crondaemon
59Obsoletes: crontabs
0d2f2c46 60%if "%{pld_release}" == "th"
bf8f51cd 61Obsoletes: vixie-cron < 4.3-1
daf76cdc 62%endif
9088c091
AM
63BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65%description
84a870a4
AM
66Cronie contains the standard UNIX daemon crond that runs specified
67programs at scheduled times and related tools. It is based on the
68original cron and has security and configuration enhancements like the
69ability to use pam and SELinux.
9088c091
AM
70
71%package anacron
84a870a4
AM
72Summary: Utility for running regular jobs
73Group: Base
74Provides: anacron = 2.4
75Obsoletes: anacron <= 2.3
9088c091
AM
76
77%description anacron
84a870a4
AM
78Anacron becames part of cronie. Anacron is used only for running
79regular jobs. The default settings execute regular jobs by anacron,
80however this could be overloaded in settings.
9088c091 81
bb090c53
JK
82%package upstart
83Summary: Upstart job description for Cronie
84Summary(pl.UTF-8): Opis zadania Upstart dla Cronie
85Group: Daemons
86Requires: %{name} = %{version}-%{release}
87Requires: upstart >= 0.6
88
89%description upstart
90Upstart job description for Cronie.
91
92%description upstart -l pl.UTF-8
93Opis zadania Upstart dla Cronie.
94
6dd99ede
BZ
95%package systemd
96Summary: systemd units for cronie
97Group: Base
98Requires: %{name} = %{version}-%{release}
a081c7fe 99Requires: systemd-units >= 37-0.10
6dd99ede
BZ
100
101%description systemd
102systemd units for cronie.
103
9088c091
AM
104%prep
105%setup -q
f440f0d0 106%patch0 -p1
9c2aa177 107%patch1 -p1
cb620710 108%patch2 -p1
9088c091
AM
109
110%build
828712ad
ER
111%{__aclocal}
112%{__autoconf}
113%{__autoheader}
114%{__automake}
9088c091 115%configure \
d39ca4fd 116 SYSCRONTAB=/etc/crontab \
695ed2ed 117 SYS_CROND_DIR=/etc/cron.d \
72768a3d 118 --sysconfdir=/etc/cron \
9088c091 119 --with-pam \
45b0067d 120 --with%{!?with_selinux:out}-selinux \
828712ad 121 --with%{!?with_audit:out}-audit \
946518b7 122 --with%{!?with_inotify:out}-inotify \
5ab1b510
ER
123 --enable-pie \
124 --enable-relro \
9088c091
AM
125 --enable-anacron
126
127%{__make}
128
129%install
130rm -rf $RPM_BUILD_ROOT
6dd99ede 131install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},/lib/systemd/system}\
bb090c53 132 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
9088c091
AM
133 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
134
135%{__make} install \
0d2f2c46 136 pamdir=/etc/pam.d \
9088c091
AM
137 DESTDIR=$RPM_BUILD_ROOT
138
fd39f74d
ER
139install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
140cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
141cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
142cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
143cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
144cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
bb090c53 145cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
9f1f3414
AF
146cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/cronie.service
147ln -s cronie.service $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
9088c091
AM
148
149touch $RPM_BUILD_ROOT/var/log/cron
150
151cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
152# cron.allow This file describes the names of the users which are
153# allowed to use the local cron daemon
154root
155EOF
156
157cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
158# cron.deny This file describes the names of the users which are
159# NOT allowed to use the local cron daemon
160EOF
161
162%clean
163rm -rf $RPM_BUILD_ROOT
164
165%pre
166%groupadd -g 117 -r -f crontab
167
168%post
fd39f74d 169if [ ! -f /var/log/cron ]; then
7ff8f944 170 install -m 660 -g crontab /dev/null /var/log/cron
fd39f74d 171fi
9088c091 172/sbin/chkconfig --add crond
9088c091
AM
173%service crond restart "Cron Daemon"
174
175%preun
176if [ "$1" = "0" ]; then
177 %service crond stop
178 /sbin/chkconfig --del crond
179fi
180
181%postun
182if [ "$1" = "0" ]; then
183 %groupremove crontab
184fi
185
8609ee66 186%triggerun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
187# Prevent preun from crond from working
188chmod a-x /etc/rc.d/init.d/crond
189
8609ee66 190%triggerpostun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
191# Restore what triggerun removed
192chmod 754 /etc/rc.d/init.d/crond
8609ee66
ER
193# reinstall crond init.d links, which could be different
194/sbin/chkconfig --del crond
77af6cfd
AM
195/sbin/chkconfig --add crond
196
bb090c53
JK
197%post upstart
198%upstart_post crond
199
200%postun upstart
201%upstart_postun crond
202
9f1f3414 203%post systemd
526108d0 204%systemd_post cronie.service
9f1f3414
AF
205
206%preun systemd
8cfdbf87 207%systemd_preun cronie.service
9f1f3414
AF
208
209%postun systemd
526108d0 210%systemd_reload
9f1f3414 211
9088c091
AM
212%files
213%defattr(644,root,root,755)
214%doc AUTHORS ChangeLog README
215%attr(750,root,crontab) %dir %{_sysconfdir}/cron*
216%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
217%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
218%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
219%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
220%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
221%attr(754,root,root) /etc/rc.d/init.d/crond
222%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
223%attr(755,root,root) %{_sbindir}/crond
224%attr(2755,root,crontab) %{_bindir}/crontab
225
226%{_mandir}/man8/crond.8*
227%{_mandir}/man8/cron.8*
228%{_mandir}/man5/crontab.5*
229%{_mandir}/man1/crontab.1*
230
231%attr(1730,root,crontab) /var/spool/cron
232%attr(660,root,crontab) %ghost /var/log/cron
233
234%files anacron
235%defattr(644,root,root,755)
236%attr(755,root,root) %{_sbindir}/anacron
84a870a4 237%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
9088c091
AM
238%{_mandir}/man5/anacrontab.5*
239%{_mandir}/man8/anacron.8*
d07a95b8
AM
240
241%attr(1730,root,crontab) /var/spool/anacron
bb090c53 242
c69c0f5a 243%if "%{pld_release}" != "ti"
bb090c53
JK
244%files upstart
245%defattr(644,root,root,755)
246%config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
c69c0f5a 247%endif
6dd99ede
BZ
248
249%files systemd
250%defattr(644,root,root,755)
9f1f3414
AF
251%{systemdunitdir}/crond.service
252%{systemdunitdir}/cronie.service
This page took 0.062431 seconds and 4 git commands to generate.