]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
- rel 9
[packages/cronie.git] / cronie.spec
CommitLineData
955f0d7d
ER
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
64e4eafc
ER
4# - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5# Mar 3 09:30:01 ravenous CROND[2528]: 4ÿ
9088c091
AM
6#
7# Conditional build:
946518b7 8%bcond_without inotify # without inotify support
0d2f2c46
ER
9%if "%{pld_release}" == "ac"
10%bcond_with selinux # without SELinux support
11%bcond_with audit # without audit support
12%else
13%bcond_without selinux # without SELinux support
828712ad 14%bcond_without audit # without audit support
0d2f2c46
ER
15%endif
16
9088c091
AM
17Summary: Cron daemon for executing programs at set times
18Name: cronie
eb52456a 19Version: 1.4.8
38b3aba9 20Release: 9
fd39f74d 21License: MIT and BSD and GPL v2
9088c091 22Group: Daemons
fd39f74d 23Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
eb52456a 24# Source0-md5: 9b1d2ce6db8d1883e06635f437170657
9088c091
AM
25Source1: %{name}.init
26Source2: cron.logrotate
27Source3: cron.sysconfig
28Source4: %{name}.crontab
29Source5: %{name}.pam
bb090c53 30Source6: %{name}.upstart
6dd99ede 31Source7: crond.service
f440f0d0 32Patch0: inotify-nosys.patch
9c2aa177 33Patch1: %{name}-nosyscrontab.patch
cb620710 34Patch2: sendmail-path.patch
9088c091 35URL: https://fedorahosted.org/cronie/
828712ad
ER
36%{?with_audit:BuildRequires: audit-libs-devel}
37BuildRequires: autoconf
38BuildRequires: automake
9088c091
AM
39%{?with_selinux:BuildRequires: libselinux-devel}
40BuildRequires: pam-devel
0d2f2c46 41BuildRequires: rpm >= 4.4.9-56
526108d0 42BuildRequires: rpmbuild(macros) >= 1.626
9088c091
AM
43Requires(post): fileutils
44Requires(post,preun): /sbin/chkconfig
9088c091
AM
45Requires(postun): /usr/sbin/groupdel
46Requires(pre): /usr/bin/getgid
47Requires(pre): /usr/sbin/groupadd
48Requires: /bin/run-parts
9088c091 49Requires: psmisc >= 20.1
bb090c53 50Requires: rc-scripts >= 0.4.3.0
38b3aba9 51Requires: systemd-units >= 37-0.10
f440f0d0 52%{?with_inotify:Requires: uname(release) >= 2.6.13}
9088c091
AM
53Provides: crondaemon
54Provides: crontabs = 1.7
55Provides: group(crontab)
0d2f2c46 56%if "%{pld_release}" == "th"
bf8f51cd 57Provides: vixie-cron = 4.3-1
daf76cdc 58%endif
9088c091
AM
59Obsoletes: crondaemon
60Obsoletes: crontabs
0d2f2c46 61%if "%{pld_release}" == "th"
bf8f51cd 62Obsoletes: vixie-cron < 4.3-1
daf76cdc 63%endif
9088c091
AM
64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66%description
84a870a4
AM
67Cronie contains the standard UNIX daemon crond that runs specified
68programs at scheduled times and related tools. It is based on the
69original cron and has security and configuration enhancements like the
70ability to use pam and SELinux.
9088c091
AM
71
72%package anacron
84a870a4
AM
73Summary: Utility for running regular jobs
74Group: Base
75Provides: anacron = 2.4
76Obsoletes: anacron <= 2.3
9088c091
AM
77
78%description anacron
84a870a4
AM
79Anacron becames part of cronie. Anacron is used only for running
80regular jobs. The default settings execute regular jobs by anacron,
81however this could be overloaded in settings.
9088c091 82
bb090c53
JK
83%package upstart
84Summary: Upstart job description for Cronie
85Summary(pl.UTF-8): Opis zadania Upstart dla Cronie
86Group: Daemons
87Requires: %{name} = %{version}-%{release}
88Requires: upstart >= 0.6
89
90%description upstart
91Upstart job description for Cronie.
92
93%description upstart -l pl.UTF-8
94Opis zadania Upstart dla Cronie.
95
9088c091
AM
96%prep
97%setup -q
f440f0d0 98%patch0 -p1
9c2aa177 99%patch1 -p1
cb620710 100%patch2 -p1
9088c091
AM
101
102%build
828712ad
ER
103%{__aclocal}
104%{__autoconf}
105%{__autoheader}
106%{__automake}
9088c091 107%configure \
d39ca4fd 108 SYSCRONTAB=/etc/crontab \
695ed2ed 109 SYS_CROND_DIR=/etc/cron.d \
72768a3d 110 --sysconfdir=/etc/cron \
9088c091 111 --with-pam \
45b0067d 112 --with%{!?with_selinux:out}-selinux \
828712ad 113 --with%{!?with_audit:out}-audit \
946518b7 114 --with%{!?with_inotify:out}-inotify \
5ab1b510
ER
115 --enable-pie \
116 --enable-relro \
9088c091
AM
117 --enable-anacron
118
119%{__make}
120
121%install
122rm -rf $RPM_BUILD_ROOT
acc567ec 123install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitdir}}\
bb090c53 124 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
9088c091
AM
125 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
126
127%{__make} install \
0d2f2c46 128 pamdir=/etc/pam.d \
9088c091
AM
129 DESTDIR=$RPM_BUILD_ROOT
130
fd39f74d
ER
131install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
132cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
133cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
134cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
135cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
136cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
bb090c53 137cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
9f1f3414
AF
138cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/cronie.service
139ln -s cronie.service $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
9088c091
AM
140
141touch $RPM_BUILD_ROOT/var/log/cron
142
143cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
144# cron.allow This file describes the names of the users which are
145# allowed to use the local cron daemon
146root
147EOF
148
149cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
150# cron.deny This file describes the names of the users which are
151# NOT allowed to use the local cron daemon
152EOF
153
154%clean
155rm -rf $RPM_BUILD_ROOT
156
157%pre
158%groupadd -g 117 -r -f crontab
159
160%post
fd39f74d 161if [ ! -f /var/log/cron ]; then
7ff8f944 162 install -m 660 -g crontab /dev/null /var/log/cron
fd39f74d 163fi
9088c091 164/sbin/chkconfig --add crond
9088c091 165%service crond restart "Cron Daemon"
38b3aba9 166%systemd_post cronie.service
9088c091
AM
167
168%preun
169if [ "$1" = "0" ]; then
170 %service crond stop
171 /sbin/chkconfig --del crond
172fi
38b3aba9 173%systemd_preun cronie.service
9088c091
AM
174
175%postun
176if [ "$1" = "0" ]; then
177 %groupremove crontab
178fi
38b3aba9
JR
179%systemd_reload
180
181%triggerpostun -- cronie < 1.4.8-9
182%systemd_trigger cronie.service
9088c091 183
8609ee66 184%triggerun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
185# Prevent preun from crond from working
186chmod a-x /etc/rc.d/init.d/crond
187
8609ee66 188%triggerpostun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
189# Restore what triggerun removed
190chmod 754 /etc/rc.d/init.d/crond
8609ee66
ER
191# reinstall crond init.d links, which could be different
192/sbin/chkconfig --del crond
77af6cfd
AM
193/sbin/chkconfig --add crond
194
bb090c53
JK
195%post upstart
196%upstart_post crond
197
198%postun upstart
199%upstart_postun crond
200
9088c091
AM
201%files
202%defattr(644,root,root,755)
203%doc AUTHORS ChangeLog README
204%attr(750,root,crontab) %dir %{_sysconfdir}/cron*
205%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
206%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
207%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
208%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
209%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
210%attr(754,root,root) /etc/rc.d/init.d/crond
211%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
38b3aba9
JR
212%{systemdunitdir}/crond.service
213%{systemdunitdir}/cronie.service
9088c091
AM
214%attr(755,root,root) %{_sbindir}/crond
215%attr(2755,root,crontab) %{_bindir}/crontab
216
217%{_mandir}/man8/crond.8*
218%{_mandir}/man8/cron.8*
219%{_mandir}/man5/crontab.5*
220%{_mandir}/man1/crontab.1*
221
222%attr(1730,root,crontab) /var/spool/cron
223%attr(660,root,crontab) %ghost /var/log/cron
224
225%files anacron
226%defattr(644,root,root,755)
227%attr(755,root,root) %{_sbindir}/anacron
84a870a4 228%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
9088c091
AM
229%{_mandir}/man5/anacrontab.5*
230%{_mandir}/man8/anacron.8*
d07a95b8
AM
231
232%attr(1730,root,crontab) /var/spool/anacron
bb090c53 233
c69c0f5a 234%if "%{pld_release}" != "ti"
bb090c53
JK
235%files upstart
236%defattr(644,root,root,755)
237%config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
c69c0f5a 238%endif
This page took 0.102926 seconds and 4 git commands to generate.