]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
The execvpe() function first appeared in glibc 2.11.
[packages/cronie.git] / cronie.spec
CommitLineData
955f0d7d
ER
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
64e4eafc
ER
4# - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5# Mar 3 09:30:01 ravenous CROND[2528]: 4ÿ
9088c091
AM
6#
7# Conditional build:
946518b7 8%bcond_without inotify # without inotify support
0d2f2c46 9%if "%{pld_release}" == "ac"
2bd551be
ER
10%bcond_with selinux # with SELinux support
11%bcond_with audit # with audit support
0d2f2c46
ER
12%else
13%bcond_without selinux # without SELinux support
828712ad 14%bcond_without audit # without audit support
701f4590
ER
15%endif
16
9088c091
AM
17Summary: Cron daemon for executing programs at set times
18Name: cronie
ced4ed8f 19Version: 1.5.0
f0baf4fa 20Release: 2
fd39f74d 21License: MIT and BSD and GPL v2
9088c091 22Group: Daemons
fd39f74d 23Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
ced4ed8f 24# Source0-md5: 9db75e1884d83a45e002d145c6c54d45
9088c091 25Source1: %{name}.init
9088c091
AM
26Source3: cron.sysconfig
27Source4: %{name}.crontab
28Source5: %{name}.pam
4b896003 29Source6: crond.service
f440f0d0 30Patch0: inotify-nosys.patch
6f54bc3d 31Patch1: sendmail-path.patch
9088c091 32URL: https://fedorahosted.org/cronie/
828712ad
ER
33%{?with_audit:BuildRequires: audit-libs-devel}
34BuildRequires: autoconf
35BuildRequires: automake
24c321ed 36BuildRequires: glibc-devel >= 6:2.21
9088c091
AM
37%{?with_selinux:BuildRequires: libselinux-devel}
38BuildRequires: pam-devel
0d2f2c46 39BuildRequires: rpm >= 4.4.9-56
cd632288 40BuildRequires: rpmbuild(macros) >= 1.647
9088c091
AM
41Requires(post): fileutils
42Requires(post,preun): /sbin/chkconfig
9088c091
AM
43Requires(postun): /usr/sbin/groupdel
44Requires(pre): /usr/bin/getgid
45Requires(pre): /usr/sbin/groupadd
46Requires: /bin/run-parts
9088c091 47Requires: psmisc >= 20.1
bb090c53 48Requires: rc-scripts >= 0.4.3.0
6f54bc3d 49%if "%{pld_release}" != "ac"
1580d998
JR
50Requires(post,preun,postun): systemd-units >= 38
51Requires: systemd-units >= 38}
cd632288 52%endif
f440f0d0 53%{?with_inotify:Requires: uname(release) >= 2.6.13}
9088c091
AM
54Provides: crondaemon
55Provides: crontabs = 1.7
56Provides: group(crontab)
0d2f2c46 57%if "%{pld_release}" == "th"
bf8f51cd 58Provides: vixie-cron = 4.3-1
daf76cdc 59%endif
9088c091 60Obsoletes: crondaemon
f497321d 61Obsoletes: cronie-systemd
9088c091 62Obsoletes: crontabs
0d2f2c46 63%if "%{pld_release}" == "th"
bf8f51cd 64Obsoletes: vixie-cron < 4.3-1
daf76cdc 65%endif
9088c091
AM
66BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68%description
84a870a4
AM
69Cronie contains the standard UNIX daemon crond that runs specified
70programs at scheduled times and related tools. It is based on the
71original cron and has security and configuration enhancements like the
72ability to use pam and SELinux.
9088c091
AM
73
74%package anacron
84a870a4
AM
75Summary: Utility for running regular jobs
76Group: Base
77Provides: anacron = 2.4
78Obsoletes: anacron <= 2.3
9088c091
AM
79
80%description anacron
84a870a4
AM
81Anacron becames part of cronie. Anacron is used only for running
82regular jobs. The default settings execute regular jobs by anacron,
83however this could be overloaded in settings.
9088c091
AM
84
85%prep
86%setup -q
f440f0d0 87%patch0 -p1
9c2aa177 88%patch1 -p1
9088c091
AM
89
90%build
828712ad
ER
91%{__aclocal}
92%{__autoconf}
93%{__autoheader}
94%{__automake}
9088c091 95%configure \
d39ca4fd 96 SYSCRONTAB=/etc/crontab \
695ed2ed 97 SYS_CROND_DIR=/etc/cron.d \
72768a3d 98 --sysconfdir=/etc/cron \
cf04dab5 99 --with-editor=/bin/vi \
9088c091 100 --with-pam \
45b0067d 101 --with%{!?with_selinux:out}-selinux \
828712ad 102 --with%{!?with_audit:out}-audit \
946518b7 103 --with%{!?with_inotify:out}-inotify \
5769fa92 104 --disable-syscrontab \
a66962af 105%if "%{cc_version}" >= "3.4"
5ab1b510 106 --enable-pie \
a66962af 107%endif
5ab1b510 108 --enable-relro \
9088c091
AM
109 --enable-anacron
110
111%{__make}
112
113%install
114rm -rf $RPM_BUILD_ROOT
acc567ec 115install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitdir}}\
4b896003 116 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
9088c091
AM
117 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
118
119%{__make} install \
0d2f2c46 120 pamdir=/etc/pam.d \
9088c091
AM
121 DESTDIR=$RPM_BUILD_ROOT
122
5b4e8f01
AZ
123cp -p %{SOURCE5} crond.pam
124
125%if %{without audit}
126# remove recording user's login uid to the process attribute
127%{__sed} -i -e '/pam_loginuid.so/d' crond.pam
128%endif
129
fd39f74d
ER
130install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
131cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
e2d97fc3 132cp -a contrib/anacrontab $RPM_BUILD_ROOT/etc/cron/anacrontab
fd39f74d
ER
133cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
134cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
5b4e8f01 135cp -a crond.pam $RPM_BUILD_ROOT/etc/pam.d/crond
4b896003 136cp -a %{SOURCE6} $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
9088c091 137
9088c091
AM
138cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
139# cron.allow This file describes the names of the users which are
140# allowed to use the local cron daemon
141root
142EOF
143
144cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
145# cron.deny This file describes the names of the users which are
146# NOT allowed to use the local cron daemon
147EOF
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%pre
153%groupadd -g 117 -r -f crontab
154
155%post
156/sbin/chkconfig --add crond
9088c091 157%service crond restart "Cron Daemon"
fdd909fe 158%systemd_post crond.service
9088c091
AM
159
160%preun
161if [ "$1" = "0" ]; then
162 %service crond stop
163 /sbin/chkconfig --del crond
164fi
fdd909fe 165%systemd_preun crond.service
9088c091
AM
166
167%postun
168if [ "$1" = "0" ]; then
169 %groupremove crontab
170fi
38b3aba9
JR
171%systemd_reload
172
ac14407c 173%triggerpostun -- cronie < 1.4.8-13
0a59c82c
JR
174if [ -f /etc/sysconfig/cron ]; then
175 . /etc/sysconfig/cron
176 __CROND_ARGS=
177 [ "$CROND_SYSLOG_RESULT" = "yes" ] && __CROND_ARGS="-s"
178 [ -n "$CROND_MAIL_PROG" ] && __CROND_ARGS="$__CROND_ARGS -m $CROND_MAIL_PROG"
ac14407c 179 if [ -n "$__CROND_ARGS" ]; then
8455c8ac 180 %{__cp} -f /etc/sysconfig/cron{,.rpmsave}
ac14407c
JR
181 echo >>/etc/sysconfig/cron
182 echo "# Added by rpm trigger" >>/etc/sysconfig/cron
183 echo "CROND_ARGS=\"$CROND_ARGS $__CROND_ARGS\"" >>/etc/sysconfig/cron
184 fi
0a59c82c 185fi
fdd909fe 186%systemd_trigger crond.service
9088c091 187
dd40ae0a 188%triggerun -- hc-cron,fcron,vixie-cron < 4.3-1
77af6cfd
AM
189# Prevent preun from crond from working
190chmod a-x /etc/rc.d/init.d/crond
191
dd40ae0a 192%triggerpostun -- hc-cron,fcron,vixie-cron < 4.3-1
77af6cfd
AM
193# Restore what triggerun removed
194chmod 754 /etc/rc.d/init.d/crond
8609ee66
ER
195# reinstall crond init.d links, which could be different
196/sbin/chkconfig --del crond
77af6cfd
AM
197/sbin/chkconfig --add crond
198
9088c091
AM
199%files
200%defattr(644,root,root,755)
201%doc AUTHORS ChangeLog README
bbfcd712
JK
202%attr(750,root,crontab) %dir /etc/cron
203%attr(750,root,crontab) %dir /etc/cron.daily
204%attr(750,root,crontab) %dir /etc/cron.hourly
205%attr(750,root,crontab) %dir /etc/cron.monthly
206%attr(750,root,crontab) %dir /etc/cron.weekly
9088c091
AM
207%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
208%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
209%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
210%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
211%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
212%attr(754,root,root) /etc/rc.d/init.d/crond
cd632288 213%{systemdunitdir}/crond.service
9088c091
AM
214%attr(755,root,root) %{_sbindir}/crond
215%attr(2755,root,crontab) %{_bindir}/crontab
216
217%{_mandir}/man8/crond.8*
218%{_mandir}/man8/cron.8*
219%{_mandir}/man5/crontab.5*
220%{_mandir}/man1/crontab.1*
221
222%attr(1730,root,crontab) /var/spool/cron
9088c091
AM
223
224%files anacron
225%defattr(644,root,root,755)
226%attr(755,root,root) %{_sbindir}/anacron
84a870a4 227%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
e2d97fc3 228%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) /etc/cron/anacrontab
9088c091
AM
229%{_mandir}/man5/anacrontab.5*
230%{_mandir}/man8/anacron.8*
d07a95b8
AM
231
232%attr(1730,root,crontab) /var/spool/anacron
This page took 0.099261 seconds and 4 git commands to generate.