]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
- release 2
[packages/cronie.git] / cronie.spec
CommitLineData
955f0d7d
ER
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
9088c091
AM
4#
5# Conditional build:
946518b7 6%bcond_without inotify # without inotify support
0d2f2c46
ER
7%if "%{pld_release}" == "ac"
8%bcond_with selinux # without SELinux support
9%bcond_with audit # without audit support
10%else
11%bcond_without selinux # without SELinux support
828712ad 12%bcond_without audit # without audit support
0d2f2c46
ER
13%endif
14
9088c091
AM
15Summary: Cron daemon for executing programs at set times
16Name: cronie
1420eb5f 17Version: 1.4.4
0f61a7cf 18Release: 2
fd39f74d 19License: MIT and BSD and GPL v2
9088c091 20Group: Daemons
fd39f74d 21Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
1420eb5f 22# Source0-md5: eb9834c5f87cca9efeed68e6fed3fe3d
9088c091
AM
23Source1: %{name}.init
24Source2: cron.logrotate
25Source3: cron.sysconfig
26Source4: %{name}.crontab
27Source5: %{name}.pam
f440f0d0 28Patch0: inotify-nosys.patch
9c2aa177 29Patch1: %{name}-nosyscrontab.patch
cb620710 30Patch2: sendmail-path.patch
9088c091 31URL: https://fedorahosted.org/cronie/
828712ad
ER
32%{?with_audit:BuildRequires: audit-libs-devel}
33BuildRequires: autoconf
34BuildRequires: automake
9088c091
AM
35%{?with_selinux:BuildRequires: libselinux-devel}
36BuildRequires: pam-devel
0d2f2c46 37BuildRequires: rpm >= 4.4.9-56
9088c091
AM
38BuildRequires: rpmbuild(macros) >= 1.268
39Requires(post): fileutils
40Requires(post,preun): /sbin/chkconfig
9088c091
AM
41Requires(postun): /usr/sbin/groupdel
42Requires(pre): /usr/bin/getgid
43Requires(pre): /usr/sbin/groupadd
44Requires: /bin/run-parts
45Requires: /sbin/chkconfig
46Requires: psmisc >= 20.1
8f55a4fa 47Requires: rc-scripts >= 0.4.0.19
f440f0d0 48%{?with_inotify:Requires: uname(release) >= 2.6.13}
9088c091
AM
49Provides: crondaemon
50Provides: crontabs = 1.7
51Provides: group(crontab)
0d2f2c46 52%if "%{pld_release}" == "th"
84a870a4 53Provides: vixie-cron = 4:4.4
daf76cdc 54%endif
9088c091
AM
55Obsoletes: crondaemon
56Obsoletes: crontabs
0d2f2c46 57%if "%{pld_release}" == "th"
84a870a4 58Obsoletes: vixie-cron <= 4:4.3
daf76cdc 59%endif
9088c091
AM
60BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62%description
84a870a4
AM
63Cronie contains the standard UNIX daemon crond that runs specified
64programs at scheduled times and related tools. It is based on the
65original cron and has security and configuration enhancements like the
66ability to use pam and SELinux.
9088c091
AM
67
68%package anacron
84a870a4
AM
69Summary: Utility for running regular jobs
70Group: Base
71Provides: anacron = 2.4
72Obsoletes: anacron <= 2.3
9088c091
AM
73
74%description anacron
84a870a4
AM
75Anacron becames part of cronie. Anacron is used only for running
76regular jobs. The default settings execute regular jobs by anacron,
77however this could be overloaded in settings.
9088c091
AM
78
79%prep
80%setup -q
f440f0d0 81%patch0 -p1
9c2aa177 82%patch1 -p1
cb620710 83%patch2 -p1
9088c091
AM
84
85%build
828712ad
ER
86%{__aclocal}
87%{__autoconf}
88%{__autoheader}
89%{__automake}
9088c091 90%configure \
d39ca4fd 91 SYSCRONTAB=/etc/crontab \
695ed2ed 92 SYS_CROND_DIR=/etc/cron.d \
72768a3d 93 --sysconfdir=/etc/cron \
9088c091 94 --with-pam \
45b0067d 95 --with%{!?with_selinux:out}-selinux \
828712ad 96 --with%{!?with_audit:out}-audit \
946518b7 97 --with%{!?with_inotify:out}-inotify \
9088c091
AM
98 --enable-anacron
99
100%{__make}
101
102%install
103rm -rf $RPM_BUILD_ROOT
d07a95b8 104install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir}} \
9088c091
AM
105 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
106 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
107
108%{__make} install \
0d2f2c46 109 pamdir=/etc/pam.d \
9088c091
AM
110 DESTDIR=$RPM_BUILD_ROOT
111
fd39f74d
ER
112install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
113cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
114cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
115cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
116cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
117cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
9088c091
AM
118
119touch $RPM_BUILD_ROOT/var/log/cron
120
121cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
122# cron.allow This file describes the names of the users which are
123# allowed to use the local cron daemon
124root
125EOF
126
127cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
128# cron.deny This file describes the names of the users which are
129# NOT allowed to use the local cron daemon
130EOF
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%pre
136%groupadd -g 117 -r -f crontab
137
138%post
fd39f74d
ER
139if [ ! -f /var/log/cron ]; then
140 umask 027
141 touch /var/log/cron
142 chgrp crontab /var/log/cron
143 chmod 660 /var/log/cron
144fi
9088c091 145/sbin/chkconfig --add crond
9088c091
AM
146%service crond restart "Cron Daemon"
147
148%preun
149if [ "$1" = "0" ]; then
150 %service crond stop
151 /sbin/chkconfig --del crond
152fi
153
154%postun
155if [ "$1" = "0" ]; then
156 %groupremove crontab
157fi
158
8609ee66 159%triggerun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
160# Prevent preun from crond from working
161chmod a-x /etc/rc.d/init.d/crond
162
8609ee66 163%triggerpostun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
164# Restore what triggerun removed
165chmod 754 /etc/rc.d/init.d/crond
8609ee66
ER
166# reinstall crond init.d links, which could be different
167/sbin/chkconfig --del crond
77af6cfd
AM
168/sbin/chkconfig --add crond
169
9088c091
AM
170%files
171%defattr(644,root,root,755)
172%doc AUTHORS ChangeLog README
173%attr(750,root,crontab) %dir %{_sysconfdir}/cron*
174%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
175%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
176%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
177%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
178%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
179%attr(754,root,root) /etc/rc.d/init.d/crond
180%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
181%attr(755,root,root) %{_sbindir}/crond
182%attr(2755,root,crontab) %{_bindir}/crontab
183
184%{_mandir}/man8/crond.8*
185%{_mandir}/man8/cron.8*
186%{_mandir}/man5/crontab.5*
187%{_mandir}/man1/crontab.1*
188
189%attr(1730,root,crontab) /var/spool/cron
190%attr(660,root,crontab) %ghost /var/log/cron
191
192%files anacron
193%defattr(644,root,root,755)
194%attr(755,root,root) %{_sbindir}/anacron
84a870a4 195%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
9088c091
AM
196%{_mandir}/man5/anacrontab.5*
197%{_mandir}/man8/anacron.8*
d07a95b8
AM
198
199%attr(1730,root,crontab) /var/spool/anacron
This page took 0.109215 seconds and 4 git commands to generate.