]> git.pld-linux.org Git - packages/cromfs.git/commitdiff
- updated to 1.5.9
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 13 Nov 2010 10:02:16 +0000 (10:02 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- removed obsolete noomp patch, added c32,libc patches
- builds with openmp support if using gcc 4.2+ (BR: libgomp-devel)

Changed files:
    cromfs-c32.patch -> 1.1
    cromfs-libc.patch -> 1.1
    cromfs-noomp.patch -> 1.2
    cromfs.spec -> 1.14

cromfs-c32.patch [new file with mode: 0644]
cromfs-libc.patch [new file with mode: 0644]
cromfs-noomp.patch [deleted file]
cromfs.spec

diff --git a/cromfs-c32.patch b/cromfs-c32.patch
new file mode 100644 (file)
index 0000000..4b8517c
--- /dev/null
@@ -0,0 +1,10 @@
+--- cromfs-1.5.9/lib/newhash.cc.orig   2009-12-17 09:44:32.000000000 +0100
++++ cromfs-1.5.9/lib/newhash.cc        2010-11-13 10:12:45.163105804 +0100
+@@ -296,6 +296,7 @@
+    }
+ #else
+     uint_least32_t a,b;
++    typedef uint_least32_t c32;
+     unsigned long len = size;
+     c += size + UINT32_C(0x9e3779b9); // 2^32 / ((1+sqrt(5))/2
+     a = b = c;
diff --git a/cromfs-libc.patch b/cromfs-libc.patch
new file mode 100644 (file)
index 0000000..f938efc
--- /dev/null
@@ -0,0 +1,10 @@
+--- cromfs-1.5.9/util/unmkcromfs.cc.orig       2009-12-17 09:44:32.000000000 +0100
++++ cromfs-1.5.9/util/unmkcromfs.cc    2010-11-13 10:26:48.243099937 +0100
+@@ -22,6 +22,7 @@
+ #ifdef HAS_LUTIMES
+  #include <sys/time.h>
+ #endif
++#include <sys/stat.h>
+ #include <getopt.h>
diff --git a/cromfs-noomp.patch b/cromfs-noomp.patch
deleted file mode 100644 (file)
index 5b45651..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- cromfs-1.5.6.2/util/unmkcromfs.cc.orig     2008-12-16 21:19:59.000000000 +0100
-+++ cromfs-1.5.6.2/util/unmkcromfs.cc  2009-01-15 21:21:12.814458885 +0100
-@@ -105,7 +105,11 @@
-         beginline();
-     #endif
-     }
-+    #ifdef _OPENMP
-     void endthread(int threadno = omp_get_thread_num())
-+    #else
-+    void endthread(int threadno = 0)
-+    #endif
-     {
-     #ifdef _OPENMP
-         lines.erase(threadno);
index 5490b00989b7e97e7fc76ca60d70626bcc0b86e5..5d3eb9f2844071922bd2b72a10dac0114023db06 100644 (file)
@@ -1,16 +1,21 @@
 Summary:       Compressed ROM filesystem for Linux in user-space
 Summary(pl.UTF-8):     System plików Compressed ROM dla Linuksa działający w przestrzeni użytkownika
 Name:          cromfs
-Version:       1.5.6.2
+Version:       1.5.9
 Release:       0.1
 License:       GPL v3
 Group:         Applications/System
 Source0:       http://bisqwit.iki.fi/src/arch/%{name}-%{version}.tar.bz2
-# Source0-md5: 11b76b8ace6cffaff6e58edceea17d9f
-Patch0:                %{name}-noomp.patch
+# Source0-md5: 9e2067c72a9edf80b232c624f0a7432e
+Patch0:                %{name}-c32.patch
+Patch1:                %{name}-libc.patch
 URL:           http://bisqwit.iki.fi/source/cromfs.html
 BuildRequires: libfuse-devel >= 0:2.5.2
+%if "%{cc_version}" >= "4.2"
+BuildRequires: libgomp-devel
+%endif
 BuildRequires: libstdc++-devel
+BuildRequires: lzo-devel >= 2
 BuildRequires: rpmbuild(macros) >= 1.167
 Requires:      libfuse >= 0:2.5.2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -47,6 +52,7 @@ cramfs.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 ./configure
@@ -77,4 +83,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc doc/ChangeLog doc/FORMAT README.html
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/cromfs-driver
+%attr(755,root,root) %{_bindir}/cvcromfs
+%attr(755,root,root) %{_bindir}/mkcromfs
+%attr(755,root,root) %{_bindir}/unmkcromfs
This page took 0.100328 seconds and 4 git commands to generate.