]> git.pld-linux.org Git - packages/criu.git/blob - criu.spec
ca51fef164f7ee2497e9902690639c3b6778307f
[packages/criu.git] / criu.spec
1 # TODO
2 # - unpackaged: /usr/libexec/criu/scripts/systemd-autofs-restart.sh
3 Summary:        Checkpoint/restore functionality for Linux in userspace
4 Summary(pl.UTF-8):      Funkcja checkpoint/restore w przestrzeni użytkownika dla Linuksa
5 Name:           criu
6 Version:        2.5
7 Release:        1
8 License:        GPL v2 (tools), LGPL v2.1 (library)
9 Group:          Applications/System
10 Source0:        http://download.openvz.org/criu/%{name}-%{version}.tar.bz2
11 # Source0-md5:  5d5115454d110adb744e885d82d2c1f6
12 Patch0:         %{name}-python.patch
13 URL:            http://criu.org/
14 BuildRequires:  asciidoc
15 BuildRequires:  libcap-devel
16 BuildRequires:  libnl-devel >= 1:3.2
17 BuildRequires:  pkgconfig
18 BuildRequires:  protobuf
19 BuildRequires:  protobuf-c-devel
20 BuildRequires:  protobuf-devel
21 BuildRequires:  python >= 2
22 BuildRequires:  python-modules
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.697
25 BuildRequires:  sed >= 4.0
26 Requires:       %{name}-libs = %{version}-%{release}
27 Requires:       iproute2 >= 3.5
28 Requires:       uname(release) >= 3.11
29 ExclusiveArch:  %{x8664} %{arm} aarch64 ppc64
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Checkpoint/Restore In Userspace, or CRIU, is a software tool for Linux
34 operating system. Using this tool, you can freeze a running
35 application (or part of it) and checkpoint it to a hard drive as a
36 collection of files. You can then use the files to restore and run the
37 application from the point it was frozen at. The distinctive feature
38 of the CRIU project is that it is mainly implemented in user space.
39
40 %description -l en.UTF-8
41 Checkpoint/Restore In Userspace, or CRIU (pronounced kree-oo, IPA:
42 /krɪʊ/, Russian: криу), is a software tool for Linux operating system.
43 Using this tool, you can freeze a running application (or part of it)
44 and checkpoint it to a hard drive as a collection of files. You can
45 then use the files to restore and run the application from the point
46 it was frozen at. The distinctive feature of the CRIU project is that
47 it is mainly implemented in user space.
48
49 %description -l pl.UTF-8
50 CRIU (Checkpoint/Restore In Userspace) to narzędzie programowe dla
51 systemu operacyjnego Linux. Przy jego użyciu można zamrozić działającą
52 aplikację (lub jej część) i zapisać migawkę na twardym dysku jako
53 zestaw plików. Następnie można użyć tych plików do odtworzenia i
54 uruchomienia aplikacji od miejsca, w którym została zamrożona.
55 Wyróżnikiem projektu CRIU jest to, że został zaimplementowany głównie
56 w przestrzeni użytkownika.
57
58 %package libs
59 Summary:        CRIU shared library
60 Summary(pl.UTF-8):      Biblioteka współdzielona CRIU
61 License:        LGPL v2.1
62 Group:          Libraries
63
64 %description libs
65 CRIU shared library.
66
67 %description libs -l pl.UTF-8
68 Biblioteka współdzielona CRIU.
69
70 %package devel
71 Summary:        Header files for CRIU library
72 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CRIU
73 License:        LGPL v2.1
74 Group:          Development/Libraries
75 Requires:       %{name}-libs = %{version}-%{release}
76
77 %description devel
78 Header files for CRIU library.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe biblioteki CRIU.
82
83 %package -n python-pycriu
84 Summary:        Python interface to CRIU
85 Summary(pl.UTF-8):      Pythonowy interfejs do CRIU
86 Group:          Libraries/Python
87 Requires:       %{name}-libs = %{version}-%{release}
88
89 %description -n python-pycriu
90 Python interface to CRIU. This package contains also crit utility.
91
92 %description -n python-pycriu -l pl.UTF-8
93 Pythonowy interfejs do CRIU. Ten pakiet zawiera także narzędzie crit.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %{__sed} -i -e 's#-O2 -g#$(OPT)#g' Makefile
100
101 %build
102 %define _make_opts \\\
103         DEB_HOST_MULTIARCH= \\\
104         CC="%{__cc}" \\\
105         OPT="%{rpmcppflags} %{rpmcflags}" \\\
106         PREFIX=%{_prefix} \\\
107         LIBDIR=%{_libdir} \\\
108         LOGROTATEDIR=%{_sysconfdir}/logrotate.d \\\
109         PYSITESCRIPTDIR=%{py_sitescriptdir} \\\
110         MANDIR=%{_mandir} \\\
111         WERROR=0 \\\
112         V=1
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %py_postclean
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   libs -p /sbin/ldconfig
126 %postun libs -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc CREDITS README.md
131 %attr(755,root,root) %{_sbindir}/criu
132 %{_mandir}/man8/criu.8*
133
134 %files libs
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/libcriu.so.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libcriu.so.1
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libcriu.so
142 %{_includedir}/criu
143 %{_pkgconfigdir}/criu.pc
144
145 %files -n python-pycriu
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/crit
148 %{py_sitescriptdir}/pycriu
149 %{py_sitescriptdir}/crit-0.0.1-py*.egg-info
This page took 0.10807 seconds and 2 git commands to generate.