]> git.pld-linux.org Git - packages/criu.git/blob - criu.spec
package systemd-autofs-restart.sh
[packages/criu.git] / criu.spec
1 Summary:        Checkpoint/restore functionality for Linux in userspace
2 Summary(pl.UTF-8):      Funkcja checkpoint/restore w przestrzeni użytkownika dla Linuksa
3 Name:           criu
4 Version:        2.5
5 Release:        1
6 License:        GPL v2 (tools), LGPL v2.1 (library)
7 Group:          Applications/System
8 Source0:        http://download.openvz.org/criu/%{name}-%{version}.tar.bz2
9 # Source0-md5:  5d5115454d110adb744e885d82d2c1f6
10 Patch0:         %{name}-python.patch
11 URL:            http://criu.org/
12 BuildRequires:  asciidoc
13 BuildRequires:  libcap-devel
14 BuildRequires:  libnl-devel >= 1:3.2
15 BuildRequires:  pkgconfig
16 BuildRequires:  protobuf
17 BuildRequires:  protobuf-c-devel
18 BuildRequires:  protobuf-devel
19 BuildRequires:  python >= 2
20 BuildRequires:  python-modules
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.697
23 BuildRequires:  sed >= 4.0
24 Requires:       %{name}-libs = %{version}-%{release}
25 Requires:       iproute2 >= 3.5
26 Requires:       uname(release) >= 3.11
27 ExclusiveArch:  %{x8664} %{arm} aarch64 ppc64
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _libexecdir     %{_prefix}/lib
31
32 %description
33 Checkpoint/Restore In Userspace, or CRIU, is a software tool for Linux
34 operating system. Using this tool, you can freeze a running
35 application (or part of it) and checkpoint it to a hard drive as a
36 collection of files. You can then use the files to restore and run the
37 application from the point it was frozen at. The distinctive feature
38 of the CRIU project is that it is mainly implemented in user space.
39
40 %description -l en.UTF-8
41 Checkpoint/Restore In Userspace, or CRIU (pronounced kree-oo, IPA:
42 /krɪʊ/, Russian: криу), is a software tool for Linux operating system.
43 Using this tool, you can freeze a running application (or part of it)
44 and checkpoint it to a hard drive as a collection of files. You can
45 then use the files to restore and run the application from the point
46 it was frozen at. The distinctive feature of the CRIU project is that
47 it is mainly implemented in user space.
48
49 %description -l pl.UTF-8
50 CRIU (Checkpoint/Restore In Userspace) to narzędzie programowe dla
51 systemu operacyjnego Linux. Przy jego użyciu można zamrozić działającą
52 aplikację (lub jej część) i zapisać migawkę na twardym dysku jako
53 zestaw plików. Następnie można użyć tych plików do odtworzenia i
54 uruchomienia aplikacji od miejsca, w którym została zamrożona.
55 Wyróżnikiem projektu CRIU jest to, że został zaimplementowany głównie
56 w przestrzeni użytkownika.
57
58 %package libs
59 Summary:        CRIU shared library
60 Summary(pl.UTF-8):      Biblioteka współdzielona CRIU
61 License:        LGPL v2.1
62 Group:          Libraries
63
64 %description libs
65 CRIU shared library.
66
67 %description libs -l pl.UTF-8
68 Biblioteka współdzielona CRIU.
69
70 %package devel
71 Summary:        Header files for CRIU library
72 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CRIU
73 License:        LGPL v2.1
74 Group:          Development/Libraries
75 Requires:       %{name}-libs = %{version}-%{release}
76
77 %description devel
78 Header files for CRIU library.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe biblioteki CRIU.
82
83 %package -n python-pycriu
84 Summary:        Python interface to CRIU
85 Summary(pl.UTF-8):      Pythonowy interfejs do CRIU
86 Group:          Libraries/Python
87 Requires:       %{name}-libs = %{version}-%{release}
88
89 %description -n python-pycriu
90 Python interface to CRIU. This package contains also crit utility.
91
92 %description -n python-pycriu -l pl.UTF-8
93 Pythonowy interfejs do CRIU. Ten pakiet zawiera także narzędzie crit.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %{__sed} -i -e 's#-O2 -g#$(OPT)#g' Makefile
100
101 %build
102 %define _make_opts \\\
103         DEB_HOST_MULTIARCH= \\\
104         CC="%{__cc}" \\\
105         OPT="%{rpmcppflags} %{rpmcflags}" \\\
106         PREFIX=%{_prefix} \\\
107         LIBDIR=%{_libdir} \\\
108         LOGROTATEDIR=%{_sysconfdir}/logrotate.d \\\
109         LIBEXECDIR=%{_libexecdir} \\\
110         PYSITESCRIPTDIR=%{py_sitescriptdir} \\\
111         MANDIR=%{_mandir} \\\
112         WERROR=0 \\\
113         V=1
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 # optional script, do not autogenerate bash dep
122 chmod -x $RPM_BUILD_ROOT%{_libexecdir}/%{name}/scripts/systemd-autofs-restart.sh
123
124 %py_postclean
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   libs -p /sbin/ldconfig
130 %postun libs -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc CREDITS README.md contrib
135 %attr(755,root,root) %{_sbindir}/criu
136 %{_mandir}/man8/criu.8*
137 %dir %{_libexecdir}/%{name}
138 %dir %{_libexecdir}/%{name}/scripts
139 %{_libexecdir}/%{name}/scripts/systemd-autofs-restart.sh
140
141 %files libs
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/libcriu.so.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libcriu.so.1
145
146 %files devel
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/libcriu.so
149 %{_includedir}/criu
150 %{_pkgconfigdir}/criu.pc
151
152 %files -n python-pycriu
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_bindir}/crit
155 %{py_sitescriptdir}/pycriu
156 %{py_sitescriptdir}/crit-0.0.1-py*.egg-info
This page took 0.062096 seconds and 3 git commands to generate.