]> git.pld-linux.org Git - packages/criu.git/blob - criu.spec
- release 2 (by relup.sh)
[packages/criu.git] / criu.spec
1 Summary:        Checkpoint/restore functionality for Linux in userspace
2 Summary(pl.UTF-8):      Funkcja checkpoint/restore w przestrzeni użytkownika dla Linuksa
3 Name:           criu
4 Version:        1.7
5 Release:        2
6 License:        GPL v2 (tools), LGPL v2.1 (library)
7 Group:          Applications/System
8 Source0:        http://download.openvz.org/criu/%{name}-%{version}.tar.bz2
9 # Source0-md5:  317a2c303f445824c640d5665a40d778
10 Patch0:         %{name}-python.patch
11 URL:            http://criu.org/
12 BuildRequires:  autoconf >= 2.50
13 BuildRequires:  protobuf-c-devel
14 BuildRequires:  python >= 2
15 BuildRequires:  rpmbuild(macros) >= 1.228
16 BuildRequires:  sed >= 4.0
17 Requires(post,preun,postun):    systemd-units >= 38
18 Requires:       %{name}-libs = %{version}-%{release}
19 Requires:       iproute2 >= 3.6
20 Requires:       uname(release) >= 3.9
21 Requires:       systemd-units >= 38
22 ExclusiveArch:  %{x8664}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Checkpoint/Restore In Userspace, or CRIU, is a software tool for Linux
27 operating system. Using this tool, you can freeze a running
28 application (or part of it) and checkpoint it to a hard drive as a
29 collection of files. You can then use the files to restore and run the
30 application from the point it was frozen at. The distinctive feature
31 of the CRIU project is that it is mainly implemented in user space.
32
33 %description -l en.UTF-8
34 Checkpoint/Restore In Userspace, or CRIU (pronounced kree-oo, IPA:
35 /krɪʊ/, Russian: криу), is a software tool for Linux operating system.
36 Using this tool, you can freeze a running application (or part of it)
37 and checkpoint it to a hard drive as a collection of files. You can
38 then use the files to restore and run the application from the point
39 it was frozen at. The distinctive feature of the CRIU project is that
40 it is mainly implemented in user space.
41
42 %description -l pl.UTF-8
43 CRIU (Checkpoint/Restore In Userspace) to narzędzie programowe dla
44 systemu operacyjnego Linux. Przy jego użyciu można zamrozić działającą
45 aplikację (lub jej część) i zapisać migawkę na twardym dysku jako
46 zestaw plików. Następnie można użyć tych plików do odtworzenia i
47 uruchomienia aplikacji od miejsca, w którym została zamrożona.
48 Wyróżnikiem projektu CRIU jest to, że został zaimplementowany głównie
49 w przestrzeni użytkownika.
50
51 %package libs
52 Summary:        CRIU shared library
53 Summary(pl.UTF-8):      Biblioteka współdzielona CRIU
54 License:        LGPL v2.1
55 Group:          Libraries
56
57 %description libs
58 CRIU shared library.
59
60 %description libs -l pl.UTF-8
61 Biblioteka współdzielona CRIU.
62
63 %package devel
64 Summary:        Header files for CRIU library
65 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CRIU
66 License:        LGPL v2.1
67 Group:          Development/Libraries
68 Requires:       %{name}-libs = %{version}-%{release}
69
70 %description devel
71 Header files for CRIU library.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe biblioteki CRIU.
75
76 %package -n python-pycriu
77 Summary:        Python interface to CRIU
78 Summary(pl.UTF-8):      Pythonowy interfejs do CRIU
79 Group:          Libraries/Python
80 Requires:       %{name}-libs = %{version}-%{release}
81
82 %description -n python-pycriu
83 Python interface to CRIU. This package contains also crit utility.
84
85 %description -n python-pycriu -l pl.UTF-8
86 Pythonowy interfejs do CRIU. Ten pakiet zawiera także narzędzie crit.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 sed -i -e 's#-O2#$(OPT)#g' Makefile*
93
94 %build
95 %{__make} \
96         DEB_HOST_MULTIARCH= \
97         CC="%{__cc}" \
98         OPT="%{rpmcppflags} %{rpmcflags}" \
99         PREFIX=%{_prefix} \
100         LOGROTATEDIR=%{_sysconfdir}/logrotate.d \
101         SYSTEMDUNITDIR=%{systemdunitdir} \
102         V=1 \
103         WERROR=0
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 %{__make} install \
108         DEB_HOST_MULTIARCH= \
109         PREFIX="%{_prefix}" \
110         LOGROTATEDIR=%{_sysconfdir}/logrotate.d \
111         SYSTEMDUNITDIR=%{systemdunitdir} \
112         MANDIR=%{_mandir} \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 %py_postclean
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 %systemd_post criu.service
122
123 %preun
124 %systemd_preun criu.service
125
126 %postun
127 %systemd_reload
128
129 %post   libs -p /sbin/ldconfig
130 %postun libs -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc CREDITS README.md
135 %attr(755,root,root) %{_sbindir}/criu
136 %{_mandir}/man8/criu.8*
137 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/criu-service
138 %{systemdunitdir}/criu.service
139 %{systemdunitdir}/criu.socket
140
141 %files libs
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/libcriu.so.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libcriu.so.1
145
146 %files devel
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/libcriu.so
149 %{_includedir}/criu
150 %{_pkgconfigdir}/criu.pc
151
152 %files -n python-pycriu
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_bindir}/crit
155 %{py_sitescriptdir}/pycriu
156 %{py_sitescriptdir}/crit-0.0.1-py*.egg-info
This page took 0.1272 seconds and 3 git commands to generate.