]> git.pld-linux.org Git - packages/criu.git/blob - criu.spec
02ecd111b05ee31a5c902f677b9b1f3255ec3ab9
[packages/criu.git] / criu.spec
1 Summary:        Checkpoint/restore functionality for Linux in userspace
2 Summary(pl.UTF-8):      Funkcja checkpoint/restore w przestrzeni użytkownika dla Linuksa
3 Name:           criu
4 Version:        2.3
5 Release:        1
6 License:        GPL v2 (tools), LGPL v2.1 (library)
7 Group:          Applications/System
8 Source0:        http://download.openvz.org/criu/%{name}-%{version}.tar.bz2
9 # Source0-md5:  ba8f3ba9aed1219f0569cc2958a4f171
10 Patch0:         %{name}-python.patch
11 URL:            http://criu.org/
12 BuildRequires:  asciidoc
13 BuildRequires:  libcap-devel
14 BuildRequires:  libnl-devel >= 1:3.2
15 BuildRequires:  pkgconfig
16 BuildRequires:  protobuf-c-devel
17 BuildRequires:  protobuf
18 BuildRequires:  protobuf-devel
19 BuildRequires:  python >= 2
20 BuildRequires:  python-modules
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.228
23 BuildRequires:  sed >= 4.0
24 Requires:       %{name}-libs = %{version}-%{release}
25 Requires:       iproute2 >= 3.6
26 Requires:       uname(release) >= 3.9
27 ExclusiveArch:  %{x8664} arm aarch64 ppc64
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Checkpoint/Restore In Userspace, or CRIU, is a software tool for Linux
32 operating system. Using this tool, you can freeze a running
33 application (or part of it) and checkpoint it to a hard drive as a
34 collection of files. You can then use the files to restore and run the
35 application from the point it was frozen at. The distinctive feature
36 of the CRIU project is that it is mainly implemented in user space.
37
38 %description -l en.UTF-8
39 Checkpoint/Restore In Userspace, or CRIU (pronounced kree-oo, IPA:
40 /krɪʊ/, Russian: криу), is a software tool for Linux operating system.
41 Using this tool, you can freeze a running application (or part of it)
42 and checkpoint it to a hard drive as a collection of files. You can
43 then use the files to restore and run the application from the point
44 it was frozen at. The distinctive feature of the CRIU project is that
45 it is mainly implemented in user space.
46
47 %description -l pl.UTF-8
48 CRIU (Checkpoint/Restore In Userspace) to narzędzie programowe dla
49 systemu operacyjnego Linux. Przy jego użyciu można zamrozić działającą
50 aplikację (lub jej część) i zapisać migawkę na twardym dysku jako
51 zestaw plików. Następnie można użyć tych plików do odtworzenia i
52 uruchomienia aplikacji od miejsca, w którym została zamrożona.
53 Wyróżnikiem projektu CRIU jest to, że został zaimplementowany głównie
54 w przestrzeni użytkownika.
55
56 %package libs
57 Summary:        CRIU shared library
58 Summary(pl.UTF-8):      Biblioteka współdzielona CRIU
59 License:        LGPL v2.1
60 Group:          Libraries
61
62 %description libs
63 CRIU shared library.
64
65 %description libs -l pl.UTF-8
66 Biblioteka współdzielona CRIU.
67
68 %package devel
69 Summary:        Header files for CRIU library
70 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CRIU
71 License:        LGPL v2.1
72 Group:          Development/Libraries
73 Requires:       %{name}-libs = %{version}-%{release}
74
75 %description devel
76 Header files for CRIU library.
77
78 %description devel -l pl.UTF-8
79 Pliki nagłówkowe biblioteki CRIU.
80
81 %package -n python-pycriu
82 Summary:        Python interface to CRIU
83 Summary(pl.UTF-8):      Pythonowy interfejs do CRIU
84 Group:          Libraries/Python
85 Requires:       %{name}-libs = %{version}-%{release}
86
87 %description -n python-pycriu
88 Python interface to CRIU. This package contains also crit utility.
89
90 %description -n python-pycriu -l pl.UTF-8
91 Pythonowy interfejs do CRIU. Ten pakiet zawiera także narzędzie crit.
92
93 %prep
94 %setup -q
95 %patch0 -p1
96
97 %{__sed} -i -e 's#-O2 -g#$(OPT)#g' Makefile
98
99 %build
100 %{__make} \
101         DEB_HOST_MULTIARCH= \
102         CC="%{__cc}" \
103         OPT="%{rpmcppflags} %{rpmcflags}" \
104         PREFIX=%{_prefix} \
105         LIBDIR=%{_libdir} \
106         LOGROTATEDIR=%{_sysconfdir}/logrotate.d \
107         V=1 \
108         WERROR=0
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 %{__make} install \
113         DEB_HOST_MULTIARCH= \
114         PREFIX=%{_prefix} \
115         LIBDIR=%{_libdir} \
116         PYSITESCRIPTDIR=%{py_sitescriptdir} \
117         LOGROTATEDIR=%{_sysconfdir}/logrotate.d \
118         MANDIR=%{_mandir} \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 %py_postclean
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   libs -p /sbin/ldconfig
127 %postun libs -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc CREDITS README.md
132 %attr(755,root,root) %{_sbindir}/criu
133 %{_mandir}/man8/criu.8*
134
135 %files libs
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libcriu.so.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libcriu.so.1
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libcriu.so
143 %{_includedir}/criu
144 %{_pkgconfigdir}/criu.pc
145
146 %files -n python-pycriu
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_bindir}/crit
149 %{py_sitescriptdir}/pycriu
150 %{py_sitescriptdir}/crit-0.0.1-py*.egg-info
This page took 0.088718 seconds and 2 git commands to generate.