]> git.pld-linux.org Git - packages/criu.git/blame - criu.spec
up to 3.15
[packages/criu.git] / criu.spec
CommitLineData
63f40716
JP
1# TODO
2# - package static libs
3# /usr/lib/compel/fds.lib.a
4# /usr/lib/compel/scripts/compel-pack.lds.S
5# /usr/lib/compel/std.lib.a
6# /usr/lib64/libcompel.a
7# /usr/lib64/libcriu.a
a9349246
ER
8#
9# Conditional build:
10%bcond_with tests # build and run tests (requires root)
11
e769518e
JB
12Summary: Checkpoint/restore functionality for Linux in userspace
13Summary(pl.UTF-8): Funkcja checkpoint/restore w przestrzeni użytkownika dla Linuksa
6be8c1d2 14Name: criu
3c9ca18c 15Version: 3.15
83bc7f40 16Release: 1
1d80f334 17License: GPL v2 (tools), LGPL v2.1 (library)
6be8c1d2
AM
18Group: Applications/System
19Source0: http://download.openvz.org/criu/%{name}-%{version}.tar.bz2
3c9ca18c 20# Source0-md5: eb47303cda4b1fca8504333df0529a0d
1d80f334 21Patch0: %{name}-python.patch
a9349246 22Patch1: tests.patch
6be8c1d2 23URL: http://criu.org/
6e51e7f7
ER
24BuildRequires: asciidoc
25BuildRequires: libcap-devel
63f40716 26BuildRequires: libnet-devel
6e51e7f7
ER
27BuildRequires: libnl-devel >= 1:3.2
28BuildRequires: pkgconfig
6e51e7f7 29BuildRequires: protobuf
7a48cad9 30BuildRequires: protobuf-c-devel
6e51e7f7 31BuildRequires: protobuf-devel
1d80f334 32BuildRequires: python >= 2
6e51e7f7
ER
33BuildRequires: python-modules
34BuildRequires: rpm-pythonprov
7a48cad9 35BuildRequires: rpmbuild(macros) >= 1.697
7a8067bd 36BuildRequires: sed >= 4.0
aa51aa10 37Requires: %{name}-libs = %{version}-%{release}
db5fa3a6
ER
38Requires: iproute2 >= 3.5
39Requires: uname(release) >= 3.11
6073a3d8 40ExclusiveArch: %{x8664} %{arm} aarch64 ppc64
6be8c1d2
AM
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
a27aad5c
ER
43%define _libexecdir %{_prefix}/lib
44
6be8c1d2 45%description
7a8067bd
ER
46Checkpoint/Restore In Userspace, or CRIU, is a software tool for Linux
47operating system. Using this tool, you can freeze a running
48application (or part of it) and checkpoint it to a hard drive as a
49collection of files. You can then use the files to restore and run the
50application from the point it was frozen at. The distinctive feature
51of the CRIU project is that it is mainly implemented in user space.
52
53%description -l en.UTF-8
6be8c1d2
AM
54Checkpoint/Restore In Userspace, or CRIU (pronounced kree-oo, IPA:
55/krɪʊ/, Russian: криу), is a software tool for Linux operating system.
56Using this tool, you can freeze a running application (or part of it)
57and checkpoint it to a hard drive as a collection of files. You can
58then use the files to restore and run the application from the point
59it was frozen at. The distinctive feature of the CRIU project is that
60it is mainly implemented in user space.
61
e769518e
JB
62%description -l pl.UTF-8
63CRIU (Checkpoint/Restore In Userspace) to narzędzie programowe dla
64systemu operacyjnego Linux. Przy jego użyciu można zamrozić działającą
65aplikację (lub jej część) i zapisać migawkę na twardym dysku jako
66zestaw plików. Następnie można użyć tych plików do odtworzenia i
67uruchomienia aplikacji od miejsca, w którym została zamrożona.
68Wyróżnikiem projektu CRIU jest to, że został zaimplementowany głównie
69w przestrzeni użytkownika.
70
aa51aa10
AM
71%package libs
72Summary: CRIU shared library
73Summary(pl.UTF-8): Biblioteka współdzielona CRIU
1d80f334 74License: LGPL v2.1
aa51aa10
AM
75Group: Libraries
76
77%description libs
78CRIU shared library.
79
80%description libs -l pl.UTF-8
81Biblioteka współdzielona CRIU.
82
83%package devel
1d80f334
JB
84Summary: Header files for CRIU library
85Summary(pl.UTF-8): Pliki nagłówkowe biblioteki CRIU
86License: LGPL v2.1
aa51aa10
AM
87Group: Development/Libraries
88Requires: %{name}-libs = %{version}-%{release}
89
90%description devel
1d80f334 91Header files for CRIU library.
aa51aa10
AM
92
93%description devel -l pl.UTF-8
1d80f334
JB
94Pliki nagłówkowe biblioteki CRIU.
95
96%package -n python-pycriu
97Summary: Python interface to CRIU
98Summary(pl.UTF-8): Pythonowy interfejs do CRIU
99Group: Libraries/Python
100Requires: %{name}-libs = %{version}-%{release}
101
102%description -n python-pycriu
103Python interface to CRIU. This package contains also crit utility.
104
105%description -n python-pycriu -l pl.UTF-8
106Pythonowy interfejs do CRIU. Ten pakiet zawiera także narzędzie crit.
aa51aa10 107
6be8c1d2
AM
108%prep
109%setup -q
1d80f334 110%patch0 -p1
a9349246 111%patch1 -p1
1d80f334 112
83bc7f40 113%{__sed} -i -e 's#-O2 -g#$(OPT)#g' Makefile
6be8c1d2
AM
114
115%build
7a48cad9
ER
116%define _make_opts \\\
117 DEB_HOST_MULTIARCH= \\\
118 CC="%{__cc}" \\\
119 OPT="%{rpmcppflags} %{rpmcflags}" \\\
120 PREFIX=%{_prefix} \\\
121 LIBDIR=%{_libdir} \\\
122 LOGROTATEDIR=%{_sysconfdir}/logrotate.d \\\
a27aad5c 123 LIBEXECDIR=%{_libexecdir} \\\
7a48cad9
ER
124 PYSITESCRIPTDIR=%{py_sitescriptdir} \\\
125 MANDIR=%{_mandir} \\\
126 WERROR=0 \\\
127 V=1
128%{__make}
6be8c1d2 129
a9349246
ER
130%if %{with tests}
131%{__make} test
132%endif
133
6be8c1d2
AM
134%install
135rm -rf $RPM_BUILD_ROOT
6be8c1d2 136%{__make} install \
6be8c1d2 137 DESTDIR=$RPM_BUILD_ROOT
7a8067bd 138
59290952
ER
139install -p contrib/docker_cr.sh $RPM_BUILD_ROOT%{_libexecdir}/%{name}/scripts
140
141# optional scripts, do not autogenerate bash dep
142chmod -x $RPM_BUILD_ROOT%{_libexecdir}/%{name}/scripts/*.sh
a27aad5c 143
1d80f334
JB
144%py_postclean
145
6be8c1d2
AM
146%clean
147rm -rf $RPM_BUILD_ROOT
148
af06864b 149%post libs -p /sbin/ldconfig
aa51aa10
AM
150%postun libs -p /sbin/ldconfig
151
6be8c1d2
AM
152%files
153%defattr(644,root,root,755)
59290952 154%doc CREDITS README.md
63f40716 155%attr(755,root,root) %{_bindir}/compel
aa51aa10 156%attr(755,root,root) %{_sbindir}/criu
63f40716
JP
157%{_mandir}/man1/compel.1*
158%{_mandir}/man1/crit.1*
6be8c1d2 159%{_mandir}/man8/criu.8*
a27aad5c
ER
160%dir %{_libexecdir}/%{name}
161%dir %{_libexecdir}/%{name}/scripts
59290952
ER
162%attr(755,root,root) %{_libexecdir}/%{name}/scripts/systemd-autofs-restart.sh
163%attr(755,root,root) %{_libexecdir}/%{name}/scripts/docker_cr.sh
aa51aa10
AM
164
165%files libs
166%defattr(644,root,root,755)
63f40716
JP
167%attr(755,root,root) %{_libdir}/libcompel.so.*.*
168%attr(755,root,root) %ghost %{_libdir}/libcompel.so.1
aa51aa10 169%attr(755,root,root) %{_libdir}/libcriu.so.*.*
63f40716 170%attr(755,root,root) %ghost %{_libdir}/libcriu.so.2
aa51aa10
AM
171
172%files devel
173%defattr(644,root,root,755)
63f40716 174%attr(755,root,root) %{_libdir}/libcompel.so
aa51aa10 175%attr(755,root,root) %{_libdir}/libcriu.so
63f40716 176%{_includedir}/compel
aa51aa10
AM
177%{_includedir}/criu
178%{_pkgconfigdir}/criu.pc
1d80f334
JB
179
180%files -n python-pycriu
181%defattr(644,root,root,755)
182%attr(755,root,root) %{_bindir}/crit
183%{py_sitescriptdir}/pycriu
184%{py_sitescriptdir}/crit-0.0.1-py*.egg-info
This page took 0.116251 seconds and 4 git commands to generate.