]> git.pld-linux.org Git - packages/criterion.git/commitdiff
- cram tests fail due to missing, unchecked dependencies
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 6 May 2020 08:19:28 +0000 (10:19 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 6 May 2020 08:19:28 +0000 (10:19 +0200)
no-cram.patch [new file with mode: 0644]

diff --git a/no-cram.patch b/no-cram.patch
new file mode 100644 (file)
index 0000000..f348b46
--- /dev/null
@@ -0,0 +1,23 @@
+--- criterion-v2.3.3/test/CMakeLists.txt~      2018-11-05 01:59:28.000000000 +0100
++++ criterion-v2.3.3/test/CMakeLists.txt       2020-05-06 10:18:05.799801261 +0200
+@@ -36,20 +36,3 @@
+ add_dependencies(criterion_tests criterion_unit_tests)
+ add_test(criterion_unit_tests criterion_unit_tests)
+-
+-find_program(SH NAMES sh sh.exe)
+-
+-if (SH) # we disable the scripted tests when sh is not available
+-  add_custom_target(cram_tests)
+-
+-  add_custom_command(TARGET cram_tests POST_BUILD
+-      COMMAND "${CMAKE_COMMAND}"
+-        -DPROJECT_BINARY_DIR="${PROJECT_BINARY_DIR}"
+-        -DCRAM_PATH="${CMAKE_CURRENT_SOURCE_DIR}/cram"
+-        -DCRAM_SHELL="${SH}"
+-        -P "${CMAKE_MODULE_PATH}/Cram.cmake"
+-  )
+-
+-  add_test(cram_tests cmake --build ${PROJECT_BINARY_DIR} --target cram_tests)
+-
+-endif ()
This page took 0.187283 seconds and 4 git commands to generate.