]> git.pld-linux.org Git - packages/crda.git/blob - crda.spec
- updated to 3.13
[packages/crda.git] / crda.spec
1 #
2 # Conditional build:
3 %bcond_with     verify  # database verification
4 %bcond_without  verbose # verbose build (V=1)
5
6 Summary:        udev helper: Central Regulatory Domain Agent
7 Summary(pl.UTF-8):      Program pomocniczy udev: Central Regulatory Domain Agent
8 Name:           crda
9 Version:        3.13
10 Release:        1
11 License:        ISC
12 Group:          Networking/Daemons
13 Source0:        https://www.kernel.org/pub/software/network/crda/%{name}-%{version}.tar.xz
14 # Source0-md5:  66b1b0417c1ad19f0009a5c0c0c1aebc
15 Patch0:         %{name}-regdb.patch
16 Patch1:         %{name}-destdir.patch
17 Patch2:         %{name}-link.patch
18 URL:            http://wireless.kernel.org/en/developers/Regulatory/CRDA
19 BuildRequires:  libgcrypt-devel
20 BuildRequires:  libnl-devel >= 1:3.2
21 BuildRequires:  pkgconfig
22 BuildRequires:  python
23 BuildRequires:  python-M2Crypto
24 BuildRequires:  python-modules
25 %{?with_verify:BuildRequires:   wireless-regdb}
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 Requires:       %{name}-libs = %{version}-%{release}
29 Requires:       udev-core
30 Requires:       wireless-regdb
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 CRDA acts as the udev helper for communication between the kernel and
35 userspace for wireless regulatory compliance. It relies on nl80211 for
36 communication. CRDA is intended to be run only through udev
37 communication from the kernel. The user should never have to run it
38 manually except if debugging udev issues.
39
40 %description -l pl.UTF-8
41 CRDA działa jako program pomocniczy udev do komunikacji między jądrem
42 a przestrzenią użytkownika w celu zgodności łączności bezprzewodowej z
43 przepisami. Na potrzeby komunikacji polega na nl80211. CRDA jest
44 przeznaczone do uruchamiania wyłącznie poprzez udev. Użytkownik nigdy
45 nie powinien wywoływać go ręcznie, chyba że w celach diagnostyki udev.
46
47 %package libs
48 Summary:        CRDA libreg shared library
49 Summary(pl.UTF-8):      Biblioteka współdzielona CRDA libreg
50 Group:          Libraries
51
52 %description libs
53 CRDA libreg shared library.
54
55 %description libs -l pl.UTF-8
56 Biblioteka współdzielona CRDA libreg.
57
58 %package devel
59 Summary:        Header files for CRDA libreg library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CRDA libreg
61 Group:          Development/Libraries
62 Requires:       %{name}-libs = %{version}-%{release}
63
64 %description devel
65 Header files for CRDA libreg library.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe biblioteki CRDA libreg.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75
76 %build
77 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
78 %{__make} \
79         CC="%{__cc}" \
80         %{?with_verbose:V=1} \
81 %if %{with verify}
82         REG_BIN=%{_datadir}/crda/regulatory.bin \
83 %else
84         all_noverify \
85 %endif
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} install \
90         %{?with_verbose:V=1} \
91         DESTDIR=$RPM_BUILD_ROOT \
92         LIBDIR=/%{_lib}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   libs -p /sbin/ldconfig
98 %postun libs -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc LICENSE README
103 %attr(755,root,root) /sbin/crda
104 %attr(755,root,root) /sbin/regdbdump
105 %{_mandir}/man8/crda.8*
106 %{_mandir}/man8/regdbdump.8*
107 /lib/udev/rules.d/85-regulatory.rules
108
109 %files libs
110 %defattr(644,root,root,755)
111 %attr(755,root,root) /%{_lib}/libreg.so
112
113 %files devel
114 %defattr(644,root,root,755)
115 %{_includedir}/reglib
This page took 0.062554 seconds and 3 git commands to generate.