]> git.pld-linux.org Git - packages/crash.git/commitdiff
- updated to 7.2.0 auto/th/crash-7.2.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 26 Nov 2017 19:19:09 +0000 (20:19 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 26 Nov 2017 19:19:09 +0000 (20:19 +0100)
- removed obsolete gdb-glibc patch

crash.spec
gdb-glibc.patch [deleted file]

index 1ddcd250240219482b2bad1e4650ff53d2e6ffab..958225d87fae8cda02bbb977d59f302a7a30bc61 100644 (file)
@@ -25,17 +25,16 @@ exit 1
 Summary:       Core Analysis Suite
 Summary(pl.UTF-8):     Zestaw narzędzi do analizy zrzutów pamięci
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       7.1.8
+Version:       7.2.0
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       GPL v2+
 Group:         Libraries
 Source0:       http://people.redhat.com/anderson/%{pname}-%{version}.tar.gz
-# Source0-md5: daf5fb52567cfcac99d3a5890edbc707
+# Source0-md5: 2fc2219541ff6b802a55c112b339ba5d
 # git clone https://code.google.com/p/eppic
 Source1:       eppic.tar.xz
 # Source1-md5: a9f80ad71de9d6f5b77534a7ebdbed8e
 Patch0:                %{pname}-x32.patch
-Patch1:                gdb-glibc.patch
 URL:           http://people.redhat.com/anderson/
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
@@ -116,8 +115,6 @@ Ten pakiet zawiera sterownik pamięci /dev/crash do sesji crash na\
 %prep
 %setup -q -a1 -n %{pname}-%{version}
 %patch0 -p1
-# apply after unpacking gdb-7.6
-cat %{PATCH1} >> gdb-7.6.patch
 
 %{__mv} eppic extensions
 
diff --git a/gdb-glibc.patch b/gdb-glibc.patch
deleted file mode 100644 (file)
index 310b97e..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-Sync ps_get_thread_area() prototype with glibc 2.25.
---- gdb-7.6/gdb/gdb_proc_service.h.orig        2017-04-11 18:57:07.217202451 +0200
-+++ gdb-7.6/gdb/gdb_proc_service.h     2017-04-11 19:06:23.527196100 +0200
-@@ -115,7 +115,7 @@ extern pid_t ps_getpid (struct ps_procha
- /* Fetch the special per-thread address associated with the given LWP.
-    This call is only used on a few platforms (most use a normal register).
-    The meaning of the `int' parameter is machine-dependent.  */
--extern ps_err_e ps_get_thread_area (const struct ps_prochandle *,
-+extern ps_err_e ps_get_thread_area (struct ps_prochandle *,
-                                   lwpid_t, int, psaddr_t *);
---- gdb-7.6/gdb/i386-linux-nat.c.orig  2017-04-11 18:57:35.960535456 +0200
-+++ gdb-7.6/gdb/i386-linux-nat.c       2017-04-11 19:06:54.617195745 +0200
-@@ -849,7 +849,7 @@ i386_linux_new_fork (struct lwp_info *pa
-    storage (or its descriptor).  */
- ps_err_e
--ps_get_thread_area (const struct ps_prochandle *ph, 
-+ps_get_thread_area (struct ps_prochandle *ph, 
-                   lwpid_t lwpid, int idx, void **base)
- {
-   /* NOTE: cagney/2003-08-26: The definition of this buffer is found
---- gdb-7.6/gdb/aarch64-linux-nat.c.orig       2017-04-11 21:51:39.994282135 +0200
-+++ gdb-7.6/gdb/aarch64-linux-nat.c    2017-04-11 22:17:19.040025470 +0200
-@@ -750,7 +750,7 @@ aarch64_linux_new_fork (struct lwp_info
-    storage (or its descriptor).  */
- ps_err_e
--ps_get_thread_area (const struct ps_prochandle *ph,
-+ps_get_thread_area (struct ps_prochandle *ph,
-                   lwpid_t lwpid, int idx, void **base)
- {
-   struct iovec iovec;
---- gdb-7.6/gdb/amd64-linux-nat.c.orig 2017-04-11 21:51:39.930945697 +0200
-+++ gdb-7.6/gdb/amd64-linux-nat.c      2017-04-11 22:16:56.868930201 +0200
-@@ -493,7 +493,7 @@ amd64_linux_new_fork (struct lwp_info *p
-    a request for a thread's local storage address.  */
- ps_err_e
--ps_get_thread_area (const struct ps_prochandle *ph,
-+ps_get_thread_area (struct ps_prochandle *ph,
-                     lwpid_t lwpid, int idx, void **base)
- {
-   if (gdbarch_bfd_arch_info (target_gdbarch ())->bits_per_word == 32)
---- gdb-7.6/gdb/arm-linux-nat.c.orig   2017-04-11 21:51:37.884178700 +0200
-+++ gdb-7.6/gdb/arm-linux-nat.c        2017-04-11 22:17:34.610794784 +0200
-@@ -613,7 +613,7 @@ supply_fpregset (struct regcache *regcac
- /* Fetch the thread-local storage pointer for libthread_db.  */
- ps_err_e
--ps_get_thread_area (const struct ps_prochandle *ph,
-+ps_get_thread_area (struct ps_prochandle *ph,
-                     lwpid_t lwpid, int idx, void **base)
- {
-   if (ptrace (PTRACE_GET_THREAD_AREA, lwpid, NULL, base) != 0)
---- gdb-7.6/gdb/m68klinux-nat.c.orig   2017-04-11 21:51:37.870844712 +0200
-+++ gdb-7.6/gdb/m68klinux-nat.c        2017-04-11 22:17:56.778556705 +0200
-@@ -568,7 +568,7 @@ fetch_core_registers (struct regcache *r
- /* Fetch the thread-local storage pointer for libthread_db.  */
- ps_err_e
--ps_get_thread_area (const struct ps_prochandle *ph, 
-+ps_get_thread_area (struct ps_prochandle *ph, 
-                   lwpid_t lwpid, int idx, void **base)
- {
-   if (ptrace (PTRACE_GET_THREAD_AREA, lwpid, NULL, base) < 0)
---- gdb-7.6/gdb/mips-linux-nat.c.orig  2017-04-11 21:51:38.040853046 +0200
-+++ gdb-7.6/gdb/mips-linux-nat.c       2017-04-11 22:18:09.319176306 +0200
-@@ -154,7 +154,7 @@ mips64_linux_register_addr (struct gdbar
- /* Fetch the thread-local storage pointer for libthread_db.  */
- ps_err_e
--ps_get_thread_area (const struct ps_prochandle *ph,
-+ps_get_thread_area (struct ps_prochandle *ph,
-                     lwpid_t lwpid, int idx, void **base)
- {
-   if (ptrace (PTRACE_GET_THREAD_AREA, lwpid, NULL, base) != 0)
This page took 0.077983 seconds and 4 git commands to generate.