]> git.pld-linux.org Git - packages/crash.git/commitdiff
- updated to 7.1.8
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 11 Apr 2017 18:25:35 +0000 (20:25 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 11 Apr 2017 18:25:35 +0000 (20:25 +0200)
- added gdb-glibc patch (fixes internal gdb build with glibc 2.25)

crash.spec
gdb-glibc.patch [new file with mode: 0644]

index 8f93390da66f7f4743166b4a28e342a569f90989..1ddcd250240219482b2bad1e4650ff53d2e6ffab 100644 (file)
@@ -25,16 +25,17 @@ exit 1
 Summary:       Core Analysis Suite
 Summary(pl.UTF-8):     Zestaw narzędzi do analizy zrzutów pamięci
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       7.1.4
+Version:       7.1.8
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       GPL v2+
 Group:         Libraries
 Source0:       http://people.redhat.com/anderson/%{pname}-%{version}.tar.gz
-# Source0-md5: 4f7a00fd09c1316da8903e8f99188d98
+# Source0-md5: daf5fb52567cfcac99d3a5890edbc707
 # git clone https://code.google.com/p/eppic
 Source1:       eppic.tar.xz
 # Source1-md5: a9f80ad71de9d6f5b77534a7ebdbed8e
 Patch0:                %{pname}-x32.patch
+Patch1:                gdb-glibc.patch
 URL:           http://people.redhat.com/anderson/
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
@@ -115,6 +116,8 @@ Ten pakiet zawiera sterownik pamięci /dev/crash do sesji crash na\
 %prep
 %setup -q -a1 -n %{pname}-%{version}
 %patch0 -p1
+# apply after unpacking gdb-7.6
+cat %{PATCH1} >> gdb-7.6.patch
 
 %{__mv} eppic extensions
 
diff --git a/gdb-glibc.patch b/gdb-glibc.patch
new file mode 100644 (file)
index 0000000..b158715
--- /dev/null
@@ -0,0 +1,23 @@
+Sync ps_get_thread_area() prototype with glibc 2.25.
+--- gdb-7.6/gdb/gdb_proc_service.h.orig        2017-04-11 18:57:07.217202451 +0200
++++ gdb-7.6/gdb/gdb_proc_service.h     2017-04-11 19:06:23.527196100 +0200
+@@ -115,7 +115,7 @@ extern pid_t ps_getpid (struct ps_procha
+ /* Fetch the special per-thread address associated with the given LWP.
+    This call is only used on a few platforms (most use a normal register).
+    The meaning of the `int' parameter is machine-dependent.  */
+-extern ps_err_e ps_get_thread_area (const struct ps_prochandle *,
++extern ps_err_e ps_get_thread_area (struct ps_prochandle *,
+                                   lwpid_t, int, psaddr_t *);
+--- gdb-7.6/gdb/i386-linux-nat.c.orig  2017-04-11 18:57:35.960535456 +0200
++++ gdb-7.6/gdb/i386-linux-nat.c       2017-04-11 19:06:54.617195745 +0200
+@@ -849,7 +849,7 @@ i386_linux_new_fork (struct lwp_info *pa
+    storage (or its descriptor).  */
+ ps_err_e
+-ps_get_thread_area (const struct ps_prochandle *ph, 
++ps_get_thread_area (struct ps_prochandle *ph, 
+                   lwpid_t lwpid, int idx, void **base)
+ {
+   /* NOTE: cagney/2003-08-26: The definition of this buffer is found
This page took 0.115428 seconds and 4 git commands to generate.