]> git.pld-linux.org Git - packages/cpufreqd.git/blob - cpufreqd.spec
- http://belnet.sourceforge->http://dl.sourceforge
[packages/cpufreqd.git] / cpufreqd.spec
1 Summary:        Scales your cpu frequency
2 Summary(pl):    Skalowanie czêstotliwo¶ci procesora
3 Name:           cpufreqd
4 Version:        1.0
5 %define _pre    beta1
6 Release:        1.%{_pre}.1
7 License:        GPL v2
8 Group:          Applications/System
9 Source0:        http://dl.sourceforge.net/sourceforge/%{name}/%{name}-%{version}-%{_pre}.tar.gz
10 # Source0-md5:  d712993e5dfbe18f7111c56127919d82
11 Source1:        %{name}.init
12 Patch0:         %{name}-am.patch
13 URL:            http://www.brodo.de/cpufreq/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This daemon monitors /proc/apm for the battery status and scales your
21 cpu frequency according to a set of rules. It is very useful for
22 providing maximum battery life but good cpu speed at the same time.
23
24 %description -l pl
25 Ten demon monitoruje stan baterii przez /proc/apm i skaluje
26 czêstotliwo¶æ procesora zgodnie z zestawem regu³. Jest bardzo
27 przydatny do zapewniania maksymalnego czasu ¿ycia baterii, a
28 jednocze¶nie dobrej szybko¶ci procesora.
29
30 %prep
31 %setup  -q -n %{name}-%{version}-%{_pre}
32 %patch0 -p1
33
34 %build
35 %{__libtoolize}
36 %{__aclocal}
37 %{__autoconf}
38 %{__automake}
39 %configure \
40         --libdir=%{_libdir}/%{name}
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/%{name}
51 install *.conf $RPM_BUILD_ROOT%{_sysconfdir}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 /sbin/chkconfig --add cpufreqd
58 if [ -f /var/lock/subsys/cpufreqd ]; then
59         /etc/rc.d/init.d/cpufreqd restart >&2
60 else
61         echo "Run \"/etc/rc.d/init.d/cpufreqd start\" to start CPU FREQ daemon."
62 fi
63
64 %preun
65 if [ "$1" = "0" ]; then
66         if [ -f /var/lock/subsys/cpufreqd ]; then
67                 /etc/rc.d/init.d/cpufreqd stop>&2
68         fi
69         /sbin/chkconfig --del cpufreqd
70 fi
71
72 %files
73 %defattr(644,root,root,755)
74 %doc README TODO
75 %attr(754,root,root) %{_bindir}/*
76 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*.conf
77 %{_mandir}/man?/*
78 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
79 %dir %{_libdir}/%{name}
80 %attr(755,root,root) %{_libdir}/%{name}/*
This page took 0.041929 seconds and 3 git commands to generate.