]> git.pld-linux.org Git - packages/cpufreqd.git/blob - cpufreqd.spec
- release 4 (by relup.sh)
[packages/cpufreqd.git] / cpufreqd.spec
1 #
2 # TODO:
3 #   - loading modules in init-script, if needed
4 #   - missing plugin: nvclock
5 #   - move plugins into separate packages? (some is needed, because of additional deps)
6 #   - update Polish translations
7 #
8 Summary:        Fully configurable daemon for dynamic frequency and voltage scaling
9 Summary(pl.UTF-8):      Skalowanie częstotliwości procesora
10 Name:           cpufreqd
11 Version:        2.4.2
12 Release:        3
13 License:        GPL v2
14 Group:          Applications/System
15 Source0:        http://dl.sourceforge.net/cpufreqd/%{name}-%{version}.tar.bz2
16 # Source0-md5:  2ca80a77849c9a69b81e27c1843c97f5
17 Source1:        %{name}.init
18 Patch0:         %{name}-battery.patch
19 URL:            http://www.linux.it/~malattia/wiki/index.php/Cpufreqd
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  cpufrequtils-devel
23 BuildRequires:  libtool
24 BuildRequires:  lm_sensors-devel
25 BuildRequires:  rpmbuild(macros) >= 1.268
26 BuildRequires:  sysfsutils-devel
27 Requires(post): sed >= 4.0
28 Requires(post,preun):   /sbin/chkconfig
29 Requires:       rc-scripts
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 A small daemon to adjust cpu speed and voltage (and not only) for
34 kernels using any of the cpufreq drivers available. Cpufreqd is not a
35 userspace governor.
36 Cpufreqd allows you to apply governor profiles from rules based on
37 battery level, ac status, temperature (ACPI or sensors), running
38 programs, cpu usage and (maybe) more. You can also change your nforce
39 FSB clock and video card frequency (NVidia only) or execute arbitrary
40 commands when a specific rule is applied.
41 You need a CPU with frequency and voltage scaling capabilities and a
42 Linux kernel with cpufreq support.
43
44 %description -l pl.UTF-8
45 Ten demon monitoruje stan baterii przez /proc/apm i skaluje
46 częstotliwość procesora zgodnie z zestawem reguł. Jest bardzo
47 przydatny do zapewniania maksymalnego czasu życia baterii, a
48 jednocześnie dobrej szybkości procesora.
49
50 %prep
51 %setup -q
52 %patch0 -p1
53
54 %build
55 %{__libtoolize}
56 %{__aclocal}
57 %{__autoconf}
58 %{__automake}
59 %configure \
60         --libdir=%{_libdir}/%{name} \
61         --enable-sensors
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post
77 /sbin/chkconfig --add cpufreqd
78 %service cpufreqd restart "CPU FREQ daemon"
79
80 %preun
81 if [ "$1" = "0" ]; then
82         %service cpufreqd stop
83         /sbin/chkconfig --del cpufreqd
84 fi
85
86 %files
87 %defattr(644,root,root,755)
88 %doc README TODO
89 %attr(754,root,root) %{_sbindir}/*
90 %attr(755,root,root) %{_bindir}/*
91 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
92 %{_mandir}/man?/*
93 %attr(754,root,root) /etc/rc.d/init.d/%{name}
94 %dir %{_libdir}/%{name}
95 %attr(755,root,root) %{_libdir}/%{name}/*
This page took 0.052495 seconds and 3 git commands to generate.