]> git.pld-linux.org Git - packages/cpuburn.git/commitdiff
- fix build on 64bit master
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 18 Feb 2013 10:19:42 +0000 (11:19 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 18 Feb 2013 10:19:42 +0000 (11:19 +0100)
cpuburn-makefile.patch
cpuburn-vars.patch [new file with mode: 0644]
cpuburn.spec

index 7580d77e518d61a761d5260799672d933e6ab999..691d5cf595648928801816d11f1a46c9f73b77bc 100644 (file)
@@ -7,4 +7,4 @@
  all : burnP5 burnP6 burnK6 burnK7 burnBX burnMMX
  .S:
 -      gcc -s -nostdlib -o $@ $<
-+      $(CC) $(CFLAGS) -s -nostdlib -o $@ $<
++      $(CC) $(CFLAGS) -s -m32 -nostdlib -o $@ $<
diff --git a/cpuburn-vars.patch b/cpuburn-vars.patch
new file mode 100644 (file)
index 0000000..3e8b666
--- /dev/null
@@ -0,0 +1,40 @@
+--- cpuburn-1.4a.orig/burnK7.S
++++ cpuburn-1.4a/burnK7.S
+@@ -74,6 +74,7 @@ int_exit:
+       push    %eax
+       int     $0x80
+ #endif
++.data                         # Data allocation
+ .align 32,0
+       .fill 64
+ half: .long 0x7fffffff,0
+--- cpuburn-1.4a.orig/burnP5.S
++++ cpuburn-1.4a/burnP5.S
+@@ -77,6 +77,7 @@ crunch:
+ #else
+       int     $0x80
+ #endif
++.data                         # Data allocation
+ .align 32,0
+ half: .long 0xffffffff,0x3fdfffff
+ one:  .long 0xffffffff,0x3fefffff
+--- cpuburn-1.4a.orig/burnP6.S
++++ cpuburn-1.4a/burnP6.S
+@@ -69,6 +69,7 @@ int_exit:                    # error abort
+       push    %eax            # *BSD syscall
+       int     $0x80
+ #endif
++.data                         # Data allocation
+ .align 32,0
+ half: .long 0x7fffffff,0
+ e:    .long 0xffffffff,0x3fdfffff
+--- cpuburn-1.4a.orig/burnK6.S
++++ cpuburn-1.4a/burnK6.S
+@@ -68,6 +68,7 @@ int_exit:
+       push    %eax
+       int     $0x80
+ #endif
++.data                         # Data allocation
+ .align 32,0
+ half: .long 0x7fffffff,0
+ e:    .long 0xffffffff,0x3fdfffff
index 4cefa3c0491f4a49956b069d4d633a2a17702621..1f4887d51b11596bd018350c8c809733df889f12 100644 (file)
@@ -8,6 +8,7 @@ Group:          Applications
 Source0:       http://pages.sbcglobal.net/redelm/%{name}_1_4_tar.gz
 # Source0-md5: f9bb5ff68afb6ccfca11718c90bcab68
 Patch0:                %{name}-makefile.patch
+Patch1:                %{name}-vars.patch
 URL:           http://pages.sbcglobal.net/redelm/
 ExclusiveArch: i486 i586 i686 athlon %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -38,6 +39,7 @@ także trwałe uszkodzenia sprzętu. Używasz na własne ryzyko!!
 %prep
 %setup  -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__make} \
This page took 0.092471 seconds and 4 git commands to generate.