]> git.pld-linux.org Git - packages/cproto.git/commitdiff
- cproto patch.
authorkloczek <kloczek@pld-linux.org>
Fri, 4 Jun 1999 08:14:48 +0000 (08:14 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cproto.patch -> 1.1

cproto.patch [new file with mode: 0644]

diff --git a/cproto.patch b/cproto.patch
new file mode 100644 (file)
index 0000000..25662c8
--- /dev/null
@@ -0,0 +1,65 @@
+diff -uNr cproto-4.6/Makefile.in cproto-4.6.new/Makefile.in
+--- cproto-4.6/Makefile.in     Sat Jan 24 03:42:00 1998
++++ cproto-4.6.new/Makefile.in Mon Mar 15 17:59:07 1999
+@@ -4,7 +4,7 @@
+ # UNIX template-makefile for C prototype generator
+ THIS = cproto
+-RELEASE = 4_6
++RELEASE = 4_6_1
+ #### Start of system configuration section. ####
+@@ -21,7 +21,7 @@
+ INSTALL_PROGRAM       = @INSTALL_PROGRAM@
+ INSTALL_DATA  = @INSTALL_DATA@
+-DEFINES               =
++DEFINES               = -DMAX_INC_DIR=64 -DMAX_INC_DEPTH=64
+ CPPFLAGS      = -I$(srcdir) $(DEFINES) -DHAVE_CONFIG_H @CPPFLAGS@
+ CFLAGS                = @CFLAGS@ $(CPPFLAGS)
+ LIBS          = @LIBS@ @LEXLIB@
+diff -uNr cproto-4.6/cproto.c cproto-4.6.new/cproto.c
+--- cproto-4.6/cproto.c        Sat Jan 24 03:42:07 1998
++++ cproto-4.6.new/cproto.c    Mon Mar 15 18:00:01 1999
+@@ -2,7 +2,7 @@
+  *
+  * C function prototype generator and function definition converter
+  */
+-#define VERSION "4.6"
++#define VERSION "4.6.1"
+ #include <stdio.h>
+ #include <ctype.h>
+diff -uNr cproto-4.6/yyerror.c cproto-4.6.new/yyerror.c
+--- cproto-4.6/yyerror.c       Sat Apr 13 07:29:18 1996
++++ cproto-4.6.new/yyerror.c   Mon Mar 15 17:58:29 1999
+@@ -126,22 +126,16 @@
+     if (count < 0) {
+       if (last++ >= 0) {
+           qsort((char *)vec, (size_t)last, sizeof(vec[0]), compar);
+-          /* limit length of error message */
+-          k = 80 - (strlen(vec[last-1]) + 2);
++
+           for (j = 0; j < last; j++) {
+               tag = j ? " " : "Expected: ";
+-              s = vec[j];
+-              if (j != (last - 1)) {
+-                  x = strlen(s) + strlen(tag);
+-                  if (k <= 0)
+-                      continue;
+-                  else if ((k - x) <= 0)
+-                      s = "...";
+-                  k -= x;
+-              }
+-              fprintf(stderr, "%s%s", tag, s);
++
++              if (vec[j])
++                  fprintf(stderr, "%s%s", tag, vec[j]);
+           }
++          
+           fprintf(stderr, "\n");
++
+           while (--last >= 0)
+               free(vec[last]);
+       }
This page took 0.08369 seconds and 4 git commands to generate.