]> git.pld-linux.org Git - packages/cppunit.git/blob - cppunit.spec
- unconditional noarch subpackages
[packages/cppunit.git] / cppunit.spec
1 Summary:        The C++ Unit Test Library
2 Summary(pl.UTF-8):      Biblioteka testowa do C++
3 Name:           cppunit
4 Version:        1.14.0
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://dev-www.libreoffice.org/src/%{name}-%{version}.tar.gz
9 # Source0-md5:  7ad93022171710a541bfe4bfd8b4a381
10 URL:            https://www.freedesktop.org/wiki/Software/cppunit/
11 BuildRequires:  autoconf >= 2.65
12 BuildRequires:  automake >= 1:1.11
13 BuildRequires:  doxygen
14 BuildRequires:  libstdc++-devel >= 6:4.7
15 BuildRequires:  libtool >= 2:1.4d
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 CppUnit is the C++ port of the famous JUnit framework for unit
20 testing.
21
22 %description -l pl.UTF-8
23 CppUnit jest portem C++ słynnego środowiska testowego JUnit.
24
25 %package devel
26 Summary:        cppunit header files
27 Summary(pl.UTF-8):      Pliki nagłówkowe cppunit
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30 Requires:       libstdc++-devel >= 6:4.7
31
32 %description devel
33 cppunit header files.
34
35 %description devel -l pl.UTF-8
36 Pliki nagłówkowe cppunit.
37
38 %package static
39 Summary:        cppunit static library
40 Summary(pl.UTF-8):      Statyczna biblioteka cppunit
41 Group:          Development/Libraries
42 Requires:       %{name}-devel = %{version}-%{release}
43
44 %description static
45 cppunit static library.
46
47 %description static -l pl.UTF-8
48 Statyczna biblioteka cppunit.
49
50 %package apidocs
51 Summary:        cppunit API documentation
52 Summary(pl.UTF-8):      Dokumentacja API cppunit
53 Group:          Documentation
54 %if "%{_rpmversion}" >= "5"
55 BuildArch:      noarch
56 %endif
57
58 %description apidocs
59 cppunit API documentation.
60
61 %description apidocs -l pl.UTF-8
62 Dokumentacja API cppunit.
63
64 %prep
65 %setup -q
66
67 %build
68 %{__libtoolize}
69 %{__aclocal} -I config
70 %{__autoconf}
71 %{__autoheader}
72 %{__automake}
73 %configure \
74         --disable-silent-rules
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 # obsoleted by pkg-config
84 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcppunit.la
85 # non-Linux
86 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/cppunit/config/config-{bcb5,evc4,mac,msvc6}.h
87 # packaged as %doc in -apidocs
88 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/cppunit/html
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS BUGS NEWS README THANKS TODO
99 %attr(755,root,root) %{_bindir}/DllPlugInTester
100 %attr(755,root,root) %{_libdir}/libcppunit-1.14.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libcppunit-1.14.so.0
102
103 %files devel
104 %defattr(644,root,root,755)
105 %doc doc/FAQ
106 %attr(755,root,root) %{_libdir}/libcppunit.so
107 %{_includedir}/cppunit
108 %{_pkgconfigdir}/cppunit.pc
109
110 %files static
111 %defattr(644,root,root,755)
112 %{_libdir}/libcppunit.a
113
114 %files apidocs
115 %defattr(644,root,root,755)
116 %doc doc/html/*
This page took 0.065067 seconds and 3 git commands to generate.