]> git.pld-linux.org Git - packages/cpplint.git/commitdiff
- initial master
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 30 Jan 2010 07:43:42 +0000 (07:43 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cpplint.spec -> 1.1

cpplint.spec [new file with mode: 0644]

diff --git a/cpplint.spec b/cpplint.spec
new file mode 100644 (file)
index 0000000..6619c84
--- /dev/null
@@ -0,0 +1,44 @@
+%define                svnrev  43
+%define                rel             1
+Summary:       C++ lint your files
+Name:          cpplint
+Version:       0.1
+Release:       0.1
+License:       Artistic License/GPL
+Group:         Development/Tools
+# svn co http://google-styleguide.googlecode.com/svn/trunk/cpplint
+# tar -cjf cpplint-$(svnversion cpplint).tar.bz2 --exclude=.svn --remove-files cpplint
+Source0:       %{name}-%{svnrev}.tar.bz2
+# Source0-md5: b34ddbdddab368aa071731cee3470fc2
+URL:           http://google-styleguide.googlecode.com/svn/trunk/cpplint/
+BuildRequires: rpm-pythonprov
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This is automated checker to make sure a C++ file follows Google's C++
+style guide
+<http://google-styleguide.googlecode.com/svn/trunk/cppguide.xml>.
+
+As it heavily relies on regular expressions, cpplint.py won't catch
+all violations of the style guide and will very occasionally report a
+false positive. There is a list of things we currently don't handle
+very well at the top of cpplint.py, and we welcome patches to improve
+it.
+
+%prep
+%setup -q -n %{name}
+%{__sed} -i -e '1s,#!.*python\(2\..\)\?,#!%{__python},' *.py
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_bindir}
+install -p %{name}.py $RPM_BUILD_ROOT%{_bindir}/%{name}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README
+%attr(755,root,root) %{_bindir}/cpplint
This page took 0.085302 seconds and 4 git commands to generate.