]> git.pld-linux.org Git - packages/cpplint.git/blob - cpplint.spec
- initial
[packages/cpplint.git] / cpplint.spec
1 %define         svnrev  43
2 %define         rel             1
3 Summary:        C++ lint your files
4 Name:           cpplint
5 Version:        0.1
6 Release:        0.1
7 License:        Artistic License/GPL
8 Group:          Development/Tools
9 # svn co http://google-styleguide.googlecode.com/svn/trunk/cpplint
10 # tar -cjf cpplint-$(svnversion cpplint).tar.bz2 --exclude=.svn --remove-files cpplint
11 Source0:        %{name}-%{svnrev}.tar.bz2
12 # Source0-md5:  b34ddbdddab368aa071731cee3470fc2
13 URL:            http://google-styleguide.googlecode.com/svn/trunk/cpplint/
14 BuildRequires:  rpm-pythonprov
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 This is automated checker to make sure a C++ file follows Google's C++
20 style guide
21 <http://google-styleguide.googlecode.com/svn/trunk/cppguide.xml>.
22
23 As it heavily relies on regular expressions, cpplint.py won't catch
24 all violations of the style guide and will very occasionally report a
25 false positive. There is a list of things we currently don't handle
26 very well at the top of cpplint.py, and we welcome patches to improve
27 it.
28
29 %prep
30 %setup -q -n %{name}
31 %{__sed} -i -e '1s,#!.*python\(2\..\)\?,#!%{__python},' *.py
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35 install -d $RPM_BUILD_ROOT%{_bindir}
36 install -p %{name}.py $RPM_BUILD_ROOT%{_bindir}/%{name}
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %defattr(644,root,root,755)
43 %doc README
44 %attr(755,root,root) %{_bindir}/cpplint
This page took 0.087008 seconds and 3 git commands to generate.