]> git.pld-linux.org Git - packages/cpplint.git/blame - cpplint.spec
- initial
[packages/cpplint.git] / cpplint.spec
CommitLineData
5348b0b8
ER
1%define svnrev 43
2%define rel 1
3Summary: C++ lint your files
4Name: cpplint
5Version: 0.1
6Release: 0.1
7License: Artistic License/GPL
8Group: Development/Tools
9# svn co http://google-styleguide.googlecode.com/svn/trunk/cpplint
10# tar -cjf cpplint-$(svnversion cpplint).tar.bz2 --exclude=.svn --remove-files cpplint
11Source0: %{name}-%{svnrev}.tar.bz2
12# Source0-md5: b34ddbdddab368aa071731cee3470fc2
13URL: http://google-styleguide.googlecode.com/svn/trunk/cpplint/
14BuildRequires: rpm-pythonprov
15BuildArch: noarch
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%description
19This is automated checker to make sure a C++ file follows Google's C++
20style guide
21<http://google-styleguide.googlecode.com/svn/trunk/cppguide.xml>.
22
23As it heavily relies on regular expressions, cpplint.py won't catch
24all violations of the style guide and will very occasionally report a
25false positive. There is a list of things we currently don't handle
26very well at the top of cpplint.py, and we welcome patches to improve
27it.
28
29%prep
30%setup -q -n %{name}
31%{__sed} -i -e '1s,#!.*python\(2\..\)\?,#!%{__python},' *.py
32
33%install
34rm -rf $RPM_BUILD_ROOT
35install -d $RPM_BUILD_ROOT%{_bindir}
36install -p %{name}.py $RPM_BUILD_ROOT%{_bindir}/%{name}
37
38%clean
39rm -rf $RPM_BUILD_ROOT
40
41%files
42%defattr(644,root,root,755)
43%doc README
44%attr(755,root,root) %{_bindir}/cpplint
This page took 0.068913 seconds and 4 git commands to generate.