]> git.pld-linux.org Git - packages/cpp-netlib.git/blame - cpp-netlib.spec
update BR
[packages/cpp-netlib.git] / cpp-netlib.spec
CommitLineData
718b5c3e
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
5Summary: The C++ Network Library Project
6Name: cpp-netlib
7Version: 0.11.1
8Release: 1
9License: Boost Software License
10Group: Libraries
11Source0: https://github.com/cpp-netlib/cpp-netlib/archive/%{name}-%{version}-final.tar.gz
12# Source0-md5: 72f3653254935038876b867417de8c74
13URL: http://cpp-netlib.org/
d5f7517c 14BuildRequires: boost-devel
718b5c3e
ER
15BuildRequires: cmake
16BuildRequires: libstdc++-devel
d5f7517c 17BuildRequires: openssl-devel
718b5c3e
ER
18BuildRequires: rpmbuild(macros) >= 1.583
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21# Unresolved symbols boost::system::system_category(), boost::system::generic_category()
22%define skip_post_check_so libcppnetlib-client-connections.so.0.11.0
23
24%description
25The project aims to build upon the latest C++ standard (currently
26C++11) to provide easy to use libraries for network programming. We
27use the latest compiler versions and features with an eye on pushing
28the boundaries on leveraging what's available in C++.
29
30Currently the library contains an HTTP client and server
31implementation, a stand-alone URI library, a network message
32framework, and some concurrency tools.
33
34%package devel
35Summary: Header files for %{name} library
36Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39Requires: boost-devel
40
41%description devel
42Header files for %{name} library.
43
44%description devel -l pl.UTF-8
45Pliki nagłówkowe biblioteki %{name}.
46
47%prep
48%setup -qc
49mv cpp-netlib-cpp-netlib-%{version}-final/* .
50
51%build
52install -d build
53cd build
54%cmake \
55 -DINSTALL_CMAKE_DIR=%{_datadir}/cmake/Modules \
56 ..
57%{__make}
58%{?with_tests:%{__make} test}
59
60%install
61rm -rf $RPM_BUILD_ROOT
62%{__make} -C build install \
63 DESTDIR=$RPM_BUILD_ROOT
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%post -p /sbin/ldconfig
69%postun -p /sbin/ldconfig
70
71%files
72%defattr(644,root,root,755)
73%doc README.rst RATIONALE.txt LICENSE_1_0.txt
74%attr(755,root,root) %{_libdir}/libcppnetlib-client-connections.so.*.*.*
75%ghost %{_libdir}/libcppnetlib-client-connections.so.0
76%attr(755,root,root) %{_libdir}/libcppnetlib-server-parsers.so.*.*.*
77%ghost %{_libdir}/libcppnetlib-server-parsers.so.0
78%attr(755,root,root) %{_libdir}/libcppnetlib-uri.so.*.*.*
79%ghost %{_libdir}/libcppnetlib-uri.so.0
80
81%files devel
82%defattr(644,root,root,755)
83%{_libdir}/libcppnetlib-client-connections.so
84%{_libdir}/libcppnetlib-server-parsers.so
85%{_libdir}/libcppnetlib-uri.so
86%{_includedir}/boost/*.hpp
87%{_includedir}/boost/network
88%{_datadir}/cmake/Modules/cppnetlibConfig.cmake
89%{_datadir}/cmake/Modules/cppnetlibConfigVersion.cmake
90%{_datadir}/cmake/Modules/cppnetlibTargets-pld.cmake
91%{_datadir}/cmake/Modules/cppnetlibTargets.cmake
This page took 0.089925 seconds and 4 git commands to generate.