]> git.pld-linux.org Git - packages/cpan2rpm.git/blob - cpan2rpm.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/cpan2rpm.git] / cpan2rpm.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Create RPMS from CPAN modules
7 Summary(pl.UTF-8):      Narzędzie tworzące pakiety RPM z modułów CPAN
8 Name:           cpan2rpm
9 Version:        2.028
10 Release:        1
11 License:        GPL v2+
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/authors/id/E/EC/ECALDER/%{name}-%{version}.tar.gz
14 # Source0-md5:  4f85e07dfa848e5b72791aed975e8bc4
15 Patch0:         %{name}-make.patch
16 URL:            http://perl.arix.com/cpan2rpm/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 cpan2rpm creates RPMs from CPAN packages, automating the locating,
24 fetching, spec file creation and building of the package.
25
26 %description -l pl.UTF-8
27 cpan2rpm tworzy pakiety RPM z pakietów CPAN, automatycznie je
28 znajdując, ściągając, tworząc plik spec i budując pakiet.
29
30 %prep
31 %setup -q
32 %patch0 -p1
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37
38 # avoid running cpan2rpm and using network
39 touch cpan2rpm.spec
40
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %attr(755,root,root) %{_bindir}/*
58 %{_mandir}/man1/*
This page took 0.072344 seconds and 3 git commands to generate.