]> git.pld-linux.org Git - packages/couchdb.git/commitdiff
- New spec file.
authorjaphy <japhy@pld-linux.org>
Sun, 8 Jun 2008 13:23:14 +0000 (13:23 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    couchdb.spec -> 1.1

couchdb.spec [new file with mode: 0644]

diff --git a/couchdb.spec b/couchdb.spec
new file mode 100644 (file)
index 0000000..67658ea
--- /dev/null
@@ -0,0 +1,115 @@
+#
+%define        snap    20080608 
+Summary:       A distributed document-oriented database
+Summary(pl.UTF-8):     Rozproszona baza danych oparta o dokumenty
+Name:          couchdb
+Version:       0.8
+Release:       0.%{snap}
+License:       Apache
+Group:         Applications
+Source0:       %{name}-%{version}-%{snap}.tar.gz
+# Source0-md5: f2f7c819f3b562887ed0c336d36c6b38
+Source1:       %{name}.init
+URL:           http://incubator.apache.org/couchdb/
+BuildRequires: rpmbuild(macros) >= 1.228
+Requires(post,preun):  /sbin/chkconfig
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: erlang >= 
+BuildRequires: help2man
+BuildRequires: intltool
+Requires(post,preun):  /sbin/chkconfig
+Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
+Provides:      group(couchdb)
+Provides:      user(couchdb)
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Apache CouchDB is a distributed, fault-tolerant and schema-free
+document-oriented database accessible via a RESTful HTTP/JSON
+API. Among other features, it provides robust, incremental replication
+with bi-directional conflict detection and resolution, and is
+queryable and indexable using a table-oriented view engine with
+JavaScript acting as the default view definition language.
+
+%description -l pl.UTF-8
+
+Apache CouchDB jest rozproszoną, odporną na błędy, nie wymagającą
+schematów, zorientowaną na dokument bazą danych z RESTowym API opartym
+o HTTP/JSON.  Między innymi zapewnia solidną, przyrostową replikację
+z dwukierunkowym wykrywaniem i rozwiązywaniem konfliktów, oraz odpytywanie
+i indeksowanie za pośrednictwem opartego na tablicach silnika widoków
+używającego JavaScriptu jako głównego języka definicji widoku.
+
+%prep
+%setup -q -n %{name}
+touch ChangeLog # needed by ./configure
+
+%build
+./bootstrap
+%configure --with-erlang=%{_libdir}/erlang/usr/include
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+rm -rf $RPM_BUILD_ROOT%{_defaultdocdir}/*
+
+mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%pre
+%groupadd -g 230 couchdb
+%useradd -u 230 -g couchdb -c "CouchDB server" couchdb
+
+%post
+/sbin/chkconfig --add %{name}
+%service %{name} restart "CouchDB server"
+
+%preun
+if [ "$1" = "0" ]; then
+       %service %{name} stop
+       /sbin/chkconfig --del %{name}
+fi
+
+%postun
+
+%if %{with initscript}
+%post init
+/sbin/chkconfig --add %{name}
+%service %{name} restart
+
+%preun init
+if [ "$1" = "0" ]; then
+       %service -q %{name} stop
+       /sbin/chkconfig --del %{name}
+fi
+%endif
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS BUGS CHANGES NEWS NOTICE README THANKS
+%attr(755,root,root) %{_bindir}/*
+%{_datadir}/apache-couchdb
+%{_libdir}/apache-couchdb
+%dir %{_sysconfdir}/apache-couchdb/
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache-couchdb/couch.ini
+%attr(700,couchdb,couchdb) %dir %{_sharedstatedir}/apache-couchdb
+%attr(700,couchdb,couchdb) %dir %{_localstatedir}/log/apache-couchdb
+%{_mandir}/man1/*
+%attr(754,root,root) /etc/rc.d/init.d/%{name}
+
+# initscript and its config
+%if %{with initscript}
+%attr(754,root,root) /etc/rc.d/init.d/%{name}
+%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
+%endif
This page took 0.165069 seconds and 4 git commands to generate.