]> git.pld-linux.org Git - packages/couchdb.git/blob - couchdb.spec
- merge todo
[packages/couchdb.git] / couchdb.spec
1 #
2 # TODO:
3 # - init script, sysconfig
4 # - merge apache-couchdb/apache-couchdb.spec here
5 #
6 Summary:        A distributed document-oriented database
7 Summary(pl.UTF-8):      Rozproszona baza danych oparta o dokumenty
8 Name:           couchdb
9 Version:        1.0.1
10 Release:        0.1
11 License:        Apache
12 Group:          Applications
13 Source0:        http://www.apache.net.pl/couchdb/1.0.1/apache-%{name}-%{version}.tar.gz
14 # Source0-md5:  001cf286b72492617e9ffba271702a00
15 #Source1:       %{name}.init
16 URL:            http://incubator.apache.org/couchdb/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  curl-devel >= 7.18.0
20 BuildRequires:  erlang
21 BuildRequires:  help2man
22 BuildRequires:  intltool
23 BuildRequires:  js-devel
24 BuildRequires:  libicu-devel >= 3.4.1
25 BuildRequires:  pakchois-devel
26 BuildRequires:  rpmbuild(macros) >= 1.228
27 Requires(post,preun):   /sbin/chkconfig
28 Requires(post,preun):   /sbin/chkconfig
29 Requires(pre):  /bin/id
30 Requires(pre):  /usr/bin/getgid
31 Requires(pre):  /usr/sbin/groupadd
32 Requires(pre):  /usr/sbin/useradd
33 Provides:       group(couchdb)
34 Provides:       user(couchdb)
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Apache CouchDB is a distributed, fault-tolerant and schema-free
39 document-oriented database accessible via a RESTful HTTP/JSON
40 API. Among other features, it provides robust, incremental replication
41 with bi-directional conflict detection and resolution, and is
42 queryable and indexable using a table-oriented view engine with
43 JavaScript acting as the default view definition language.
44
45 %description -l pl.UTF-8
46
47 Apache CouchDB jest rozproszoną, odporną na błędy, nie wymagającą
48 schematów, zorientowaną na dokument bazą danych z RESTowym API opartym
49 o HTTP/JSON.  Między innymi zapewnia solidną, przyrostową replikację
50 z dwukierunkowym wykrywaniem i rozwiązywaniem konfliktów, oraz odpytywanie
51 i indeksowanie za pośrednictwem opartego na tablicach silnika widoków
52 używającego JavaScriptu jako głównego języka definicji widoku.
53
54 %prep
55 %setup -q -n apache-%{name}-%{version}
56
57 %build
58 %configure --with-erlang=%{_libdir}/erlang/usr/include
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 rm -rf $RPM_BUILD_ROOT%{_defaultdocdir}/*
68
69 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
70
71 mv $RPM_BUILD_ROOT/etc/rc.d/{,init.d}/%{name}
72 #install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %pre
78 %groupadd -g 230 couchdb
79 %useradd -u 230 -g couchdb -c "CouchDB server" couchdb
80
81 %post
82 /sbin/chkconfig --add %{name}
83 %service %{name} restart "CouchDB server"
84
85 %preun
86 if [ "$1" = "0" ]; then
87         %service %{name} stop
88         /sbin/chkconfig --del %{name}
89 fi
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS BUGS CHANGES NEWS NOTICE README THANKS
94 %attr(755,root,root) %{_bindir}/*
95 %{_datadir}/couchdb
96 %{_libdir}/couchdb
97 %dir %{_sysconfdir}/couchdb
98 %dir %{_sysconfdir}/couchdb/default.d
99 %dir %{_sysconfdir}/couchdb/local.d
100 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/couchdb/*.ini
101 %attr(700,couchdb,couchdb) %dir %{_sharedstatedir}/couchdb
102 %attr(700,couchdb,couchdb) %dir %{_localstatedir}/log/couchdb
103 %{_mandir}/man1/*
104 %attr(754,root,root) /etc/rc.d/init.d/%{name}
105 #config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
This page took 0.062462 seconds and 3 git commands to generate.