]> git.pld-linux.org Git - packages/corona.git/blob - corona.spec
- release 12 (rebuild without libgif.la)
[packages/corona.git] / corona.spec
1 Summary:        Image input/output library
2 Summary(pl.UTF-8):      Biblioteka wejścia/wyjścia dla obrazów
3 Name:           corona
4 Version:        1.0.2
5 Release:        10
6 License:        zlib
7 Group:          Libraries
8 Source0:        http://downloads.sourceforge.net/corona/%{name}-%{version}.tar.gz
9 # Source0-md5:  29d1a7f1e2c85a83e9620496c62740ce
10 Patch0:         %{name}-system-gif.patch
11 Patch1:         %{name}-config.patch
12 Patch2:         %{name}-gcc43.patch
13 Patch3:         %{name}-libpng15.patch
14 Patch4:         giflib5.patch
15 URL:            http://corona.sourceforge.net/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  dos2unix
19 BuildRequires:  giflib-devel >= 4.1.0
20 BuildRequires:  libjpeg-devel
21 BuildRequires:  libpng-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool >= 2:1.5
24 BuildRequires:  rpmbuild(macros) >= 1.565
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Corona is an image input/output library that can read, write, and
29 manipulate image files in just a few lines of code. It can write PNG
30 and TGA files, and read PNG, JPEG, PCX, BMP, TGA, and GIF. Corona was
31 designed to be easy to use, and exports a straightforward C++ API.
32 With just a few lines of C++, you can add image loading to your
33 application.
34
35 %description -l pl.UTF-8
36 Corona to biblioteka wejścia/wyjścia dla obrazów, potrafiąca czytać,
37 zapisywać i obrabiać pliki obrazów w zaledwie kilku liniach kodu.
38 Potrafi zapisywać pliki PNG i TGA, a czytać PNG, JPEG, PCX, BMP, TGA i
39 GIF. Została zaprojektowana jako łatwa w użyciu i eksportuje
40 bezpośrednie API C++. Za pomocą tylko kilku linii kodu C++ można dodać
41 wczytywanie obrazów do swojej aplikacji.
42
43 %package devel
44 Summary:        Header files for corona library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki corona
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       giflib-devel >= 4.1.0
49 Requires:       libjpeg-devel
50 Requires:       libpng-devel
51 Requires:       libstdc++-devel
52
53 %description devel
54 Header files for corona library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki corona.
58
59 %package static
60 Summary:        Static corona library
61 Summary(pl.UTF-8):      Statyczna biblioteka corona
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static corona library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka corona.
70
71 %prep
72 %setup -q
73 %undos src/*.cpp src/*.h
74 %patch0 -p1
75 %patch1 -p1
76 %patch2 -p1
77 %patch3 -p1
78 %patch4 -p1
79
80 %build
81 %{__libtoolize}
82 %{__aclocal}
83 %{__autoconf}
84 %{__automake}
85 %configure
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc doc/{changelog.txt,faq.txt,license.txt,literature.txt,readme.txt}
103 %attr(755,root,root) %{_bindir}/corconvert
104 %attr(755,root,root) %{_libdir}/libcorona-*.so
105
106 %files devel
107 %defattr(644,root,root,755)
108 %doc doc/tutorial.txt
109 %attr(755,root,root) %{_bindir}/corona-config
110 %attr(755,root,root) %{_libdir}/libcorona.so
111 %{_libdir}/libcorona.la
112 %{_includedir}/corona.h
113
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/libcorona.a
This page took 0.10635 seconds and 3 git commands to generate.