]> git.pld-linux.org Git - packages/coreutils.git/commitdiff
- updated to 8.20 auto/th/coreutils-8.20-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 18 Nov 2012 08:09:55 +0000 (09:09 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 18 Nov 2012 08:09:55 +0000 (09:09 +0100)
- updated pl.po-update,info,getgid patches

coreutils-getgid.patch
coreutils-info.patch
coreutils-pl.po-update.patch
coreutils.spec

index b8c836cb0378913ae321bd83e72172ea3bb80847..a7a5b5797d98a40c8831d77e8c460af4e94e3d81 100644 (file)
@@ -10,17 +10,16 @@ diff -urN coreutils-8.16.orig//README coreutils-8.16/README
    link ln logname ls md5sum mkdir mkfifo mknod mktemp mv nice nl nohup
    nproc od paste pathchk pinky pr printenv printf ptx pwd readlink realpath
    rm rmdir runcon seq sha1sum sha224sum sha256sum sha384sum sha512sum shred
-diff -urN coreutils-8.16.orig//man/Makefile.am coreutils-8.16/man/Makefile.am
---- coreutils-8.16.orig//man/Makefile.am       2012-03-26 09:50:41.000000000 +0000
-+++ coreutils-8.16/man/Makefile.am     2012-04-18 09:07:17.410850573 +0000
-@@ -60,6 +60,7 @@
- false.1:      $(common_dep)   $(srcdir)/false.x       ../src/false.c
- fmt.1:                $(common_dep)   $(srcdir)/fmt.x         ../src/fmt.c
- fold.1:               $(common_dep)   $(srcdir)/fold.x        ../src/fold.c
-+getgid.1:     $(common_dep)   $(srcdir)/getgid.x      ../src/getgid.c
- groups.1:     $(common_dep)   $(srcdir)/groups.x      ../src/groups.c
- head.1:               $(common_dep)   $(srcdir)/head.x        ../src/head.c
- hostid.1:     $(common_dep)   $(srcdir)/hostid.x      ../src/hostid.c
+--- coreutils-8.20/man/local.mk.orig   2012-11-18 07:54:05.958535288 +0100
++++ coreutils-8.20/man/local.mk        2012-11-18 07:55:01.678534127 +0100
+@@ -87,6 +87,7 @@
+ man/false.1:     src/false
+ man/fmt.1:       src/fmt
+ man/fold.1:      src/fold
++man/getgid.1:    src/getgid
+ man/groups.1:    src/groups
+ man/head.1:      src/head
+ man/hostid.1:    src/hostid
 diff -urN coreutils-8.16.orig//man/getgid.1 coreutils-8.16/man/getgid.1
 --- coreutils-8.16.orig//man/getgid.1  1970-01-01 00:00:00.000000000 +0000
 +++ coreutils-8.16/man/getgid.1        2012-04-18 09:07:17.410850573 +0000
@@ -111,17 +110,16 @@ diff -urN coreutils-8.16.orig//po/pl.po coreutils-8.16/po/pl.po
  #. This is a proper name. See the gettext manual, section Names.
  #: src/env.c:32 src/printenv.c:45 src/whoami.c:35
  msgid "Richard Mlynarik"
-diff -urN coreutils-8.16.orig//src/Makefile.am coreutils-8.16/src/Makefile.am
---- coreutils-8.16.orig//src/Makefile.am       2012-03-24 18:22:13.000000000 +0000
-+++ coreutils-8.16/src/Makefile.am     2012-04-18 09:07:17.411850524 +0000
-@@ -69,6 +69,7 @@
-   false               \
-   fmt         \
-   fold                \
-+  getgid      \
-   ginstall    \
-   groups      \
-   head                \
+--- coreutils-8.20/src/local.mk.orig   2012-11-18 07:56:05.651866127 +0100
++++ coreutils-8.20/src/local.mk        2012-11-18 07:59:50.728528105 +0100
+@@ -122,6 +122,7 @@
+ src_false_LDADD = $(LDADD)
+ src_fmt_LDADD = $(LDADD)
+ src_fold_LDADD = $(LDADD)
++src_getgid_LDADD = $(LDADD)
+ src_getlimits_LDADD = $(LDADD)
+ src_ginstall_LDADD = $(LDADD)
+ src_groups_LDADD = $(LDADD)
 diff -urN coreutils-8.16.orig//src/getgid.c coreutils-8.16/src/getgid.c
 --- coreutils-8.16.orig//src/getgid.c  1970-01-01 00:00:00.000000000 +0000
 +++ coreutils-8.16/src/getgid.c        2012-04-18 09:44:16.000000000 +0000
@@ -214,3 +212,13 @@ diff -urN coreutils-8.16.orig//src/getgid.c coreutils-8.16/src/getgid.c
 +    printf("%lu\n", (unsigned long int) gr->gr_gid);
 +  exit(EXIT_SUCCESS);
 +}
+--- coreutils-8.20/build-aux/gen-lists-of-programs.sh.orig     2012-10-23 16:14:12.000000000 +0200
++++ coreutils-8.20/build-aux/gen-lists-of-programs.sh  2012-11-18 08:48:50.915133486 +0100
+@@ -66,6 +66,7 @@
+     false
+     fmt
+     fold
++    getgid
+     ginstall
+     groups
+     head
index d4b80f10644dbc7249804f3ede0a74b0ee4c2ac4..8aab476f550609d271717c4d9b8e5d08e467f8aa 100644 (file)
@@ -1,5 +1,5 @@
---- coreutils-8.19/doc/coreutils.texi.orig     2012-08-15 19:32:54.000000000 +0200
-+++ coreutils-8.19/doc/coreutils.texi  2012-10-14 11:45:06.772459710 +0200
+--- coreutils-8.20/doc/coreutils.texi.orig     2012-10-23 16:14:12.000000000 +0200
++++ coreutils-8.20/doc/coreutils.texi  2012-11-18 07:50:44.871872811 +0100
 @@ -20,119 +20,111 @@
  @syncodeindex pg cp
  @syncodeindex vr cp
  @section @command{md5sum}: Print or check MD5 digests
  
  @pindex md5sum
-@@ -3738,7 +3723,7 @@
+@@ -3749,7 +3734,7 @@
  @exitstatus
  
  
  @section @command{sha1sum}: Print or check SHA-1 digests
  
  @pindex sha1sum
-@@ -3750,7 +3735,7 @@
+@@ -3761,7 +3746,7 @@
  
  @command{sha1sum} computes a 160-bit checksum for each specified
  @var{file}.  The usage and options of this command are precisely the
  
  Note: The SHA-1 digest is more secure than MD5, and no collisions of
  it are known (different files having the same fingerprint).  However,
-@@ -3790,7 +3775,7 @@
+@@ -3801,7 +3786,7 @@
  various lengths (respectively 224, 256, 384 and 512 bits),
  collectively known as the SHA-2 hashes.  The usage and options of
  these commands are precisely the same as for @command{md5sum}.
  
  Note: The SHA384 and SHA512 digests are considerably slower to
  compute, especially on 32-bit computers, than SHA224 or SHA256.
-@@ -3805,16 +3790,16 @@
+@@ -3816,16 +3801,16 @@
  These commands work with (or produce) sorted files.
  
  @menu
  @section @command{sort}: Sort text files
  
  @pindex sort
-@@ -4100,7 +4085,7 @@
+@@ -4111,7 +4096,7 @@
  Sort by hashing the input keys and then sorting the hash values.
  Choose the hash function at random, ensuring that it is free of
  collisions so that differing keys have differing hash values.  This is
  except that keys with the same value sort together.
  
  If multiple random sort fields are specified, the same random hash
-@@ -4288,7 +4273,7 @@
+@@ -4299,7 +4284,7 @@
  @var{n} is set to the number of available processors, but limited
  to 8, as there are diminishing performance gains after that.
  Note also that using @var{n} threads increases the memory usage by
  
  @item -u
  @itemx --unique
-@@ -4306,7 +4291,7 @@
+@@ -4317,7 +4302,7 @@
  this equivalence does not extend to arbitrary @command{sort} options.
  For example, @code{sort -n -u} inspects only the value of the initial
  numeric string when checking for uniqueness, whereas @code{sort -n |
  
  @macro zeroTerminatedOption
  @item -z
-@@ -4529,7 +4514,7 @@
+@@ -4540,7 +4525,7 @@
  @end itemize
  
  
  @section @command{shuf}: Shuffling text
  
  @pindex shuf
-@@ -4659,7 +4644,7 @@
+@@ -4670,7 +4655,7 @@
  @exitstatus
  
  
  @section @command{uniq}: Uniquify files
  
  @pindex uniq
-@@ -4681,7 +4666,7 @@
+@@ -4692,7 +4677,7 @@
  The input need not be sorted, but repeated input lines are detected
  only if they are adjacent.  If you want to discard non-adjacent
  duplicate lines, perhaps you want to use @code{sort -u}.
  
  @vindex LC_COLLATE
  Comparisons honor the rules specified by the @env{LC_COLLATE}
-@@ -4808,7 +4793,7 @@
+@@ -4819,7 +4804,7 @@
  @exitstatus
  
  
  @section @command{comm}: Compare two sorted files line by line
  
  @pindex comm
-@@ -4890,7 +4875,7 @@
+@@ -4901,7 +4886,7 @@
  
  @end table
  
  @section @command{ptx}: Produce permuted indexes
  
  @pindex ptx
-@@ -5349,7 +5334,7 @@
+@@ -5360,7 +5345,7 @@
  @end itemize
  
  
  @section @command{tsort}: Topological sort
  
  @pindex tsort
-@@ -5511,13 +5496,13 @@
+@@ -5522,13 +5507,13 @@
  @chapter Operating on fields
  
  @menu
  @section @command{cut}: Print selected parts of lines
  
  @pindex cut
-@@ -5637,7 +5622,7 @@
+@@ -5648,7 +5633,7 @@
  @exitstatus
  
  
  @section @command{paste}: Merge lines of files
  
  @pindex paste
-@@ -5707,7 +5692,7 @@
+@@ -5718,7 +5703,7 @@
  @exitstatus
  
  
  @section @command{join}: Join lines on a common field
  
  @pindex join
-@@ -5881,13 +5866,13 @@
+@@ -5892,13 +5877,13 @@
  This commands operate on individual characters.
  
  @menu
  @section @command{tr}: Translate, squeeze, and/or delete characters
  
  @pindex tr
-@@ -6267,7 +6252,7 @@
+@@ -6278,7 +6263,7 @@
  @end itemize
  
  
  @section @command{expand}: Convert tabs to spaces
  
  @pindex expand
-@@ -6320,7 +6305,7 @@
+@@ -6331,7 +6316,7 @@
  @exitstatus
  
  
  @section @command{unexpand}: Convert spaces to tabs
  
  @pindex unexpand
-@@ -6381,14 +6366,14 @@
+@@ -6392,14 +6377,14 @@
  and @command{vdir}, which list information about files.
  
  @menu
  @section @command{ls}: List directory contents
  
  @pindex ls
-@@ -7253,7 +7238,7 @@
+@@ -7264,7 +7249,7 @@
  @item +@var{format}
  @vindex LC_TIME
  List timestamps using @var{format}, where @var{format} is interpreted
  For example, @option{--time-style="+%Y-%m-%d %H:%M:%S"} causes
  @command{ls} to list timestamps like @samp{2002-03-30 23:45:56}.  As
  with @command{date}, @var{format}'s interpretation is affected by the
-@@ -7445,7 +7430,7 @@
+@@ -7456,7 +7441,7 @@
  @end table
  
  
  @section @command{dir}: Briefly list directory contents
  
  @pindex dir
-@@ -7455,10 +7440,10 @@
+@@ -7466,10 +7451,10 @@
  -b}; that is, by default files are listed in columns, sorted vertically,
  and special characters are represented by backslash escape sequences.
  
  @section @command{vdir}: Verbosely list directory contents
  
  @pindex vdir
-@@ -7468,7 +7453,7 @@
+@@ -7479,7 +7464,7 @@
  -b}; that is, by default files are listed in long format and special
  characters are represented by backslash escape sequences.
  
  @section @command{dircolors}: Color setup for @command{ls}
  
  @pindex dircolors
-@@ -7555,16 +7540,16 @@
+@@ -7566,16 +7551,16 @@
  copying, moving (renaming), and deleting (removing).
  
  @menu
  @section @command{cp}: Copy files and directories
  
  @pindex cp
-@@ -8018,7 +8003,7 @@
+@@ -8029,7 +8014,7 @@
  @exitstatus
  
  
  @section @command{dd}: Convert and copy a file
  
  @pindex dd
-@@ -8458,7 +8443,7 @@
+@@ -8484,7 +8469,7 @@
  @exitstatus
  
  
  @section @command{install}: Copy files and set attributes
  
  @pindex install
-@@ -8639,7 +8624,7 @@
+@@ -8665,7 +8650,7 @@
  @exitstatus
  
  
  @section @command{mv}: Move (rename) files
  
  @pindex mv
-@@ -8770,7 +8755,7 @@
+@@ -8796,7 +8781,7 @@
  @exitstatus
  
  
  @section @command{rm}: Remove files or directories
  
  @pindex rm
-@@ -8932,7 +8917,7 @@
+@@ -8958,7 +8943,7 @@
  @exitstatus
  
  
  @section @command{shred}: Remove files more securely
  
  @pindex shred
-@@ -8942,7 +8927,7 @@
+@@ -8968,7 +8953,7 @@
  @command{shred} overwrites devices or files, to help prevent even
  very expensive hardware from recovering the data.
  
  not actually destroyed.  Only the index listing where the file is
  stored is destroyed, and the storage is made available for reuse.
  There are undelete utilities that will attempt to reconstruct the index
-@@ -9189,18 +9174,18 @@
+@@ -9215,18 +9200,18 @@
  (FIFOs), symbolic links, sockets, and so-called @dfn{special files}.
  
  @menu
  @section @command{link}: Make a hard link via the link syscall
  
  @pindex link
-@@ -9213,7 +9198,7 @@
+@@ -9239,7 +9224,7 @@
  @code{link} function.  @xref{Hard Links, , , libc,
  The GNU C Library Reference Manual}.
  It avoids the bells and whistles of the more commonly-used
  Synopsis:
  
  @example
-@@ -9239,7 +9224,7 @@
+@@ -9265,7 +9250,7 @@
  @exitstatus
  
  
  @section @command{ln}: Make links between files
  
  @pindex ln
-@@ -9420,7 +9405,7 @@
+@@ -9446,7 +9431,7 @@
  '/tmp/file' -> '../a/file'
  @end smallexample
  
  over relative file name generation.
  
  @item -s
-@@ -9484,7 +9469,7 @@
+@@ -9510,7 +9495,7 @@
  @end smallexample
  
  
  @section @command{mkdir}: Make directories
  
  @pindex mkdir
-@@ -9563,7 +9548,7 @@
+@@ -9589,7 +9574,7 @@
  @exitstatus
  
  
  @section @command{mkfifo}: Make FIFOs (named pipes)
  
  @pindex mkfifo
-@@ -9610,7 +9595,7 @@
+@@ -9636,7 +9621,7 @@
  @exitstatus
  
  
  @section @command{mknod}: Make block or character special files
  
  @pindex mknod
-@@ -9693,7 +9678,7 @@
+@@ -9719,7 +9704,7 @@
  @exitstatus
  
  
  @section @command{readlink}: Print value of a symlink or canonical file name
  
  @pindex readlink
-@@ -9788,7 +9773,7 @@
+@@ -9814,7 +9799,7 @@
  @exitstatus
  
  
  @section @command{rmdir}: Remove empty directories
  
  @pindex rmdir
-@@ -9836,12 +9821,12 @@
+@@ -9862,12 +9847,12 @@
  
  @end table
  
  @section @command{unlink}: Remove files via the unlink syscall
  
  @pindex unlink
-@@ -9852,7 +9837,7 @@
+@@ -9878,7 +9863,7 @@
  @code{unlink} function.  @xref{Deleting Files, , , libc,
  The GNU C Library Reference Manual}.  Synopsis:
  It avoids the bells and whistles of the more commonly-used
  
  @example
  unlink @var{filename}
-@@ -9886,14 +9871,14 @@
+@@ -9912,14 +9897,14 @@
  These commands change file attributes.
  
  @menu
  @section @command{chown}: Change file owner and group
  
  @pindex chown
-@@ -10111,7 +10096,7 @@
+@@ -10137,7 +10122,7 @@
  @end smallexample
  
  
  @section @command{chgrp}: Change group ownership
  
  @pindex chgrp
-@@ -10234,7 +10219,7 @@
+@@ -10260,7 +10245,7 @@
  @end smallexample
  
  
  @section @command{chmod}: Change access permissions
  
  @pindex chmod
-@@ -10334,7 +10319,7 @@
+@@ -10360,7 +10345,7 @@
  @exitstatus
  
  
  @section @command{touch}: Change file timestamps
  
  @pindex touch
-@@ -10541,15 +10526,15 @@
+@@ -10567,15 +10552,15 @@
  file status information, and write buffers to disk.
  
  @menu
  @section @command{df}: Report file system disk space usage
  
  @pindex df
-@@ -10767,7 +10752,7 @@
+@@ -10793,7 +10778,7 @@
  or @option{-x} is used together with a file name argument.
  
  
  @section @command{du}: Estimate file space usage
  
  @pindex du
-@@ -10965,7 +10950,7 @@
+@@ -10991,7 +10976,7 @@
  @item +@var{format}
  @vindex LC_TIME
  List timestamps using @var{format}, where @var{format} is interpreted
  For example, @option{--time-style="+%Y-%m-%d %H:%M:%S"} causes
  @command{du} to list timestamps like @samp{2002-03-30 23:45:56}.  As
  with @command{date}, @var{format}'s interpretation is affected by the
-@@ -11033,7 +11018,7 @@
+@@ -11059,7 +11044,7 @@
  @exitstatus
  
  
  @section @command{stat}: Report file or file system status
  
  @pindex stat
-@@ -11217,7 +11202,7 @@
+@@ -11243,7 +11228,7 @@
  @exitstatus
  
  
  @section @command{sync}: Synchronize data on disk with memory
  
  @pindex sync
-@@ -11244,7 +11229,7 @@
+@@ -11270,7 +11255,7 @@
  @exitstatus
  
  
  @section @command{truncate}: Shrink or extend the size of a file
  
  @pindex truncate
-@@ -11320,13 +11305,13 @@
+@@ -11346,13 +11331,13 @@
  This section describes commands that display text strings.
  
  @menu
  @section @command{echo}: Print a line of text
  
  @pindex echo
-@@ -11415,12 +11400,12 @@
+@@ -11441,12 +11426,12 @@
  @var{string} contains a backslash or if the first argument is
  @option{-n}.  Portable programs can use the @command{printf} command
  if they need to omit trailing newlines or output control characters or
  @section @command{printf}: Format and print data
  
  @pindex printf
-@@ -11574,7 +11559,7 @@
+@@ -11600,7 +11585,7 @@
  @exitstatus
  
  
  @section @command{yes}: Print a string until interrupted
  
  @pindex yes
-@@ -11605,14 +11590,14 @@
+@@ -11631,14 +11616,14 @@
  pipeline.
  
  @menu
  @section @command{false}: Do nothing, unsuccessfully
  
  @pindex false
-@@ -11642,7 +11627,7 @@
- non-@acronym{GNU} hosts.
+@@ -11668,7 +11653,7 @@
+ non-GNU hosts.
  
  
 -@node true invocation
  @section @command{true}: Do nothing, successfully
  
  @pindex true
-@@ -11678,7 +11663,7 @@
+@@ -11704,7 +11689,7 @@
  more secure and faster than a shell script implementation, and may safely
  be used as a dummy shell for the purpose of disabling accounts.
  
  @section @command{test}: Check file types and compare values
  
  @pindex test
-@@ -12011,7 +11996,7 @@
+@@ -12037,7 +12022,7 @@
  @end table
  
  
  @section @command{expr}: Evaluate expressions
  
  @pindex expr
-@@ -12288,11 +12273,11 @@
+@@ -12314,11 +12299,11 @@
  it's described here.
  
  @menu
  @section @command{tee}: Redirect output to multiple files or processes
  
  @pindex tee
-@@ -12453,15 +12438,15 @@
+@@ -12479,15 +12464,15 @@
  This section describes commands that manipulate file names.
  
  @menu
  @section @command{basename}: Strip directory and suffix from a file name
  
  @pindex basename
-@@ -12547,7 +12532,7 @@
+@@ -12573,7 +12558,7 @@
  @end smallexample
  
  
  @section @command{dirname}: Strip last file name component
  
  @pindex dirname
-@@ -12604,7 +12589,7 @@
+@@ -12630,7 +12615,7 @@
  @end smallexample
  
  
  @section @command{pathchk}: Check file name validity and portability
  
  @pindex pathchk
-@@ -12680,7 +12665,7 @@
+@@ -12706,7 +12691,7 @@
  1 otherwise.
  @end display
  
  @section @command{mktemp}: Create temporary file or directory
  
  @pindex mktemp
-@@ -12855,7 +12840,7 @@
+@@ -12881,7 +12866,7 @@
  @end display
  
  
  @section @command{realpath}: Print the resolved file name.
  
  @pindex realpath
-@@ -12983,14 +12968,14 @@
+@@ -13009,14 +12994,14 @@
  so forth.  See also the user-related commands in the next section.
  
  @menu
  @section @command{pwd}: Print working directory
  
  @pindex pwd
-@@ -13037,7 +13022,7 @@
+@@ -13063,7 +13048,7 @@
  @exitstatus
  
  
  @section @command{stty}: Print or change terminal characteristics
  
  @pindex stty
-@@ -13721,7 +13706,7 @@
+@@ -13747,7 +13732,7 @@
  @end table
  
  
  @section @command{printenv}: Print all or some environment variables
  
  @pindex printenv
-@@ -13756,7 +13741,7 @@
+@@ -13782,7 +13767,7 @@
  @end display
  
  
  @section @command{tty}: Print file name of terminal on standard input
  
  @pindex tty
-@@ -13806,16 +13791,16 @@
+@@ -13832,16 +13817,16 @@
  logins, groups, and so forth.
  
  @menu
  @section @command{id}: Print user identity
  
  @pindex id
-@@ -13901,7 +13886,7 @@
+@@ -13927,7 +13912,7 @@
  @end macro
  @primaryAndSupplementaryGroups{id,user argument}
  
  @section @command{logname}: Print current login name
  
  @pindex logname
-@@ -13922,7 +13907,7 @@
+@@ -13948,7 +13933,7 @@
  @exitstatus
  
  
  @section @command{whoami}: Print effective user ID
  
  @pindex whoami
-@@ -13938,7 +13923,7 @@
+@@ -13964,7 +13949,7 @@
  @exitstatus
  
  
  @section @command{groups}: Print group names a user is in
  
  @pindex groups
-@@ -13966,7 +13951,7 @@
+@@ -13992,7 +13977,7 @@
  @exitstatus
  
  
  @section @command{users}: Print login names of users currently logged in
  
  @pindex users
-@@ -13997,7 +13982,7 @@
+@@ -14023,7 +14008,7 @@
  @exitstatus
  
  
  @section @command{who}: Print who is currently logged in
  
  @pindex who
-@@ -14156,16 +14141,14 @@
+@@ -14182,16 +14167,14 @@
  information.
  
  @menu
  @section @command{date}: Print or set system date and time
  
  @pindex date
-@@ -14858,7 +14841,7 @@
+@@ -14884,7 +14867,7 @@
  @end itemize
  
  
  @section @command{arch}: Print machine hardware name
  
  @pindex arch
-@@ -14878,7 +14861,7 @@
+@@ -14904,7 +14887,7 @@
  @exitstatus
  
  
  @section @command{nproc}: Print the number of available processors
  
  @pindex nproc
-@@ -14915,7 +14898,7 @@
+@@ -14941,7 +14924,7 @@
  @exitstatus
  
  
  @section @command{uname}: Print system information
  
  @pindex uname
-@@ -15045,31 +15028,7 @@
+@@ -15071,31 +15054,7 @@
  @exitstatus
  
  
  @section @command{hostid}: Print numeric host identifier
  
  @pindex hostid
-@@ -15093,37 +15052,6 @@
+@@ -15119,37 +15078,6 @@
  
  @exitstatus
  
  @node SELinux context
  @chapter SELinux context
  
-@@ -15135,11 +15063,11 @@
+@@ -15161,11 +15089,11 @@
  contexts.
  
  @menu
  @section @command{chcon}: Change SELinux context of file
  
  @pindex chcon
-@@ -15226,7 +15154,7 @@
+@@ -15252,7 +15180,7 @@
  
  @exitstatus
  
  @section @command{runcon}: Run a command in specified SELinux context
  
  @pindex runcon
-@@ -15311,16 +15239,16 @@
+@@ -15337,16 +15265,16 @@
  user, etc.
  
  @menu
  @section @command{chroot}: Run a command with a different root directory
  
  @pindex chroot
-@@ -15408,7 +15336,7 @@
+@@ -15434,7 +15362,7 @@
  @end display
  
  
  @section @command{env}: Run a command in a modified environment
  
  @pindex env
-@@ -15558,7 +15486,7 @@
+@@ -15584,7 +15512,7 @@
  @end display
  
  
  @section @command{nice}: Run a command with modified niceness
  
  @pindex nice
-@@ -15681,7 +15609,7 @@
+@@ -15707,7 +15635,7 @@
  @end example
  
  
  @section @command{nohup}: Run a command immune to hangups
  
  @pindex nohup
-@@ -15754,7 +15682,7 @@
+@@ -15780,7 +15708,7 @@
  instead of 125.
  
  
  @section @command{stdbuf}: Run a command with modified I/O stream buffering
  
  @pindex stdbuf
-@@ -15843,7 +15771,7 @@
+@@ -15869,7 +15797,7 @@
  @end display
  
  
  @section @command{timeout}: Run a command with a time limit
  
  @pindex timeout
-@@ -15924,90 +15852,6 @@
+@@ -15950,90 +15878,6 @@
  @end display
  
  
 -
 -If a negative @var{pid} argument is desired as the first one, it
 -should be preceded by @option{--}.  However, as a common extension to
--@acronym{POSIX}, @option{--} is not required with @samp{kill
+-POSIX, @option{--} is not required with @samp{kill
 --@var{signal} -@var{pid}}.  The following commands are equivalent:
 -
 -@example
  @node Delaying
  @chapter Delaying
  
-@@ -16017,11 +15861,11 @@
+@@ -16043,11 +15887,11 @@
  @c Perhaps @command{wait} or other commands should be described here also?
  
  @menu
  @section @command{sleep}: Delay for a specified time
  
  @pindex sleep
-@@ -16071,12 +15915,12 @@
+@@ -16097,12 +15941,12 @@
  These programs do numerically-related operations.
  
  @menu
  @section @command{factor}: Print prime factors
  
  @pindex factor
-@@ -16134,7 +15978,7 @@
+@@ -16160,7 +16004,7 @@
  @exitstatus
  
  
index 3bd359775bccd34ab18a4ec461bd88cd1b1775bc..23e52d3732b68f5cba9e218e73886818611e5feb 100644 (file)
---- coreutils-8.19/po/pl.po.orig       2012-08-20 08:22:10.000000000 +0200
-+++ coreutils-8.19/po/pl.po    2012-10-14 10:20:31.269339375 +0200
-@@ -8084,7 +8084,6 @@
- "polecenia\n"
+--- coreutils-8.20/po/pl.po.orig       2012-11-18 07:22:42.025241225 +0100
++++ coreutils-8.20/po/pl.po    2012-11-18 07:46:58.035210874 +0100
+@@ -14,7 +14,7 @@
+ # 2 format strings: Jakub Bogusz <qboosh@pld-linux.org>, 2007.
+ msgid ""
+ msgstr ""
+-"Project-Id-Version: coreutils 8.19\n"
++"Project-Id-Version: coreutils 8.20\n"
+ "Report-Msgid-Bugs-To: bug-coreutils@gnu.org\n"
+ "POT-Creation-Date: 2012-10-23 16:59+0100\n"
+ "PO-Revision-Date: 2012-08-20 20:15+0200\n"
+@@ -3173,7 +3173,6 @@
+ "  ibs=BAJTÓW      czytanie tylu BAJTÓW naraz (domyślnie: 512)\n"
  
- #: src/rm.c:154
+ #: src/dd.c:535
 -#, fuzzy
  msgid ""
- "      --no-preserve-root  do not treat '/' specially\n"
- "      --preserve-root   do not remove '/' (default)\n"
-@@ -8093,9 +8092,9 @@
- "  -v, --verbose         explain what is being done\n"
+ "  if=FILE         read from FILE instead of stdin\n"
+ "  iflag=FLAGS     read as per the comma separated symbol list\n"
+@@ -3194,10 +3193,10 @@
+ "                    oddzielonych przecinkami\n"
+ "  seek=ILE        przeskoczenie ILU bloków o rozmiarze obs na wyjściu\n"
+ "  skip=ILE        przeskoczenie ILU bloków o rozmiarze ibs na wejściu\n"
+-"  status=noxfer   bez statystyki kopiowania\n"
++"  status=JAKIE    JAIE informacje pomijać na wyjściu diagnostycznym;\n"
++"                  'noxfer' bez statystyki kopiowania, 'none' bez niczego\n"
+ #: src/dd.c:546
+-#, fuzzy
+ msgid ""
+ "\n"
+ "N and BYTES may be followed by the following multiplicative suffixes:\n"
+@@ -3208,7 +3207,7 @@
+ "\n"
+ msgstr ""
+ "\n"
+-"N, BLOKI i BAJTY mogą mieć następujące przyrostki mnożące:\n"
++"N i BAJTY mogą mieć następujące przyrostki mnożące:\n"
+ "c =1, w =2, b =512, kB =1000, K =1024, MB =1000*1000, M =1024*1024, xM =M\n"
+ "GB =1000*1000*1000, G =1024*1024*1024, itd. dla T, P, E, Z, Y.\n"
+ "\n"
+@@ -3640,7 +3639,7 @@
+ #: src/df.c:319 src/df.c:328
+ #, c-format
+ msgid "%s-%s"
+-msgstr ""
++msgstr "%2$s %1$s"
+ #: src/df.c:873
+ msgid ""
+@@ -3989,7 +3988,7 @@
+ #: src/du.c:501
+ #, c-format
+ msgid "mount point %s already traversed"
+-msgstr ""
++msgstr "punkt montowania %s już był przejrzany"
+ #: src/du.c:611
+ #, c-format
+@@ -4416,17 +4415,17 @@
+ #. This is a proper name. See the gettext manual, section Names.
+ #: src/factor.c:111
+ msgid "Niels Moller"
+-msgstr ""
++msgstr "Niels Möller"
+ #: src/factor.c:1252 src/factor.c:1352 src/factor.c:1428
+ #, c-format
+ msgid "Lucas prime test failure.  This should not happen"
+-msgstr ""
++msgstr "Błąd testu Lucasa liczby pierwszej. Nie powinno się zdarzyć"
+ #: src/factor.c:2061
+ #, c-format
+ msgid "squfof queue overflow"
+-msgstr ""
++msgstr "przepełnienie kolejki squfof"
+ #: src/factor.c:2377
+ msgid "using single-precision arithmetic"
+@@ -6079,7 +6078,7 @@
+ #: src/md5sum.c:184
+ msgid "      --tag            create a BSD-style checksum\n"
+-msgstr ""
++msgstr "      --tag            tworzenie sum kontrolnych w stylu BSD\n"
+ #: src/md5sum.c:188
+ msgid ""
+@@ -6189,12 +6188,12 @@
+ #: src/md5sum.c:760
+ #, c-format
+ msgid "--tag does not support --text mode"
+-msgstr ""
++msgstr "--tag nie obsługuje trybu --text"
+ #: src/md5sum.c:766
+-#, fuzzy, c-format
++#, c-format
+ msgid "the --tag option is meaningless when verifying checksums"
+-msgstr "opcja --status ma znaczenie tylko przy weryfikacji sum kontrolnych"
++msgstr "opcja --tag nie ma znaczenia przy weryfikacji sum kontrolnych"
+ #: src/md5sum.c:773
+ #, c-format
+@@ -6576,7 +6575,7 @@
+ msgstr "Składnia: %s [OPCJA] [POLECENIE [ARGUMENT]...]\n"
+ #: src/nice.c:73
+-#, fuzzy, c-format
++#, c-format
+ msgid ""
+ "Run COMMAND with an adjusted niceness, which affects process scheduling.\n"
+ "With no COMMAND, print the current niceness.  Niceness values range from\n"
+@@ -6585,9 +6584,10 @@
+ "  -n, --adjustment=N   add integer N to the niceness (default 10)\n"
  msgstr ""
- "      --no-preserve-root bez traktowania katalogu '/' w specjalny sposób\n"
--"                          (domyślnie)\n"
--"      --preserve-root   odmowa usunięcia '/' (domyslnie)\n"
-+"      --preserve-root   odmowa usunięcia '/' (domyślne)\n"
- "  -r, -R, --recursive   usuwanie katalogów z zawartością rekursywnie\n"
-+"  -d, --dir             usuwanie pustych katalogów\n"
- "  -v, --verbose         wyjaśnianie co się dzieje\n"
- #: src/rm.c:163
+ "Uruchomienie POLECENIA z poprawionym priorytetem, co wpływa na przydział\n"
+-"czasu procesora. Bez POLECENIE wypisuje bieżący priorytet. Priorytet może\n"
++"czasu procesora. Bez POLECENIA wypisuje bieżący priorytet. Priorytet może\n"
+ "mieć wartość od %d (największe przydziały czasu) do %d (najmniejsze).\n"
+ "\n"
++"  -n, --adjustment=N   dodanie liczby całkowitej N do priorytetu (domyślnie 10)\n"
+ #: src/nice.c:168
+ #, c-format
+@@ -11250,7 +11250,7 @@
+ #: src/timeout.c:456
+ #, c-format
+ msgid "the monitored command dumped core"
+-msgstr ""
++msgstr "monitorowane polecenie utworzyło zrzut pamięci"
+ #. This is a proper name. See the gettext manual, section Names.
+ #: src/touch.c:43
+@@ -11326,7 +11326,6 @@
+ "  -m                     zmiana tylko czasu modyfikacji\n"
+ #: src/touch.c:238
+-#, fuzzy
+ msgid ""
+ "  -r, --reference=FILE   use this file's times instead of current time\n"
+ "  -t STAMP               use [[CC]YY]MMDDhhmm[.ss] instead of current time\n"
+@@ -11337,9 +11336,9 @@
+ "  -r, --reference=PLIK   użycie czasu tego PLIKU zamiast czasu bieżącego\n"
+ "  -t CZAS                użycie [[CC]YY]MMDDhhmm[.ss] zamiast bieżącego "
+ "czasu\n"
+-"  --time=SŁOWO           ustawienie czasu wg SŁOWA: access atime use (czas\n"
+-"                           dostępu, to samo co -a), modify mtime (czas\n"
+-"                           modyfikacji, to samo co -m)\n"
++"      --time=SŁOWO       ustawienie czasu wg SŁOWA:\n"
++"                           access, atime, use (czas dostępu, to samo co -a)\n"
++"                           modify, mtime (czas modyfikacji, to samo co -m)\n"
+ #: src/touch.c:247
+ msgid ""
index cb4232ada6b6539157279fae7c10f135afb41db4..49fa1e62bdd0e956f00a5f4fad6782c0e1a5c160 100644 (file)
@@ -6,12 +6,12 @@
 Summary:       GNU Core-utils - basic command line utilities
 Summary(pl.UTF-8):     GNU Core-utils - podstawowe narzędzia działające z linii poleceń
 Name:          coreutils
-Version:       8.19
+Version:       8.20
 Release:       1
 License:       GPL v3+
 Group:         Applications/System
 Source0:       http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
-# Source0-md5: 1a01231a2f3ed37c0efc073ccdda9375
+# Source0-md5: 3d69af8f561fce512538a9fe85f147ff
 Source1:       %{name}-non-english-man-pages.tar.bz2
 # Source1-md5: f7c986ebc74ccb8d08ed70141063f14c
 Source2:       DIR_COLORS
@@ -124,10 +124,10 @@ Programy zawarte w tym pakiecie to:
 # allow rebuilding *.gmo
 %{__rm} po/stamp-po
 
-# fails under C locale:
+# 8-bit-pfx test fails under C locale:
 # LC_ALL=C echo -e "ça\nçb\n"|LC_ALL=C fmt -p 'ç'
 # fmt: memory exhausted
-%{__sed} -i -e 25,27d tests/fmt/base
+%{__sed} -i -e 25,27d tests/fmt/base.pl
 
 # /etc/resolv.conf is blocked in pld builders, try some other file
 %{__sed} -i -e 's,/etc/resolv.conf,/etc/hosts,' gnulib-tests/test-read-file.c
@@ -135,14 +135,16 @@ Programy zawarte w tym pakiecie to:
 # getgid needs to be fixed:
 # getgid: missing operand
 # Try `getgid --help' for more information.
-%{__rm} tests/misc/help-version
-%{__sed} -i -e '/misc\/help-version/d' tests/Makefile.am
+%{__rm} tests/misc/help-version.sh
+%{__sed} -i -e '/misc\/help-version/d' tests/local.mk
 
 # fails on some filesystems (like XFS), where readdir returns d_type=DT_UNKNOWN
-%{__rm} tests/ls/stat-free-color
-%{__sed} -i -e '/ls\/stat-free-color/d' tests/Makefile.am
+%{__rm} tests/ls/stat-free-color.sh
+%{__sed} -i -e '/ls\/stat-free-color/d' tests/local.mk
 
 %build
+build-aux/gen-lists-of-programs.sh --autoconf > m4/cu-progs.m4
+build-aux/gen-lists-of-programs.sh --automake > src/cu-progs.mk
 %{__gettextize}
 %{__aclocal} -I m4
 %{__autoconf}
This page took 0.239376 seconds and 4 git commands to generate.