]> git.pld-linux.org Git - packages/coreutils.git/commitdiff
up to 9.5 master auto/th/coreutils-9.5-1
authorJan Palus <atler@pld-linux.org>
Thu, 28 Mar 2024 21:31:57 +0000 (22:31 +0100)
committerJan Palus <atler@pld-linux.org>
Thu, 28 Mar 2024 21:31:57 +0000 (22:31 +0100)
coreutils-fmt-wchars.patch
coreutils-getgid.patch
coreutils-info.patch
coreutils.spec

index fcc6792efc939af08132e7dd19466d97580b19a1..066adfdbb3f30ffa9e18da44c67b8c46d0657d8b 100644 (file)
@@ -24,9 +24,9 @@
  
  #include <config.h>
 +#include <wchar.h>
+ #include <ctype.h>
  #include <stdio.h>
  #include <sys/types.h>
- #include <getopt.h>
 @@ -40,7 +41,7 @@
  /* The following parameters represent the program's idea of what is
     "best".  Adjust to taste, subject to the caveats given.  */
index 79c21d5f84f212689d430542a7884d834b92ee03..d73e737fa5c3e1470c1df9bab6e976a100a1472f 100644 (file)
@@ -109,7 +109,7 @@ diff -urNp -x '*.orig' coreutils-8.32.org/po/pl.po coreutils-8.32/po/pl.po
 +"\t%s nazwa-grupy\n"
 +
  #. This is a proper name. See the gettext manual, section Names.
- #: src/echo.c:27
+ #: src/echo.c:28
  msgid "Brian Fox"
 diff -urNp -x '*.orig' coreutils-8.32.org/src/getgid.c coreutils-8.32/src/getgid.c
 --- coreutils-8.32.org/src/getgid.c    1970-01-01 01:00:00.000000000 +0100
index c54e7dcb28765da3db499c5135b072a5d528c8e6..da9e259009446c1829f4742d3bff7a81158fdb45 100644 (file)
@@ -1,6 +1,6 @@
---- coreutils-9.4/doc/coreutils.texi.orig      2023-08-29 13:39:27.000000000 +0200
-+++ coreutils-9.4/doc/coreutils.texi   2023-08-29 23:57:13.945034048 +0200
-@@ -24,123 +24,112 @@
+--- coreutils-9.5/doc/coreutils.texi.orig      2024-03-24 18:51:06.000000000 +0100
++++ coreutils-9.5/doc/coreutils.texi   2024-03-28 22:13:57.040433328 +0100
+@@ -24,124 +24,113 @@
  @syncodeindex pg cp
  @syncodeindex vr cp
  
@@ -79,6 +79,7 @@
 -* od: (coreutils)od invocation.                 Dump files in octal, etc.
 -* paste: (coreutils)paste invocation.           Merge lines of files.
 -* pathchk: (coreutils)pathchk invocation.       Check file name portability.
+-* pinky: (coreutils)pinky invocation.           Print information about users.
 -* pr: (coreutils)pr invocation.                 Paginate or columnate files.
 -* printenv: (coreutils)printenv invocation.     Print environment variables.
 -* printf: (coreutils)printf invocation.         Format and print data.
 +* od: (coreutils)od.                  Dump files in octal, etc.
 +* paste: (coreutils)paste.            Merge lines of files.
 +* pathchk: (coreutils)pathchk.                Check file name portability.
++* pinky: (coreutils)pinky.            Print information about users.
 +* pr: (coreutils)pr.                  Paginate or columnate files.
 +* printenv: (coreutils)printenv.      Print environment variables.
 +* printf: (coreutils)printf.          Format and print data.
  @end direntry
  
  @copying
-@@ -205,10 +194,9 @@ Free Documentation License''.
+@@ -206,10 +195,9 @@ Free Documentation License''.
  * File name manipulation::       dirname basename pathchk mktemp realpath
  * Working context::              pwd stty printenv tty
  * User information::             id logname whoami groups users who
  * Delaying::                     sleep
  * Numeric operations::           factor numfmt seq
  * File permissions::             Access modes
-@@ -240,45 +228,45 @@ Common Options
+@@ -241,45 +229,45 @@ Common Options
  
  Output of entire files
  
  
  @command{ptx}: Produce permuted indexes
  
-@@ -290,15 +278,15 @@ Operating on sorted files
+@@ -291,15 +279,15 @@ Operating on sorted files
  
  Operating on fields
  
  
  @command{tr}: Translate, squeeze, and/or delete characters
  
-@@ -308,10 +296,10 @@ Operating on characters
+@@ -309,10 +297,10 @@ Operating on characters
  
  Directory listing
  
  
  @command{ls}:  List directory contents
  
-@@ -323,51 +311,51 @@ Directory listing
+@@ -324,51 +312,51 @@ Directory listing
  
  Basic operations
  
  
  @command{test}: Check file types and compare values
  
-@@ -386,22 +374,22 @@ Conditions
+@@ -387,22 +375,22 @@ Conditions
  
  Redirection
  
  
  @command{stty}: Print or change terminal characteristics
  
-@@ -415,22 +403,20 @@ Working context
+@@ -416,23 +404,21 @@ Working context
  
  User information
  
 -* groups invocation::            Print group names a user is in
 -* users invocation::             Print login names of users currently logged in
 -* who invocation::               Print who is currently logged in
+-* pinky invocation::             Print information about users
 +* id::                           Print user identity
 +* logname::                      Print current login name
 +* whoami::                       Print effective user ID
 +* groups::                       Print group names a user is in
 +* users::                        Print login names of users currently logged in
 +* who::                          Print who is currently logged in
++* pinky::                        Print information about users
  
  System context
  
  
  @command{date}: Print or set system date and time
  
-@@ -445,31 +431,27 @@ System context
+@@ -447,31 +433,27 @@ System context
  
  SELinux context
  
  
  
  File timestamps
-@@ -1623,16 +1605,16 @@ These commands read and write entire fil
+@@ -1628,16 +1610,16 @@ These commands read and write entire fil
  in some way.
  
  @menu
  @section @command{cat}: Concatenate and write files
  
  @pindex cat
-@@ -1734,7 +1716,7 @@ cat
+@@ -1739,7 +1721,7 @@ cat
  @end example
  
  
  @section @command{tac}: Concatenate and write files in reverse
  
  @pindex tac
-@@ -1792,7 +1774,7 @@ tac -r -s 'x\|[^x]'
+@@ -1797,7 +1779,7 @@ tac -r -s 'x\|[^x]'
  @end example
  
  
  @section @command{nl}: Number lines and write files
  
  @pindex nl
-@@ -1960,7 +1942,7 @@ Use @var{number} characters for line num
+@@ -1965,7 +1947,7 @@ Use @var{number} characters for line num
  @exitstatus
  
  
  @section @command{od}: Write files in octal or other formats
  
  @pindex od
-@@ -2226,7 +2208,7 @@ address.
+@@ -2237,7 +2219,7 @@ address.
  @exitstatus
  
  
  @section @command{base32}: Transform data into printable data
  
  @pindex base32
-@@ -2236,11 +2218,11 @@ address.
+@@ -2247,11 +2229,11 @@ address.
  into (or from) base32 encoded form.  The base32 encoded form uses
  printable ASCII characters to represent binary data.
  The usage and options of this command are precisely the
  @section @command{base64}: Transform data into printable data
  
  @pindex base64
-@@ -2261,7 +2243,7 @@ The base32 encoding expands data to roug
+@@ -2272,7 +2254,7 @@ The base32 encoding expands data to roug
  The format conforms to
- @uref{https://tools.ietf.org/search/rfc4648, RFC 4648}.
+ @uref{https://datatracker.ietf.org/doc/rfc4648/, RFC 4648}.
  
 -For more general encoding functionality see @ref{basenc invocation}.
 +For more general encoding functionality see @ref{basenc}.
  
  The program accepts the following options.  Also see @ref{Common options}.
  
-@@ -2302,7 +2284,7 @@ to permit distorted data to be decoded.
+@@ -2313,7 +2295,7 @@ to permit distorted data to be decoded.
  
  @exitstatus
  
  @section @command{basenc}: Transform data into printable data
  
  @pindex basenc
-@@ -2323,7 +2305,7 @@ The @var{encoding} argument is required.
+@@ -2334,7 +2316,7 @@ The @var{encoding} argument is required.
  @command{basenc} reads from standard input.
  The @option{-w/--wrap},@option{-i/--ignore-garbage},
  @option{-d/--decode} options of this command are precisely the same as
  
  
  Supported @var{encoding}s are:
-@@ -2438,13 +2420,13 @@ $ printf 01010100 | basenc --base2lsbf -
+@@ -2449,13 +2431,13 @@ $ printf 01010100 | basenc --base2lsbf -
  These commands reformat the contents of files.
  
  @menu
  @section @command{fmt}: Reformat paragraph text
  
  @pindex fmt
-@@ -2548,7 +2530,7 @@ leaving the code unchanged.
+@@ -2559,7 +2541,7 @@ leaving the code unchanged.
  
  @exitstatus
  
  @section @command{pr}: Paginate or columnate files for printing
  
  @pindex pr
-@@ -2658,7 +2640,7 @@ Double space the output.
+@@ -2671,7 +2653,7 @@ Double space the output.
  @cindex time formats
  @cindex formatting times
  Format header dates using @var{format}, using the same conventions as
  Except for directives, which start with
  @samp{%}, characters in @var{format} are printed unchanged.  You can use
  this option to specify an arbitrary string in place of the header date,
-@@ -2888,7 +2870,7 @@ line is never truncated.
+@@ -2901,7 +2883,7 @@ line is never truncated.
  @exitstatus
  
  
  @section @command{fold}: Wrap input lines to fit in specified width
  
  @pindex fold
-@@ -2955,13 +2937,13 @@ instead.
+@@ -2968,13 +2950,13 @@ instead.
  These commands output pieces of the input.
  
  @menu
  @section @command{head}: Output the first part of files
  
  @pindex head
-@@ -3040,7 +3022,7 @@ avoid @command{head}, e.g., by using @sa
+@@ -3053,7 +3035,7 @@ avoid @command{head}, e.g., by using @sa
  @exitstatus
  
  
  @section @command{tail}: Output the last part of files
  
  @pindex tail
-@@ -3293,7 +3275,7 @@ mean either @samp{tail ./+4} or @samp{ta
+@@ -3307,7 +3289,7 @@ mean either @samp{tail ./+4} or @samp{ta
  @exitstatus
  
  
  @section @command{split}: Split a file into pieces.
  
  @pindex split
-@@ -3550,7 +3532,7 @@ $ seq 100 > k; split -nl/7/33 k
+@@ -3564,7 +3546,7 @@ $ seq 100 > k; split -nl/7/33 k
  @end example
  
  
  @section @command{csplit}: Split a file into context-determined pieces
  
  @pindex csplit
-@@ -3770,17 +3752,17 @@ These commands generate just a few numbe
+@@ -3784,17 +3766,17 @@ These commands generate just a few numbe
  contents of files.
  
  @menu
  @section @command{wc}: Print newline, word, and byte counts
  
  @pindex wc
-@@ -3931,7 +3913,7 @@ find . -name '*.[ch]' -print0 |
+@@ -3955,7 +3937,7 @@ find . -name '*.[ch]' -print0 |
  @exitstatus
  
  
  @section @command{sum}: Print checksum and block counts
  
  @pindex sum
-@@ -3980,7 +3962,7 @@ next section) is preferable in new appli
+@@ -4004,7 +3986,7 @@ next section) is preferable in new appli
  @exitstatus
  
  
  @section @command{cksum}: Print and verify file checksums
  
  @pindex cksum
-@@ -4027,7 +4009,7 @@ The 32-bit CRC used is based on the poly
+@@ -4052,7 +4034,7 @@ The 32-bit CRC used is based on the poly
  for CRC error checking in the ISO/IEC 8802-3:1996 standard (Ethernet).
  Similar output formats are used for the other legacy checksums
  selectable with @option{--algorithm=sysv} or @option{--algorithm=bsd},
  
  @item Tagged output format
  With the @option{--algorithm} option selecting non legacy checksums,
-@@ -4273,7 +4255,7 @@ exit nonzero after all warnings have bee
+@@ -4302,7 +4284,7 @@ exit nonzero after all warnings have bee
  Also file name escaping is not used.
  @end table
  
  @section @command{md5sum}: Print or check MD5 digests
  
  @pindex md5sum
-@@ -4296,7 +4278,7 @@ fingerprint is considered infeasible at
+@@ -4325,7 +4307,7 @@ fingerprint is considered infeasible at
  to modify certain files, including digital certificates, so that they
  appear valid when signed with an \hash\ digest.  For more secure hashes,
- consider using SHA-2, or the newer @command{b2sum} command.
+ consider using SHA-2 or @command{b2sum}.
 -@xref{sha2 utilities}. @xref{b2sum invocation}.
 +@xref{sha2 utilities}. @xref{b2sum}.
  @end macro
  @weakHash{MD5}
  
-@@ -4320,7 +4302,7 @@ The program accepts @ref{cksum common op
+@@ -4349,7 +4331,7 @@ The program accepts @ref{cksum common op
  @exitstatus
  
  
  @section @command{b2sum}: Print or check BLAKE2 digests
  
  @pindex b2sum
-@@ -4342,7 +4324,7 @@ In addition @command{b2sum} supports the
+@@ -4371,7 +4353,7 @@ In addition @command{b2sum} supports the
  @end table
  
  
  @section @command{sha1sum}: Print or check SHA-1 digests
  
  @pindex sha1sum
-@@ -4400,16 +4382,16 @@ collectively known as the SHA-2 hashes.
+@@ -4429,16 +4411,16 @@ collectively known as the SHA-2 hashes.
  These commands work with (or produce) sorted files.
  
  @menu
  @section @command{sort}: Sort text files
  
  @pindex sort
-@@ -4705,7 +4687,7 @@ appear earlier in the output instead of
+@@ -4737,7 +4719,7 @@ appear earlier in the output instead of
  Sort by hashing the input keys and then sorting the hash values.
  Choose the hash function at random, ensuring that it is free of
  collisions so that differing keys have differing hash values.  This is
  except that keys with the same value sort together.
  
  If multiple random sort fields are specified, the same random hash
-@@ -4904,7 +4886,7 @@ Set the number of sorts run in parallel
+@@ -4936,7 +4918,7 @@ Set the number of sorts run in parallel
  @var{n} is set to the number of available processors, but limited
- to 8, as there are diminishing performance gains after that.
Note also that using @var{n} threads increases the memory usage by
+ to 8, as performance gains diminish after that.
Using @var{n} threads increases the memory usage by
 -a factor of log @var{n}.  Also see @ref{nproc invocation}.
 +a factor of log @var{n}.  Also see @ref{nproc}.
  
  @item -u
  @itemx --unique
-@@ -4922,7 +4904,7 @@ The commands @code{sort -u} and @code{so
+@@ -4954,7 +4936,7 @@ The commands @code{sort -u} and @code{so
  this equivalence does not extend to arbitrary @command{sort} options.
  For example, @code{sort -n -u} inspects only the value of the initial
  numeric string when checking for uniqueness, whereas @code{sort -n |
  
  @optZeroTerminated
  @macro newlineFieldSeparator
-@@ -5138,7 +5120,7 @@ ls */* | sort -t / -k 1,1R -k 2,2
+@@ -5170,7 +5152,7 @@ ls */* | sort -t / -k 1,1R -k 2,2
  @end itemize
  
  
  @section @command{shuf}: Shuffling text
  
  @pindex shuf
-@@ -5294,7 +5276,7 @@ shuf -r -n 100 -e Head Tail
+@@ -5326,7 +5308,7 @@ shuf -r -n 100 -e Head Tail
  @exitstatus
  
  
  @section @command{uniq}: Uniquify files
  
  @pindex uniq
-@@ -5316,7 +5298,7 @@ lines that are not repeated, or all repe
+@@ -5348,7 +5330,7 @@ lines that are not repeated, or all repe
  The input need not be sorted, but repeated input lines are detected
  only if they are adjacent.  If you want to discard non-adjacent
  duplicate lines, perhaps you want to use @code{sort -u}.
  
  @vindex LC_COLLATE
  Comparisons honor the rules specified by the @env{LC_COLLATE}
-@@ -5482,7 +5464,7 @@ compared.
+@@ -5514,7 +5496,7 @@ compared.
  @exitstatus
  
  
  @section @command{comm}: Compare two sorted files line by line
  
  @pindex comm
-@@ -5598,7 +5580,7 @@ $ comm -12 file1 file2 | wc -l    # numb
+@@ -5630,7 +5612,7 @@ $ comm -12 file1 file2 | wc -l    # numb
  
  @end table
  
  @section @command{ptx}: Produce permuted indexes
  
  @pindex ptx
-@@ -6088,7 +6070,7 @@ allowed with System V @command{ptx}.
+@@ -6120,7 +6102,7 @@ allowed with System V @command{ptx}.
  @end itemize
  
  
  @section @command{tsort}: Topological sort
  
  @pindex tsort
-@@ -6250,13 +6232,13 @@ in different ways.
+@@ -6282,13 +6264,13 @@ in different ways.
  @chapter Operating on fields
  
  @menu
  @section @command{cut}: Print selected parts of lines
  
  @pindex cut
-@@ -6381,7 +6363,7 @@ many fields and want to print all but a
+@@ -6413,7 +6395,7 @@ many fields and want to print all but a
  @exitstatus
  
  
  @section @command{paste}: Merge lines of files
  
  @pindex paste
-@@ -6479,7 +6461,7 @@ $ paste -d '%_' num2 let3 num2
+@@ -6511,7 +6493,7 @@ $ paste -d '%_' num2 let3 num2
  @exitstatus
  
  
  @section @command{join}: Join lines on a common field
  
  @pindex join
-@@ -7011,13 +6993,13 @@ entire lines as the key.
+@@ -7043,13 +7025,13 @@ entire lines as the key.
  These commands operate on individual characters.
  
  @menu
  @section @command{tr}: Translate, squeeze, and/or delete characters
  
  @pindex tr
-@@ -7440,7 +7422,7 @@ tr -d -- -axM
+@@ -7472,7 +7454,7 @@ tr -d -- -axM
  @end itemize
  
  
  @section @command{expand}: Convert tabs to spaces
  
  @pindex expand
-@@ -7509,7 +7491,7 @@ characters) on each line to spaces.
+@@ -7541,7 +7523,7 @@ characters) on each line to spaces.
  @exitstatus
  
  
  @section @command{unexpand}: Convert spaces to tabs
  
  @pindex unexpand
-@@ -7572,14 +7554,14 @@ This chapter describes the @command{ls}
+@@ -7604,14 +7586,14 @@ This chapter describes the @command{ls}
  and @command{vdir}, which list information about files.
  
  @menu
  @section @command{ls}: List directory contents
  
  @pindex ls
-@@ -8495,7 +8477,7 @@ be one of the following:
+@@ -8531,7 +8513,7 @@ be one of the following:
  @item +@var{format}
  @vindex LC_TIME
  List timestamps using @var{format}, where @var{format} is interpreted
  For example, @option{--time-style="+%Y-%m-%d %H:%M:%S"} causes
  @command{ls} to list timestamps like @samp{2020-03-30 23:45:56}.  As
  with @command{date}, @var{format}'s interpretation is affected by the
-@@ -8696,7 +8678,7 @@ This is the default unless the output is
+@@ -8732,7 +8714,7 @@ This is the default unless the output is
  @end table
  
  
  @section @command{dir}: Briefly list directory contents
  
  @pindex dir
-@@ -8706,10 +8688,10 @@ This is the default unless the output is
+@@ -8742,10 +8724,10 @@ This is the default unless the output is
  -b}; that is, by default files are listed in columns, sorted vertically,
  and special characters are represented by backslash escape sequences.
  
  @section @command{vdir}: Verbosely list directory contents
  
  @pindex vdir
-@@ -8719,9 +8701,9 @@ and special characters are represented b
+@@ -8755,9 +8737,9 @@ and special characters are represented b
  -b}; that is, by default files are listed in long format and special
  characters are represented by backslash escape sequences.
  
  @section @command{dircolors}: Color setup for @command{ls}
  
  @pindex dircolors
-@@ -8814,16 +8796,16 @@ This chapter describes the commands for
+@@ -8850,16 +8832,16 @@ This chapter describes the commands for
  copying, moving (renaming), and deleting (removing).
  
  @menu
  @section @command{cp}: Copy files and directories
  
  @pindex cp
-@@ -9356,7 +9338,7 @@ option, and overrides the @option{--pres
+@@ -9399,7 +9381,7 @@ option, and overrides the @option{--pres
  @exitstatus
  
  
  @section @command{dd}: Convert and copy a file
  
  @pindex dd
-@@ -9666,7 +9648,7 @@ If neither this nor @samp{fsync} are spe
+@@ -9709,7 +9691,7 @@ If neither this nor @samp{fsync} are spe
  usual with file systems, i.e., output data and metadata may be cached
  in primary memory for some time before the operating system physically
  writes it, and thus output data and metadata may be lost if power is lost.
  This conversion is a GNU extension to POSIX.
  
  @item fsync
-@@ -9945,7 +9927,7 @@ environment variable is set.
+@@ -9987,7 +9969,7 @@ environment variable is set.
  @exitstatus
  
  
  @section @command{install}: Copy files and set attributes
  
  @pindex install
-@@ -10129,7 +10111,7 @@ This option is mutually exclusive with t
+@@ -10171,7 +10153,7 @@ This option is mutually exclusive with t
  @exitstatus
  
  
  @section @command{mv}: Move (rename) files
  
  @pindex mv
-@@ -10284,7 +10266,7 @@ to the system default type for destinati
+@@ -10354,7 +10336,7 @@ to the system default type for destinati
  @exitstatus
  
  
  @section @command{rm}: Remove files or directories
  
  @pindex rm
-@@ -10450,7 +10432,7 @@ predates the development of the @code{ge
+@@ -10520,7 +10502,7 @@ predates the development of the @code{ge
  @exitstatus
  
  
  @section @command{shred}: Remove files more securely
  
  @pindex shred
-@@ -10460,7 +10442,7 @@ predates the development of the @code{ge
+@@ -10530,7 +10512,7 @@ predates the development of the @code{ge
  @command{shred} overwrites devices or files, to help prevent even
  extensive forensics from recovering the data.
  
  and metadata are not actually destroyed.  Only the file's directory
  entry is removed, and the file's storage is reclaimed only when no
  process has the file open and no other directory entry links to the
-@@ -10747,18 +10729,18 @@ Besides directories, other special file
+@@ -10817,18 +10799,18 @@ Besides directories, other special file
  (FIFOs), symbolic links, sockets, and so-called @dfn{special files}.
  
  @menu
  @section @command{link}: Make a hard link via the link syscall
  
  @pindex link
-@@ -10771,7 +10753,7 @@ It is a minimalist interface to the syst
+@@ -10841,7 +10823,7 @@ It is a minimalist interface to the syst
  @code{link} function.  @xref{Hard Links, , , libc,
  The GNU C Library Reference Manual}.
  It avoids the bells and whistles of the more commonly-used
  Synopsis:
  
  @example
-@@ -10797,7 +10779,7 @@ to specify which behavior is desired.
+@@ -10867,7 +10849,7 @@ to specify which behavior is desired.
  @exitstatus
  
  
  @section @command{ln}: Make links between files
  
  @pindex ln
-@@ -10985,7 +10967,7 @@ ln -srv /a/file /tmp
+@@ -11055,7 +11037,7 @@ ln -srv /a/file /tmp
  Relative symbolic links are generated based on their canonicalized
  containing directory, and canonicalized targets.  I.e., all symbolic
  links in these file names will be resolved.
  over relative file name generation, as demonstrated in the following example:
  
  @example
-@@ -11062,7 +11044,7 @@ ln -s ../adir/afile yetanotherfile
+@@ -11132,7 +11114,7 @@ ln -s ../adir/afile yetanotherfile
  @end example
  
  
  @section @command{mkdir}: Make directories
  
  @pindex mkdir
-@@ -11140,7 +11122,7 @@ Print a message for each created directo
+@@ -11210,7 +11192,7 @@ Print a message for each created directo
  @exitstatus
  
  
  @section @command{mkfifo}: Make FIFOs (named pipes)
  
  @pindex mkfifo
-@@ -11181,7 +11163,7 @@ permission bits.  @xref{File permissions
+@@ -11251,7 +11233,7 @@ permission bits.  @xref{File permissions
  @exitstatus
  
  
  @section @command{mknod}: Make block or character special files
  
  @pindex mknod
-@@ -11258,7 +11240,7 @@ Set the mode of created files to @var{mo
+@@ -11328,7 +11310,7 @@ Set the mode of created files to @var{mo
  @exitstatus
  
  
  @section @command{readlink}: Print value of a symlink or canonical file name
  
  @pindex readlink
-@@ -11282,7 +11264,7 @@ of a symbolic link, it produces no outpu
+@@ -11352,7 +11334,7 @@ of a symbolic link, it produces no outpu
  @command{readlink} outputs the absolute name of the given files which contain
  no @file{.}, @file{..} components nor any repeated separators
- (@file{/}) or symbolic links.  Note the @command{realpath} command is the
+ (@file{/}) or symbolic links.  The @command{realpath} command is the
 -preferred command to use for canonicalization.  @xref{realpath invocation}.
 +preferred command to use for canonicalization.  @xref{realpath}.
  
  @end table
  
-@@ -11357,7 +11339,7 @@ The @command{realpath} command without o
+@@ -11427,7 +11409,7 @@ The @command{realpath} command without o
  @exitstatus
  
  
  @section @command{rmdir}: Remove empty directories
  
  @pindex rmdir
-@@ -11404,7 +11386,7 @@ Give a diagnostic for each successful re
+@@ -11474,7 +11456,7 @@ Give a diagnostic for each successful re
  
  @end table
  
  
  To remove all empty directories under @var{dirname}, including
  directories that become empty because other directories are removed,
-@@ -11421,7 +11403,7 @@ find @var{dirname} -depth -type d -exec
+@@ -11491,7 +11473,7 @@ find @var{dirname} -depth -type d -exec
  @exitstatus
  
  
  @section @command{unlink}: Remove files via the unlink syscall
  
  @pindex unlink
-@@ -11432,7 +11414,7 @@ It is a minimalist interface to the syst
+@@ -11502,7 +11484,7 @@ It is a minimalist interface to the syst
  @code{unlink} function.  @xref{Deleting Files, , , libc,
  The GNU C Library Reference Manual}.  Synopsis:
  It avoids the bells and whistles of the more commonly-used
  
  @example
  unlink @var{filename}
-@@ -11466,14 +11448,14 @@ timestamps, and other information.  Coll
+@@ -11536,14 +11518,14 @@ timestamps, and other information.  Coll
  These commands change file attributes.
  
  @menu
  @section @command{chown}: Change file owner and group
  
  @pindex chown
-@@ -11701,7 +11683,7 @@ chown -hR root /u
+@@ -11775,7 +11757,7 @@ chown -hR root /u
  @end example
  
  
  @section @command{chgrp}: Change group ownership
  
  @pindex chgrp
-@@ -11710,7 +11692,7 @@ chown -hR root /u
+@@ -11784,7 +11766,7 @@ chown -hR root /u
  
  @command{chgrp} changes the group ownership of each given @var{file}
  to @var{group} (which can be either a group name or a numeric group ID)
  Synopsis:
  
  @example
-@@ -11829,7 +11811,7 @@ chgrp -hR staff /u
+@@ -11886,7 +11868,7 @@ chgrp -hR staff /u
  @end example
  
  
  @section @command{chmod}: Change access permissions
  
  @pindex chmod
-@@ -11951,7 +11933,7 @@ chmod -R a=,+rwX dir
+@@ -12037,7 +12019,7 @@ chmod -R a=,+rwX dir
  @end smallexample
  
  
  @section @command{touch}: Change file timestamps
  
  @pindex touch
-@@ -12126,15 +12108,15 @@ how much storage is in use or available,
+@@ -12212,15 +12194,15 @@ how much storage is in use or available,
  file status information, and write buffers to file systems.
  
  @menu
  @section @command{df}: Report file system space usage
  
  @pindex df
-@@ -12442,7 +12424,7 @@ be read and one or more of the options @
+@@ -12528,7 +12510,7 @@ be read and one or more of the options @
  or @option{-x} is used together with a file name argument.
  
  
  @section @command{du}: Estimate file space usage
  
  @pindex du
-@@ -12701,7 +12683,7 @@ be one of the following:
+@@ -12787,7 +12769,7 @@ be one of the following:
  @item +@var{format}
  @vindex LC_TIME
  List timestamps using @var{format}, where @var{format} is interpreted
  For example, @option{--time-style="+%Y-%m-%d %H:%M:%S"} causes
  @command{du} to list timestamps like @samp{2020-07-21 23:45:56}.  As
  with @command{date}, @var{format}'s interpretation is affected by the
-@@ -12797,7 +12779,7 @@ underlying devices.
+@@ -12883,7 +12865,7 @@ underlying devices.
  @exitstatus
  
  
  @section @command{stat}: Report file or file system status
  
  @pindex stat
-@@ -13039,7 +13021,7 @@ with @env{TZ}, libc, The GNU C Library R
+@@ -13125,7 +13107,7 @@ with @env{TZ}, libc, The GNU C Library R
  @exitstatus
  
  
  @section @command{sync}: Synchronize cached writes to persistent storage
  
  @pindex sync
-@@ -13099,7 +13081,7 @@ write barriers, than a global sync(2) us
+@@ -13185,7 +13167,7 @@ write barriers, than a global sync(2) us
  @exitstatus
  
  
  @section @command{truncate}: Shrink or extend the size of a file
  
  @pindex truncate
-@@ -13176,13 +13158,13 @@ the size of each @var{file} based on its
+@@ -13262,13 +13244,13 @@ the size of each @var{file} based on its
  This section describes commands that display text strings.
  
  @menu
  @section @command{echo}: Print a line of text
  
  @pindex echo
-@@ -13205,7 +13187,7 @@ strings cannot be passed to @command{ech
+@@ -13291,7 +13273,7 @@ strings cannot be passed to @command{ech
  It is therefore not advisable to use @command{echo} for printing unknown or
  variable arguments.  The @command{printf} command is recommended as a more
  portable and flexible replacement for tasks historically performed by
  
  The program accepts the following options.  Also see @ref{Common options}.
  Options must precede operands, and the normally-special argument
-@@ -13280,12 +13262,12 @@ POSIX does not require support for any o
+@@ -13366,12 +13348,12 @@ POSIX does not require support for any o
  that the behavior of @command{echo} is implementation-defined if any
  @var{string} contains a backslash or if the first argument is @option{-n}.
  Portable programs should use the @command{printf} command instead.
  @section @command{printf}: Format and print data
  
  @pindex printf
-@@ -13447,7 +13429,7 @@ Options must precede operands.
+@@ -13533,7 +13515,7 @@ Options must precede operands.
  @exitstatus
  
  
  @section @command{yes}: Print a string until interrupted
  
  @pindex yes
-@@ -13478,14 +13460,14 @@ condition of shell @code{if} statements,
+@@ -13564,14 +13546,14 @@ condition of shell @code{if} statements,
  pipeline.
  
  @menu
  @section @command{false}: Do nothing, unsuccessfully
  
  @pindex false
-@@ -13515,7 +13497,7 @@ Portable programs should not assume that
+@@ -13601,7 +13583,7 @@ Portable programs should not assume that
  non-GNU hosts.
  
  
  @section @command{true}: Do nothing, successfully
  
  @pindex true
-@@ -13551,7 +13533,7 @@ This version of @command{true} is implem
+@@ -13637,7 +13619,7 @@ This version of @command{true} is implem
  more secure and faster than a shell script implementation, and may safely
  be used as a dummy shell for the purpose of disabling accounts.
  
  @section @command{test}: Check file types and compare values
  
  @pindex test
-@@ -13922,7 +13904,7 @@ True if either @var{expr1} or @var{expr2
+@@ -14006,7 +13988,7 @@ True if either @var{expr1} or @var{expr2
  @end table
  
  
  @section @command{expr}: Evaluate expressions
  
  @pindex expr
-@@ -14199,11 +14181,11 @@ useful redirection is performed by a sep
+@@ -14283,11 +14265,11 @@ useful redirection is performed by a sep
  it's described here.
  
  @menu
  @section @command{tee}: Redirect output to multiple files or processes
  
  @pindex tee
-@@ -14419,15 +14401,15 @@ tar chof - "$tardir" \
+@@ -14503,15 +14485,15 @@ tar chof - "$tardir" \
  This section describes commands that manipulate file names.
  
  @menu
  @section @command{basename}: Strip directory and suffix from a file name
  
  @pindex basename
-@@ -14509,7 +14491,7 @@ basename -a -s .h include/stdio.h includ
+@@ -14593,7 +14575,7 @@ basename -a -s .h include/stdio.h includ
  @end example
  
  
  @section @command{dirname}: Strip last file name component
  
  @pindex dirname
-@@ -14562,7 +14544,7 @@ dirname stdio.h
+@@ -14646,7 +14628,7 @@ dirname stdio.h
  @end example
  
  
  @section @command{pathchk}: Check file name validity and portability
  
  @pindex pathchk
-@@ -14638,7 +14620,7 @@ Exit status:
+@@ -14722,7 +14704,7 @@ Exit status:
  1 otherwise.
  @end display
  
  @section @command{mktemp}: Create temporary file or directory
  
  @pindex mktemp
-@@ -14813,7 +14795,7 @@ Exit status:
+@@ -14897,7 +14879,7 @@ Exit status:
  @end display
  
  
  @section @command{realpath}: Print the resolved file name.
  
  @pindex realpath
-@@ -15005,14 +14987,14 @@ which you are working: the current direc
+@@ -15089,14 +15071,14 @@ which you are working: the current direc
  so forth.  See also the user-related commands in the next section.
  
  @menu
  @section @command{pwd}: Print working directory
  
  @pindex pwd
-@@ -15059,7 +15041,7 @@ environment variable is set.
+@@ -15143,7 +15125,7 @@ environment variable is set.
  @exitstatus
  
  
  @section @command{stty}: Print or change terminal characteristics
  
  @pindex stty
-@@ -15803,7 +15785,7 @@ or
+@@ -15887,7 +15869,7 @@ or
  @end table
  
  
  @section @command{printenv}: Print all or some environment variables
  
  @pindex printenv
-@@ -15838,7 +15820,7 @@ Exit status:
+@@ -15922,7 +15904,7 @@ Exit status:
  @end display
  
  
  @section @command{tty}: Print file name of terminal on standard input
  
  @pindex tty
-@@ -15888,16 +15870,16 @@ This section describes commands that pri
+@@ -15972,17 +15954,17 @@ This section describes commands that pri
  logins, groups, and so forth.
  
  @menu
 -* groups invocation::           Print group names a user is in.
 -* users invocation::            Print login names of users currently logged in.
 -* who invocation::              Print who is currently logged in.
+-* pinky invocation::            Print information about users.
 +* id::                          Print user identity.
 +* logname::                     Print current login name.
 +* whoami::                      Print effective user ID.
 +* groups::                      Print group names a user is in.
 +* users::                       Print login names of users currently logged in.
 +* who::                         Print who is currently logged in.
++* pinky::                       Print information about users.
  @end menu
  
  
  @section @command{id}: Print user identity
  
  @pindex id
-@@ -16004,7 +15986,7 @@ database to be consulted afresh, and so
+@@ -16089,7 +16071,7 @@ database to be consulted afresh, and so
  
  @exitstatus
  
  @section @command{logname}: Print current login name
  
  @pindex logname
-@@ -16025,7 +16007,7 @@ options}.
+@@ -16110,7 +16092,7 @@ options}.
  @exitstatus
  
  
  @section @command{whoami}: Print effective user name
  
  @pindex whoami
-@@ -16041,7 +16023,7 @@ options}.
+@@ -16126,7 +16108,7 @@ options}.
  @exitstatus
  
  
  @section @command{groups}: Print group names a user is in
  
  @pindex groups
-@@ -16068,7 +16050,7 @@ options}.
+@@ -16153,7 +16135,7 @@ options}.
  
  @exitstatus
  
  @section @command{users}: Print login names of users currently logged in
  
  @pindex users
-@@ -16103,7 +16085,7 @@ should not rely on its existence on non-
+@@ -16188,7 +16170,7 @@ should not rely on its existence on non-
  @exitstatus
  
  
  @section @command{who}: Print who is currently logged in
  
  @pindex who
-@@ -16266,16 +16248,14 @@ This section describes commands that pri
+@@ -16342,7 +16324,7 @@ should not rely on its existence on non-
+ @exitstatus
+-@node pinky invocation
++@node pinky
+ @section @command{pinky}: Print information about users
+ @command{pinky} is a lightweight implementation of the @command{finger} command.
+@@ -16417,16 +16399,14 @@ This section describes commands that pri
  information.
  
  @menu
  @section @command{date}: Print or set system date and time
  
  @pindex date
-@@ -17049,7 +17029,7 @@ date --date='2017-01-01 00:00:00 +0000'
+@@ -17200,7 +17180,7 @@ date --date='2017-01-01 00:00:00 +0000'
  @end itemize
  
  
  @section @command{arch}: Print machine hardware name
  
  @pindex arch
-@@ -17072,7 +17052,7 @@ not rely on its existence.
+@@ -17223,7 +17203,7 @@ not rely on its existence.
  @exitstatus
  
  
  @section @command{nproc}: Print the number of available processors
  
  @pindex nproc
-@@ -17111,7 +17091,7 @@ If possible, exclude this @var{number} o
+@@ -17262,7 +17242,7 @@ If possible, exclude this @var{number} o
  @exitstatus
  
  
  @section @command{uname}: Print system information
  
  @pindex uname
-@@ -17241,35 +17221,7 @@ Print the kernel version.
+@@ -17392,35 +17372,7 @@ Print the kernel version.
  @exitstatus
  
  
  @section @command{hostid}: Print numeric host identifier
  
  @pindex hostid
-@@ -17297,44 +17249,6 @@ existence.
+@@ -17448,44 +17400,6 @@ existence.
  
  @exitstatus
  
  @node SELinux context
  @chapter SELinux context
  
-@@ -17346,11 +17260,11 @@ This section describes commands for oper
+@@ -17497,11 +17411,11 @@ This section describes commands for oper
  contexts.
  
  @menu
  @section @command{chcon}: Change SELinux context of file
  
  @pindex chcon
-@@ -17453,7 +17367,7 @@ Set range @var{range} in the target secu
+@@ -17604,7 +17518,7 @@ Set range @var{range} in the target secu
  
  @exitstatus
  
  @section @command{runcon}: Run a command in specified SELinux context
  
  @pindex runcon
-@@ -17546,16 +17460,16 @@ different than the current one: a modifi
+@@ -17697,16 +17611,16 @@ different than the current one: a modifi
  user, etc.
  
  @menu
  @section @command{chroot}: Run a command with a different root directory
  
  @pindex chroot
-@@ -17671,7 +17585,7 @@ the exit status of @var{command} otherwi
+@@ -17822,7 +17736,7 @@ the exit status of @var{command} otherwi
  @end display
  
  
  @section @command{env}: Run a command in a modified environment
  
  @pindex env
-@@ -18293,7 +18207,7 @@ OLDUSER=gordon
+@@ -18451,7 +18365,7 @@ OLDUSER=gordon
  
  
  
  @section @command{nice}: Run a command with modified niceness
  
  @pindex nice
-@@ -18424,7 +18338,7 @@ $ sudo nice -n -1 nice
+@@ -18582,7 +18496,7 @@ $ sudo nice -n -1 nice
  @end example
  
  
  @section @command{nohup}: Run a command immune to hangups
  
  @pindex nohup
-@@ -18498,7 +18412,7 @@ If @env{POSIXLY_CORRECT} is set, interna
+@@ -18656,7 +18570,7 @@ If @env{POSIXLY_CORRECT} is set, interna
  instead of 125.
  
  
  @section @command{stdbuf}: Run a command with modified I/O stream buffering
  
  @pindex stdbuf
-@@ -18592,7 +18506,7 @@ the exit status of @var{command} otherwi
+@@ -18752,7 +18666,7 @@ the exit status of @var{command} otherwi
  @end display
  
  
  @section @command{timeout}: Run a command with a time limit
  
  @pindex timeout
-@@ -18728,90 +18642,6 @@ timeout -s INT 5s env --ignore-signal=IN
+@@ -18888,90 +18802,6 @@ timeout -s INT 5s env --ignore-signal=IN
  timeout -s INT -k 3s 5s env --ignore-signal=INT sleep 20
  @end example
  
  @node Delaying
  @chapter Delaying
  
-@@ -18821,11 +18651,11 @@ signal names and numbers.
+@@ -18981,11 +18811,11 @@ signal names and numbers.
  @c Perhaps @command{wait} or other commands should be described here also?
  
  @menu
  @section @command{sleep}: Delay for a specified time
  
  @pindex sleep
-@@ -18888,13 +18718,13 @@ options}.
+@@ -19048,13 +18878,13 @@ options}.
  These programs do numerically-related operations.
  
  @menu
  @section @command{factor}: Print prime factors
  
  @pindex factor
-@@ -18959,7 +18789,7 @@ are the product of two large primes), ot
+@@ -19119,7 +18949,7 @@ are the product of two large primes), ot
  @exitstatus
  
  
  @section @command{numfmt}: Reformat numbers
  
  @pindex numfmt
-@@ -19312,7 +19142,7 @@ $ LC_ALL=ta_IN numfmt --from=iec --forma
+@@ -19475,7 +19305,7 @@ $ LC_ALL=ta_IN numfmt --from=iec --forma
  @end example
  
  
  @section @command{seq}: Print numeric sequences
  
  @pindex seq
-@@ -19487,7 +19317,7 @@ Naively, a file's atime, mtime, and ctim
+@@ -19650,7 +19480,7 @@ Naively, a file's atime, mtime, and ctim
  whenever you read, write, or change the attributes of the file
  respectively, and searching a directory counts as reading it.  A
  file's atime and mtime can also be set directly, via the
index e834afece1f3e759eebaf895a3201fb0687e4d0f..9d5ef5b6e948c6a961b8aafa378545628da6b1ef 100644 (file)
@@ -8,12 +8,12 @@
 Summary:       GNU Core-utils - basic command line utilities
 Summary(pl.UTF-8):     GNU Core-utils - podstawowe narzędzia działające z linii poleceń
 Name:          coreutils
-Version:       9.4
+Version:       9.5
 Release:       1
 License:       GPL v3+
 Group:         Applications/System
 Source0:       http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
-# Source0-md5: 459e9546074db2834eefe5421f250025
+# Source0-md5: e99adfa059a63db3503cc71f3d151e31
 Source1:       %{name}-non-english-man-pages.tar.bz2
 # Source1-md5: f7c986ebc74ccb8d08ed70141063f14c
 Source2:       DIR_COLORS
This page took 0.280761 seconds and 4 git commands to generate.