]> git.pld-linux.org Git - packages/coreutils.git/blobdiff - coreutils.spec
- partially update from fedora, fixes test suite
[packages/coreutils.git] / coreutils.spec
index 9e15575ce673b852911442ae79c5fd9ea3f3c352..180b00191edb3a61ef78f793d4c2f6a8fcf15299 100644 (file)
@@ -1,12 +1,17 @@
+#
+# Conditional build:
+%bcond_with    advcopy # progress bar in cp (orphaned patch)
+%bcond_without tests   # do not perform "make test check"
+#
 Summary:       GNU Core-utils - basic command line utilities
 Summary(pl.UTF-8):     GNU Core-utils - podstawowe narzędzia działające z linii poleceń
 Name:          coreutils
-Version:       6.10
+Version:       8.10
 Release:       1
 License:       GPL v3+
 Group:         Applications/System
-Source0:       http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.lzma
-# Source0-md5: 23582a4e8b21e837cfbafbc3834a8a4b
+Source0:       http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
+# Source0-md5: 4bb81c051da6e5436fc1ad9a67ae44fe
 Source1:       %{name}-non-english-man-pages.tar.bz2
 # Source1-md5: f7c986ebc74ccb8d08ed70141063f14c
 Source2:       DIR_COLORS
@@ -24,30 +29,41 @@ Patch3:             %{name}-su-paths.patch
 Patch4:                %{name}-uname-cpuinfo.patch
 Patch5:                %{name}-date-man.patch
 Patch6:                %{name}-mem.patch
-Patch7:                %{name}-install-C.patch
-Patch8:                %{name}-po.patch
+Patch7:                %{name}-7.4-sttytcsadrain.patch
+
 Patch9:                %{name}-fmt-wchars.patch
 Patch10:       %{name}-runuser.patch
 Patch11:       %{name}-split-pam.patch
+Patch12:       %{name}-sparc64.patch
+# http://translationproject.org/latest/coreutils/pl.po (pass through msgcat to generate shorter diff)
+Patch13:       %{name}-pl.po-update.patch
+# from http://www.beatex.org/web/advancedcopy.html, edited by shadzik
+Patch14:       %{name}-advcopy.patch
 URL:           http://www.gnu.org/software/coreutils/
 BuildRequires: acl-devel
-BuildRequires: autoconf >= 2.61
-BuildRequires: automake >= 1:1.10
+BuildRequires: attr-devel
+BuildRequires: autoconf >= 2.62
+BuildRequires: automake >= 1:1.11.1
 BuildRequires: gcc >= 5:3.2
-BuildRequires: gettext-devel >= 0.16-2
+BuildRequires: gettext-devel >= 0.17
+BuildRequires: gmp-devel
 BuildRequires: help2man
+BuildRequires: libcap-devel
 BuildRequires: libselinux-devel
-BuildRequires: lzma
 BuildRequires: pam-devel
 BuildRequires: rpmbuild(find_lang) >= 1.24
+BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo >= 4.2
+BuildRequires: xz
 Requires:      pam >= 0.77.3
 Requires:      setup >= 2.4.6-2
+Provides:      coreutils-su
 Provides:      fileutils
-Provides:      mktemp
+Provides:      mktemp = %{version}-%{release}
 Provides:      sh-utils
 Provides:      stat
 Provides:      textutils
+Obsoletes:     coreutils-su
 Obsoletes:     fileutils
 Obsoletes:     mktemp
 Obsoletes:     sh-utils
@@ -72,9 +88,9 @@ The programs that can be built with this package are:
   dd df dir dircolors dirname du echo env expand expr factor false fmt
   fold install groups head hostid id join link ln logname ls md5sum
   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
-  printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
-  su sum sync tac tail tee test touch tr true tsort tty uname unexpand
-  uniq unlink users vdir wc who whoami yes
+  printf ptx pwd rm rmdir runuser seq sha1sum shred sleep sort split
+  stat stty su sum sync tac tail tee test touch tr true tsort tty uname
+  unexpand uniq unlink users vdir wc who whoami yes
 
 %description -l pl.UTF-8
 Narzędzia podstawowe (core utilities) GNU to połączone paczki GNU
@@ -90,13 +106,13 @@ Programy zawarte w tym pakiecie to:
   dd df dir dircolors dirname du echo env expand expr factor false fmt
   fold ginstall groups head hostid id join link ln logname ls md5sum
   mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
-  printf ptx pwd rm rmdir seq sha1sum shred sleep sort split stat stty
-  su sum sync tac tail tee test touch tr true tsort tty uname unexpand
-  uniq unlink users vdir wc who whoami yes
+  printf ptx pwd rm rmdir runuser seq sha1sum shred sleep sort split
+  stat stty su sum sync tac tail tee test touch tr true tsort tty uname
+  unexpand uniq unlink users vdir wc who whoami yes
 
 %prep
-%setup -q -c -T -a1
-lzma -dc %{SOURCE0} | tar xf - -C ..
+%setup -q -a1
+%patch13 -p1
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -105,15 +121,21 @@ lzma -dc %{SOURCE0} | tar xf - -C ..
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
-%patch8 -p1
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
+%ifarch sparc64
+%patch12 -p1
+%endif
+%if %{with advcopy}
+# progress-bar patch, -g,--progress-bar //if in doubt, comment it out
+%patch14 -p1
+%endif
 
 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
 
 # allow rebuilding *.gmo
-rm -f po/stamp-po
+%{__rm} po/stamp-po
 
 %build
 %{__gettextize}
@@ -124,12 +146,15 @@ rm -f po/stamp-po
 %configure \
        CFLAGS="%{rpmcflags} -DSYSLOG_SUCCESS -DSYSLOG_FAILURE -DSYSLOG_NON_ROOT" \
        DEFAULT_POSIX2_VERSION=199209 \
+       --disable-silent-rules \
        --enable-install-program=arch \
        --enable-no-install-program=hostname,kill,uptime \
        --enable-pam
 
 %{__make}
 
+%{?with_tests:%{__make} tests check}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/bin,/sbin,%{_bindir},%{_sbindir},/etc/pam.d,/etc/shrc.d}
@@ -137,9 +162,9 @@ install -d $RPM_BUILD_ROOT{/bin,/sbin,%{_bindir},%{_sbindir},/etc/pam.d,/etc/shr
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv -f $RPM_BUILD_ROOT%{_bindir}/{arch,basename,cat,chgrp,chmod,chown,cp,date,dd,df,\
-echo,false,id,link,ln,ls,mkdir,mknod,mv,nice,printf,pwd,rm,rmdir,sleep,sort,stty,\
-sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
+mv -f $RPM_BUILD_ROOT%{_bindir}/{arch,basename,cat,chgrp,chmod,chown,cp,date,dd,\
+df,echo,false,id,link,ln,ls,mkdir,mknod,mktemp,mv,nice,printf,pwd,rm,rmdir,\
+sleep,sort,stat,stty,sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
 
 mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
 
@@ -160,7 +185,7 @@ for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN ; do
        install man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
 done
 install %{SOURCE9} $RPM_BUILD_ROOT%{_mandir}/pl/man1/mktemp.1
-# unwanted
+# unwanted (-f left intentionally - some manuals could have no translations)
 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,uptime}.1
 
 %find_lang %{name}
@@ -183,13 +208,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) /sbin/runuser
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_sbindir}/chroot
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/su
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/su-l
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/runuser
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/runuser-l
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS
-/etc/shrc.d/fileutils.csh
-/etc/shrc.d/fileutils.sh
+%config(noreplace) /etc/shrc.d/fileutils.*sh
+%dir %{_libdir}/coreutils
+%attr(755,root,root) %{_libdir}/coreutils/libstdbuf.so
 %{_mandir}/man1/*
 %lang(cs) %{_mandir}/cs/man1/*
 %lang(da) %{_mandir}/da/man1/*
This page took 0.037793 seconds and 4 git commands to generate.