]> git.pld-linux.org Git - packages/coq.git/commitdiff
- up to 8.4pl3 auto/th/coq-8.4pl3-1
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 30 Apr 2014 17:25:48 +0000 (19:25 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 30 Apr 2014 17:25:48 +0000 (19:25 +0200)
coq-lablgtk2.patch
coq.spec

index e198ec3858aeb56db6d0d03dc240d846958b6f46..11027593e279687e86ef5865c1fd1165b7d73e0e 100644 (file)
@@ -1,31 +1,32 @@
 --- coq-8.1pl4/configure~      2008-10-09 11:40:41.000000000 +0200
 +++ coq-8.1pl4/configure       2009-02-16 14:03:00.496249846 +0100
-@@ -471,13 +471,13 @@
- else
-     case $lablgtkdir_spec in
-       no) 
--          if [ -f "${CAMLLIB}/lablgtk2/glib.mli" ]; then
-+          if [ -f "${CAMLLIB}/lablgtk2/glib.cmi" ]; then
-               lablgtkdir=${CAMLLIB}/lablgtk2
--          elif [ -f "${CAMLLIB}/site-lib/lablgtk2/glib.mli" ]; then
-+          elif [ -f "${CAMLLIB}/site-lib/lablgtk2/glib.cmi" ]; then
-               lablgtkdir=${CAMLLIB}/site-lib/lablgtk2
-           fi;;
-       yes)
--          if [ ! -f "$lablgtkdir/glib.mli" ]; then
-+          if [ ! -f "$lablgtkdir/glib.cmi" ]; then
-               echo "Incorrect LablGtk2 library (glib.mli not found)."
+@@ -634,7 +634,7 @@
+             # Beware of the final \r in Win32
+             lablgtkdirtmp="$(ocamlfind query lablgtk2 2> /dev/null | tr -d '\r')"
+             if [ "$lablgtkdirtmp" != "" ]; then
+-                if [ -f "$lablgtkdirtmp/glib.cmi" -a -f "$lablgtkdirtmp/glib.mli" ]; then
++                if [ -f "$lablgtkdirtmp/glib.cmi" -o -f "$lablgtkdirtmp/glib.mli" ]; then
+                     lablgtkdirfoundmsg="LabelGtk2 found by ocamlfind"
+                     lablgtkdir=$lablgtkdirtmp
+                     LABLGTKLIB=$lablgtkdir # Pour le message utilisateur
+@@ -652,7 +652,7 @@
+                 echo "$lablgtkdir is not a valid directory."
                echo "Configuration script failed!"
                exit 1
-@@ -486,9 +486,6 @@
+-          elif [ -f "$lablgtkdir/glib.cmi" -a -f "$lablgtkdir/glib.mli" ]; then
++          elif [ -f "$lablgtkdir/glib.cmi" -o -f "$lablgtkdir/glib.mli" ]; then
+                 lablgtkdirfoundmsg="LablGtk2 directory found"
+                 LABLGTKLIB=$lablgtkdir # Pour le message utilisateur
+             else
+@@ -664,9 +664,6 @@
      if [ "$lablgtkdir" = "" ]; then
        echo "LablGtk2 not found: CoqIde will not be available."
        COQIDE=no
 -    elif [ -z "`grep -w convert_with_fallback "$lablgtkdir/glib.mli"`" ]; then
--      echo "LablGtk2 found but too old: CoqIde will not be available."
+-      echo "$lablgtkdirfoundmsg but too old: CoqIde will not be available."
 -      COQIDE=no;
      elif [ "$coqide_spec" = "yes" -a "$COQIDE" = "byte" ]; then 
-       echo "LablGtk2 found, bytecode CoqIde will be used as requested."
+       echo "$lablgtkdirfoundmsg, bytecode CoqIde will be used as requested."
        COQIDE=byte
 @@ -855,15 +852,7 @@
  ####################################################
index 25c9f7d1637328347127e6fe001fe522ec84acc5..8d9284a3f4ccaf15d1a8bb3d28e608b4b55742a4 100644 (file)
--- a/coq.spec
+++ b/coq.spec
@@ -8,13 +8,13 @@
 Summary:       The Coq Proof Assistant
 Summary(pl.UTF-8):     Coq - narzędzie pomagające w udowadnianiu
 Name:          coq
-Version:       8.3pl1
-Release:       2
+Version:       8.4pl3
+Release:       1
 License:       GPL
 Group:         Applications/Math
 Vendor:                INRIA Rocquencourt
 Source0:       http://coq.inria.fr/V%{version}/files/%{name}-%{version}.tar.gz
-# Source0-md5: 1869d22b337f5da59ba3bbe1433f9a3b
+# Source0-md5: 40a3057ae296bbb228e1e6537f44ccb1
 Source1:       coqide.desktop
 Source2:       coqide.xpm
 Patch0:                %{name}-lablgtk2.patch
@@ -89,6 +89,8 @@ Styl dokumentacji Coq dla latexa.
        -libdir %{_libdir}/coq \
        -mandir %{_mandir} \
        -docdir %{_docdir}/%{name}-%{version} \
+       -configdir %{_sysconfdir}/%{name} \
+       -datadir %{_datadir}/%{name} \
        -emacs emacs \
        -browser "xdg-open %s" \
        -emacslib %{_datadir}/emacs/site-lisp \
@@ -119,6 +121,8 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc %{_docdir}/%{name}-%{version}
+%dir %{_sysconfdir}/%{name}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/coqide-gtk2rc
 %attr(755,root,root) %{_bindir}/coq_makefile
 %attr(755,root,root) %{_bindir}/coq-tex
 %attr(755,root,root) %{_bindir}/coqc
@@ -150,6 +154,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/gallina.1*
 %{_desktopdir}/coqide.desktop
 %{_pixmapsdir}/coqide.xpm
+%{_datadir}/%{name}
 
 %files emacs
 %defattr(644,root,root,755)
This page took 0.047467 seconds and 4 git commands to generate.