]> git.pld-linux.org Git - packages/coq.git/blobdiff - coq.spec
- updated to 8.4pl6
[packages/coq.git] / coq.spec
index b299a6179d214e9d4b0f6f1d4f0b6580b56b059b..ed0021a74af239d410f3c49a6cb3154f308de992 100644 (file)
--- a/coq.spec
+++ b/coq.spec
@@ -3,18 +3,22 @@
 #      - package and R: Csdp (https://projects.coin-or.org/Csdp)
 #
 # Conditional build:
-%bcond_with    tests   # run testsuite (csdp dependant micromega tests fail badly on x86_64)
+%bcond_without ocaml_opt       # skip building native optimized binaries (bytecode is always built)
+%bcond_with    tests           # run testsuite (csdp dependant micromega tests fail badly on x86_64)
 #
+%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
+%undefine      with_ocaml_opt
+%endif
+
 Summary:       The Coq Proof Assistant
 Summary(pl.UTF-8):     Coq - narzędzie pomagające w udowadnianiu
 Name:          coq
-Version:       8.4pl5
+Version:       8.4pl6
 Release:       1
-License:       GPL
+License:       LGPL v2.1
 Group:         Applications/Math
-Vendor:                INRIA Rocquencourt
 Source0:       http://coq.inria.fr/distrib/V%{version}/files/%{name}-%{version}.tar.gz
-# Source0-md5: 7839005b48527a85149da950bd2ac006
+# Source0-md5: 2334a98b64578cb81d2b4127e327b368
 Source1:       coqide.desktop
 Source2:       coqide.xpm
 Patch0:                %{name}-lablgtk2.patch
@@ -27,11 +31,18 @@ BuildRequires:      ocaml >= 3.09.0
 BuildRequires: camlp5 >= 5.01
 BuildRequires: ocaml-lablgtk2-devel >= 2.12.0
 BuildRequires: sed >= 4.0
+BuildRequires: texlive-fonts-cmextra
+BuildRequires: texlive-fonts-cmsuper
+BuildRequires: texlive-fonts-other
+BuildRequires: texlive-format-pdflatex
 BuildRequires: texlive-latex-ams
 BuildRequires: texlive-latex-comment
 BuildRequires: texlive-latex-moreverb
+BuildRequires: texlive-latex-ucs
+BuildRequires: texlive-makeindex
 BuildRequires: texlive-psutils
-BuildRequires: texlive-format-pdflatex
+# hyperref.sty (from latex) requires ifxexex.sty (from xetex)
+BuildRequires: texlive-xetex
 %requires_eq   ocaml-runtime
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -94,12 +105,12 @@ Styl dokumentacji Coq dla latexa.
        -emacs emacs \
        -browser "xdg-open %s" \
        -emacslib %{_datadir}/emacs/site-lisp \
-       -opt \
+       %{?with_ocaml_opt:-opt} \
        --coqdocdir %{_datadir}/texmf/tex/latex/misc \
-       --coqide opt
+       --coqide %{?with_ocaml_opt:opt}%{!?with_ocaml_opt:byte}
 
-%{__make} -j1 world VERBOSE=1
-%{?with_tests:%{__make} -j1 check VERBOSE=1}   # Use native coq to compile theories
+%{__make} -j1 world VERBOSE=1 CAML_LD_LIBRARY_PATH=kernel/byterun
+%{?with_tests:%{__make} -j1 check VERBOSE=1 CAML_LD_LIBRARY_PATH=kernel/byterun} # Use native coq to compile theories
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -114,6 +125,7 @@ install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
 
 # pdf is enough
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/ps
+cp -p CHANGES COMPATIBILITY COPYRIGHT CREDITS README $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -127,14 +139,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/coq-tex
 %attr(755,root,root) %{_bindir}/coqc
 %attr(755,root,root) %{_bindir}/coqchk
-%attr(755,root,root) %{_bindir}/coqchk.opt
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/coqchk.opt}
 %attr(755,root,root) %{_bindir}/coqdep
 %attr(755,root,root) %{_bindir}/coqdoc
 %attr(755,root,root) %{_bindir}/coqide*
 %attr(755,root,root) %{_bindir}/coqmktop
 %attr(755,root,root) %{_bindir}/coqtop
 %attr(755,root,root) %{_bindir}/coqtop.byte
-%attr(755,root,root) %{_bindir}/coqtop.opt
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/coqtop.opt}
 %attr(755,root,root) %{_bindir}/coqwc
 %attr(755,root,root) %{_bindir}/gallina
 %dir %{_libdir}/coq
@@ -149,7 +161,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/coqmktop.1*
 %{_mandir}/man1/coqtop.1*
 %{_mandir}/man1/coqtop.byte.1*
-%{_mandir}/man1/coqtop.opt.1*
+%{?with_ocaml_opt:%{_mandir}/man1/coqtop.opt.1*}
 %{_mandir}/man1/coqwc.1*
 %{_mandir}/man1/gallina.1*
 %{_desktopdir}/coqide.desktop
This page took 0.050361 seconds and 4 git commands to generate.