]> git.pld-linux.org Git - packages/coq.git/blobdiff - coq.spec
- package installed docs
[packages/coq.git] / coq.spec
index 4ad971ece5e9cfd0e6505171d2b890e89441f730..5d9fcec8849b7c70d133018fca38d7e0291f4da7 100644 (file)
--- a/coq.spec
+++ b/coq.spec
@@ -1,3 +1,10 @@
+#
+# TODO:
+#      - package and R: Csdp (https://projects.coin-or.org/Csdp)
+#
+# Conditional build:
+%bcond_with    tests   # run testsuite (csdp dependant micromega tests fail badly on x86_64)
+#
 Summary:       The Coq Proof Assistant
 Summary(pl.UTF-8):     Coq - narzędzie pomagające w udowadnianiu
 Name:          coq
@@ -73,6 +80,7 @@ Styl dokumentacji Coq dla latexa.
 %patch0 -p1
 
 %{__sed} -i -e 's|#!/bin/sh|#!/bin/bash|' test-suite/check
+%{__sed} -i -e 's|\(MAKE_TSOPTS=.*\) -s \(.*\)|\1 \2|' Makefile.build
 
 %build
 ./configure \
@@ -81,14 +89,14 @@ Styl dokumentacji Coq dla latexa.
        -mandir %{_mandir} \
        -docdir %{_docdir}/%{name}-%{version} \
        -emacs emacs \
-       -browser 'iceweasel -remote "OpenURL(%s,new-tab)" || iceweasel %s &' \
+       -browser "xdg-open %s" \
        -emacslib %{_datadir}/emacs/site-lisp \
        -opt \
        --coqdocdir %{_datadir}/texmf/tex/latex/misc \
        --coqide opt
 
-%{__make} -j1 world
-%{__make} -j1 check    # Use native coq to compile theories
+%{__make} -j1 world VERBOSE=1
+%{?with_tests:%{__make} -j1 check VERBOSE=1}   # Use native coq to compile theories
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -101,11 +109,15 @@ install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
 
+# pdf is enough
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/ps
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
+%doc %{_docdir}/%{name}-%{version}
 %attr(755,root,root) %{_bindir}/coq_makefile
 %attr(755,root,root) %{_bindir}/coq-tex
 %attr(755,root,root) %{_bindir}/coqc
This page took 0.036384 seconds and 4 git commands to generate.