]> git.pld-linux.org Git - packages/coq.git/blob - coq.spec
cbb02cd532940d88d568516961f635f86e9677b3
[packages/coq.git] / coq.spec
1 #
2 # TODO:
3 #       - package and R: Csdp (https://projects.coin-or.org/Csdp)
4 #
5 # Conditional build:
6 %bcond_with     tests   # run testsuite (csdp dependant micromega tests fail badly on x86_64)
7 #
8 Summary:        The Coq Proof Assistant
9 Summary(pl.UTF-8):      Coq - narzędzie pomagające w udowadnianiu
10 Name:           coq
11 Version:        8.3pl1
12 Release:        0.1
13 License:        GPL
14 Group:          Applications/Math
15 Vendor:         INRIA Rocquencourt
16 Source0:        http://coq.inria.fr/V%{version}/files/%{name}-%{version}.tar.gz
17 # Source0-md5:  1869d22b337f5da59ba3bbe1433f9a3b
18 Source1:        coqide.desktop
19 Source2:        coqide.xpm
20 Patch0:         %{name}-lablgtk2.patch
21 URL:            http://coq.inria.fr/
22 BuildRequires:  bash
23 BuildRequires:  emacs
24 BuildRequires:  hevea
25 BuildRequires:  netpbm-progs
26 BuildRequires:  ocaml >= 3.09.0
27 BuildRequires:  camlp5 >= 5.01
28 BuildRequires:  ocaml-lablgtk2-devel >= 2.12.0
29 BuildRequires:  sed >= 4.0
30 BuildRequires:  texlive-latex-ams
31 BuildRequires:  texlive-latex-comment
32 BuildRequires:  texlive-latex-moreverb
33 BuildRequires:  texlive-psutils
34 BuildRequires:  texlive-format-pdflatex
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Coq is a proof assistant which:
39  - allows to handle calculus assertions,
40  - check mechanically proofs of these assertions,
41  - helps to find formal proofs,
42  - extracts a certified program from the constructive proof of its
43    formal specification.
44
45 %description -l pl.UTF-8
46 Coq to narzędzie pomagające w udowadnianiu, które:
47 - pozwala uporać się z twierdzeniami dotyczącymi rachunku
48   różniczkowego,
49 - mechanicznie sprawdzać dowody tych twierdzeń,
50 - pomagać w znalezieniu formalnych dowodów,
51 - wyciągać program o dowiedzionej poprawności z konstruktywnego
52   dowodu jego formalnej specyfikacji.
53
54 %package emacs
55 Summary:        Emacs mode and syntax for Coq
56 Summary(pl.UTF-8):      Tryb i składnia Coq dla Emacsa
57 Group:          Development/Tools
58 Requires:       %{name} = %{version}-%{release}
59
60 %description emacs
61 Emacs mode and suyntax files for Coq.
62
63 %description emacs -l pl.UTF-8
64 Pliki trybu i składni Coq dla Emacsa.
65
66 %package latex
67 Summary:        Coq documentation style for latex
68 Summary(pl.UTF-8):      Styl dokumentacji Coq dla latexa
69 Group:          Development/Tools
70 Requires:       %{name} = %{version}-%{release}
71
72 %description latex
73 Coq documentation style for latex.
74
75 %description latex -l pl.UTF-8
76 Styl dokumentacji Coq dla latexa.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81
82 %{__sed} -i -e 's|#!/bin/sh|#!/bin/bash|' test-suite/check
83 %{__sed} -i -e 's|\(MAKE_TSOPTS=.*\) -s \(.*\)|\1 \2|' Makefile.build
84
85 %build
86 ./configure \
87         -bindir %{_bindir} \
88         -libdir %{_libdir}/coq \
89         -mandir %{_mandir} \
90         -docdir %{_docdir}/%{name}-%{version} \
91         -emacs emacs \
92         -browser "xdg-open %s" \
93         -emacslib %{_datadir}/emacs/site-lisp \
94         -opt \
95         --coqdocdir %{_datadir}/texmf/tex/latex/misc \
96         --coqide opt
97
98 %{__make} -j1 world VERBOSE=1
99 %{?with_tests:%{__make} -j1 check VERBOSE=1}    # Use native coq to compile theories
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
104
105 %{__make} -e install \
106         COQINSTALLPREFIX=$RPM_BUILD_ROOT/
107 # To install only locally the binaries compiled with absolute paths
108
109 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
110 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_bindir}/coq_makefile
118 %attr(755,root,root) %{_bindir}/coq-tex
119 %attr(755,root,root) %{_bindir}/coqc
120 %attr(755,root,root) %{_bindir}/coqchk
121 %attr(755,root,root) %{_bindir}/coqchk.opt
122 %attr(755,root,root) %{_bindir}/coqdep
123 %attr(755,root,root) %{_bindir}/coqdoc
124 %attr(755,root,root) %{_bindir}/coqide*
125 %attr(755,root,root) %{_bindir}/coqmktop
126 %attr(755,root,root) %{_bindir}/coqtop
127 %attr(755,root,root) %{_bindir}/coqtop.byte
128 %attr(755,root,root) %{_bindir}/coqtop.opt
129 %attr(755,root,root) %{_bindir}/coqwc
130 %attr(755,root,root) %{_bindir}/gallina
131 %dir %{_libdir}/coq
132 %{_libdir}/coq/*
133 %{_mandir}/man1/coq_makefile.1*
134 %{_mandir}/man1/coq-tex.1*
135 %{_mandir}/man1/coqc.1*
136 %{_mandir}/man1/coqchk.1*
137 %{_mandir}/man1/coqdep.1*
138 %{_mandir}/man1/coqdoc.1*
139 %{_mandir}/man1/coqide.1*
140 %{_mandir}/man1/coqmktop.1*
141 %{_mandir}/man1/coqtop.1*
142 %{_mandir}/man1/coqtop.byte.1*
143 %{_mandir}/man1/coqtop.opt.1*
144 %{_mandir}/man1/coqwc.1*
145 %{_mandir}/man1/gallina.1*
146 %{_desktopdir}/coqide.desktop
147 %{_pixmapsdir}/coqide.xpm
148
149 %files emacs
150 %defattr(644,root,root,755)
151 %{_datadir}/emacs/site-lisp/coq.el
152 %{_datadir}/emacs/site-lisp/coq-db.el
153 %{_datadir}/emacs/site-lisp/coq-font-lock.el
154 %{_datadir}/emacs/site-lisp/coq-inferior.el
155 %{_datadir}/emacs/site-lisp/coq-syntax.el
156
157 %files latex
158 %defattr(644,root,root,755)
159 %{_datadir}/texmf/tex/latex/misc/coqdoc.sty
This page took 0.041135 seconds and 3 git commands to generate.