]> git.pld-linux.org Git - packages/coq.git/blame - coq.spec
- rel 2
[packages/coq.git] / coq.spec
CommitLineData
8f33d8d4 1#
857e15b1
JR
2# TODO:
3# - package and R: Csdp (https://projects.coin-or.org/Csdp)
4#
8f33d8d4 5# Conditional build:
857e15b1 6%bcond_with tests # run testsuite (csdp dependant micromega tests fail badly on x86_64)
8f33d8d4 7#
521adcea 8Summary: The Coq Proof Assistant
374d5475 9Summary(pl.UTF-8): Coq - narzędzie pomagające w udowadnianiu
680764bb 10Name: coq
72eff188 11Version: 8.3pl1
f4499714 12Release: 2
680764bb
JR
13License: GPL
14Group: Applications/Math
15Vendor: INRIA Rocquencourt
5f0acdc3 16Source0: http://coq.inria.fr/V%{version}/files/%{name}-%{version}.tar.gz
72eff188 17# Source0-md5: 1869d22b337f5da59ba3bbe1433f9a3b
8bee228d
JR
18Source1: coqide.desktop
19Source2: coqide.xpm
5f0acdc3 20Patch0: %{name}-lablgtk2.patch
3432574d 21URL: http://coq.inria.fr/
5f0acdc3 22BuildRequires: bash
680764bb 23BuildRequires: emacs
8bee228d
JR
24BuildRequires: hevea
25BuildRequires: netpbm-progs
861daf7b 26BuildRequires: ocaml >= 3.09.0
5f0acdc3 27BuildRequires: camlp5 >= 5.01
72eff188 28BuildRequires: ocaml-lablgtk2-devel >= 2.12.0
5f0acdc3 29BuildRequires: sed >= 4.0
308e7511 30BuildRequires: texlive-latex-ams
8bee228d 31BuildRequires: texlive-latex-comment
b46eabb1 32BuildRequires: texlive-latex-moreverb
8edb6738 33BuildRequires: texlive-psutils
8bee228d 34BuildRequires: texlive-format-pdflatex
f4499714 35%requires_eq ocaml-runtime
680764bb
JR
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39Coq is a proof assistant which:
bcd66107 40 - allows to handle calculus assertions,
41 - check mechanically proofs of these assertions,
42 - helps to find formal proofs,
43 - extracts a certified program from the constructive proof of its
44 formal specification.
3432574d 45
3f4e388b
JR
46%description -l pl.UTF-8
47Coq to narzędzie pomagające w udowadnianiu, które:
48- pozwala uporać się z twierdzeniami dotyczącymi rachunku
49 różniczkowego,
50- mechanicznie sprawdzać dowody tych twierdzeń,
51- pomagać w znalezieniu formalnych dowodów,
52- wyciągać program o dowiedzionej poprawności z konstruktywnego
bcd66107 53 dowodu jego formalnej specyfikacji.
680764bb 54
9019ffc7
JR
55%package emacs
56Summary: Emacs mode and syntax for Coq
57Summary(pl.UTF-8): Tryb i składnia Coq dla Emacsa
58Group: Development/Tools
59Requires: %{name} = %{version}-%{release}
60
61%description emacs
62Emacs mode and suyntax files for Coq.
63
64%description emacs -l pl.UTF-8
65Pliki trybu i składni Coq dla Emacsa.
66
67%package latex
68Summary: Coq documentation style for latex
69Summary(pl.UTF-8): Styl dokumentacji Coq dla latexa
70Group: Development/Tools
71Requires: %{name} = %{version}-%{release}
72
73%description latex
74Coq documentation style for latex.
75
76%description latex -l pl.UTF-8
77Styl dokumentacji Coq dla latexa.
78
680764bb
JR
79%prep
80%setup -q
5f0acdc3
JR
81%patch0 -p1
82
83%{__sed} -i -e 's|#!/bin/sh|#!/bin/bash|' test-suite/check
857e15b1 84%{__sed} -i -e 's|\(MAKE_TSOPTS=.*\) -s \(.*\)|\1 \2|' Makefile.build
680764bb
JR
85
86%build
87./configure \
88 -bindir %{_bindir} \
89 -libdir %{_libdir}/coq \
90 -mandir %{_mandir} \
2dc46485 91 -docdir %{_docdir}/%{name}-%{version} \
680764bb 92 -emacs emacs \
8f33d8d4 93 -browser "xdg-open %s" \
680764bb
JR
94 -emacslib %{_datadir}/emacs/site-lisp \
95 -opt \
1c74cbbc 96 --coqdocdir %{_datadir}/texmf/tex/latex/misc \
8bee228d 97 --coqide opt
680764bb 98
857e15b1
JR
99%{__make} -j1 world VERBOSE=1
100%{?with_tests:%{__make} -j1 check VERBOSE=1} # Use native coq to compile theories
680764bb
JR
101
102%install
103rm -rf $RPM_BUILD_ROOT
8bee228d 104install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
3432574d
JB
105
106%{__make} -e install \
107 COQINSTALLPREFIX=$RPM_BUILD_ROOT/
680764bb
JR
108# To install only locally the binaries compiled with absolute paths
109
8bee228d
JR
110install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
111install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
112
c10c241b
JR
113# pdf is enough
114%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/ps
115
680764bb
JR
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%files
120%defattr(644,root,root,755)
c10c241b 121%doc %{_docdir}/%{name}-%{version}
861daf7b 122%attr(755,root,root) %{_bindir}/coq_makefile
9019ffc7 123%attr(755,root,root) %{_bindir}/coq-tex
680764bb 124%attr(755,root,root) %{_bindir}/coqc
2dc46485
JR
125%attr(755,root,root) %{_bindir}/coqchk
126%attr(755,root,root) %{_bindir}/coqchk.opt
680764bb 127%attr(755,root,root) %{_bindir}/coqdep
1c74cbbc 128%attr(755,root,root) %{_bindir}/coqdoc
5f0acdc3 129%attr(755,root,root) %{_bindir}/coqide*
861daf7b
JR
130%attr(755,root,root) %{_bindir}/coqmktop
131%attr(755,root,root) %{_bindir}/coqtop
132%attr(755,root,root) %{_bindir}/coqtop.byte
133%attr(755,root,root) %{_bindir}/coqtop.opt
1c74cbbc 134%attr(755,root,root) %{_bindir}/coqwc
861daf7b 135%attr(755,root,root) %{_bindir}/gallina
3432574d 136%dir %{_libdir}/coq
1c74cbbc 137%{_libdir}/coq/*
9019ffc7
JR
138%{_mandir}/man1/coq_makefile.1*
139%{_mandir}/man1/coq-tex.1*
680764bb 140%{_mandir}/man1/coqc.1*
2dc46485
JR
141%{_mandir}/man1/coqchk.1*
142%{_mandir}/man1/coqdep.1*
143%{_mandir}/man1/coqdoc.1*
2dc46485 144%{_mandir}/man1/coqide.1*
9019ffc7 145%{_mandir}/man1/coqmktop.1*
680764bb
JR
146%{_mandir}/man1/coqtop.1*
147%{_mandir}/man1/coqtop.byte.1*
148%{_mandir}/man1/coqtop.opt.1*
1c74cbbc 149%{_mandir}/man1/coqwc.1*
2dc46485 150%{_mandir}/man1/gallina.1*
8bee228d
JR
151%{_desktopdir}/coqide.desktop
152%{_pixmapsdir}/coqide.xpm
9019ffc7
JR
153
154%files emacs
155%defattr(644,root,root,755)
156%{_datadir}/emacs/site-lisp/coq.el
157%{_datadir}/emacs/site-lisp/coq-db.el
158%{_datadir}/emacs/site-lisp/coq-font-lock.el
159%{_datadir}/emacs/site-lisp/coq-inferior.el
160%{_datadir}/emacs/site-lisp/coq-syntax.el
161
162%files latex
163%defattr(644,root,root,755)
164%{_datadir}/texmf/tex/latex/misc/coqdoc.sty
This page took 0.056274 seconds and 4 git commands to generate.