]> git.pld-linux.org Git - packages/cooledit.git/blobdiff - cooledit.spec
- /bin/sh instead of /bin/bash in script created in %%post
[packages/cooledit.git] / cooledit.spec
index ce5714b4afba9c03e4976ef924b543cac66db930..40638c2e805c12e6c65abcdd59bf3537c718c5b6 100644 (file)
@@ -5,16 +5,14 @@ Version:      3.14.2
 Release:       1
 License:       GPL
 Group:         Applications/Editors
-Group(pt):     X11/Aplicações/Editores
-Group(pl):     Aplikacje/Edytory
 Source0:       ftp://sunsite.unc.edu/pub/Linux/apps/editors/X/%{name}-%{version}.tar.gz
-Patch0:                cooledit-install.patch
+Patch0:                %{name}-install.patch
 Icon:          cooledit.gif
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 BuildRequires: autoconf
 BuildRequires: automake
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%description 
+%description
 Full-featured X Window text editor; multiple edit windows; 3D
 Motif-ish look and feel; shift-arrow and mouse text highlighting;
 column text highlighting and manipulation; key for key undo; macro
@@ -38,14 +36,15 @@ plik
 
 %prep
 %setup -q -T -c -D
-(cd ..
+cd ..
 gzip -dc %{SOURCE0} | tar -x --no-same-permission -f -
-chmod -R +X %{name}-%{version})
+chmod -R +X %{name}-%{version}
+cd %{name}-%{version}
 %patch -p1
 
 %build
-aclocal
-autoconf
+%{__aclocal}
+%{__autoconf}
 %configure
 %{__make}
 
@@ -53,17 +52,16 @@ autoconf
 rm -rf $RPM_BUILD_ROOT
 %{__make} install DESTDIR=$RPM_BUILD_ROOT
 
-gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/* \
-       ABOUT-NLS AUTHORS BUGS FAQ INTERNATIONAL \
-       MAILING_LIST NEWS PROGRAMMING README TODO VERSION ChangeLog \
-       cooledit.lsm coolicon.lsm coolman.lsm
-
 %find_lang %{name}
 
+%clean
+rm -rf $RPM_BUILD_ROOT
+
 %post
- check if the command is already present:      
+umask 022
+# check if the command is already present:
 if test -z "`grep coolicon %{_libdir}/X11/xinit/Xclients`" ; then
- estimate the speed of this machine:   
+# estimate the speed of this machine:
     BOGOMIPS=`cat /proc/cpuinfo | grep bogomips | sed -e 's/^[^0-9]*//' -e 's/\..*$//'`
     BOGOMIPS="$BOGOMIPS"
     if test -z "$BOGOMIPS" ; then
@@ -72,7 +70,7 @@ if test -z "`grep coolicon %{_libdir}/X11/xinit/Xclients`" ; then
     if test "$BOGOMIPS" -gt "500" ; then
        BOGOMIPS=500
     fi
- add use of shape extension if this is a fast machine: 
+# add use of shape extension if this is a fast machine:
     if test "$BOGOMIPS" -gt "80" ; then
        COOLICON_OPTIONS="-s -X $BOGOMIPS"
     else
@@ -80,41 +78,32 @@ if test -z "`grep coolicon %{_libdir}/X11/xinit/Xclients`" ; then
     fi
 
     cat > temp.Xclients <<EOF
-#!/bin/bash
+#!/bin/sh
 
- coolicon needs an existing mail file, even if it is empty
-MAILFILE=/var/spool/mail/\$LOGNAME
+# coolicon needs an existing mail file, even if it is empty
+MAILFILE=/var/mail/\$LOGNAME
 if test -f \$MAILFILE ; then
-    cat /dev/null
-else
-    cat /dev/null > \$MAILFILE
-    chmod 0600 \$MAILFILE
-fi
 coolicon $COOLICON_OPTIONS -M \$MAILFILE 2>&1 | coolmessage &
-
+fi
 EOF
     cat temp.Xclients %{_libdir}/X11/xinit/Xclients > temp2.Xclients
-    cp temp2.Xclients %{_libdir}/X11/xinit/Xclients
+    cp -f temp2.Xclients %{_libdir}/X11/xinit/Xclients
     chmod 0755 %{_libdir}/X11/xinit/Xclients
-    rm temp.Xclients temp2.Xclients
+    rm -f temp.Xclients temp2.Xclients
 fi
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc {ABOUT-NLS,AUTHORS,BUGS,FAQ,INTERNATIONAL}.gz
-%doc {MAILING_LIST,NEWS,PROGRAMMING,README,TODO,VERSION,ChangeLog}.gz
-%doc {cooledit.lsm,coolicon.lsm,coolman.lsm}.gz
-
-%attr(755,root,root) %{_libdir}/libCw.so*
+%doc AUTHORS BUGS FAQ INTERNATIONAL
+%doc MAILING_LIST NEWS PROGRAMMING README TODO VERSION ChangeLog
+%doc cooledit.lsm coolicon.lsm coolman.lsm
 %attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_libdir}/libCw.so*
 
 %{_libdir}/libCw.la
 %{_libdir}/libCw.a
 
-%{_libdir}/coolicon/*
-%{_libdir}/cooledit/*
+%{_libdir}/coolicon
+%{_libdir}/cooledit
 
 %{_mandir}/man1/*
This page took 0.113584 seconds and 4 git commands to generate.