]> git.pld-linux.org Git - packages/cooledit.git/blobdiff - cooledit.spec
- tabs in preamble
[packages/cooledit.git] / cooledit.spec
index c35d375d827771c6069180ff9188f5073447e7e8..01588e3c62f95e4b9b48153e195a6e8f77b42849 100644 (file)
@@ -1,5 +1,5 @@
 Summary:       Full featured multiple window programmer's text editor
-Summary(pl):   Funkcjonalny edytor tekstu dla programistów
+Summary(pl.UTF-8):     Funkcjonalny edytor tekstu dla programistów
 Name:          cooledit
 Version:       3.17.7
 Release:       1
@@ -8,9 +8,11 @@ Group:         Applications/Editors
 Source0:       http://cooledit.sourceforge.net/%{name}-%{version}.tar.gz
 # Source0-md5: 06e16994ebc2108e04dc7c6bd29981de
 URL:           http://cooledit.sourceforge.net/
-Icon:          cooledit.gif
-BuildRequires: autoconf
-BuildRequires: automake
+BuildRequires: XFree86-devel
+Requires(post):        /sbin/ldconfig
+Requires(post):        coreutils
+Requires(post):        grep
+Requires(post):        sed
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -23,88 +25,85 @@ commands with seamless shell interface; redefine keys with an easy
 interactive key learner; syntax highlighting for various file types;
 full support for proportional fonts.
 
-%description -l pl
-Cooledit to pe³nowarto¶ciowy edytor tekstowy dla X Window. Jego
-najistotniejsze cechy to: obs³uga wielu okien edycyjnych, zaznaczanie
-tekstu za pomoc± shift-strza³ek i myszki, motifowy wygl±d, kolumnowe
-zaznaczanie i modyfikacja tekstu, wielopoziomowe undo, nagrywanie
-makr, wyszukaj i zamieñ za pomoc± wyra¿eñ regularnych, menu,
-przeci±gnij i upu¶æ, interaktywna przegl±darka stron podrêcznika
-systemowego (man), uruchamianie make oraz innych komend za pomoc±
-zintegrowanego interfejsu pow³oki, redefiniowanie klawiszy za pomoc±
-interaktywnego narzêdzia, pod¶wietlanie sk³adni rozmaitych typów
-plików, pe³na obs³uga fontów proporcjonalnych.
+%description -l pl.UTF-8
+Cooledit to pełnowartościowy edytor tekstowy dla systemu X Window.
+Jego najistotniejsze cechy to: obsługa wielu okien edycyjnych,
+zaznaczanie tekstu za pomocą strzałek z shiftem i myszki, motifowy
+wygląd, kolumnowe zaznaczanie i modyfikacja tekstu, wielopoziomowe
+undo, nagrywanie makr, wyszukiwanie i zamiana za pomocą wyrażeń
+regularnych, menu, "przeciągnij i upuść", interaktywna przeglądarka
+stron podręcznika systemowego (man), uruchamianie make oraz innych
+poleceń za pomocą zintegrowanego interfejsu powłoki, redefiniowanie
+klawiszy za pomocą interaktywnego narzędzia, podświetlanie składni
+rozmaitych typów plików, pełna obsługa fontów proporcjonalnych.
 
 %prep
-%setup -q -T -c -D
-cd ..
-gzip -dc %{SOURCE0} | tar -x --no-same-permission -f -
-chmod -R +X %{name}-%{version}
-cd %{name}-%{version}
+%setup -q
 
 %build
-%{__aclocal}
-%{__autoconf}
-%configure
+%configure \
+       --disable-static
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# no -devel package, so useless
+rm -f $RPM_BUILD_ROOT%{_libdir}/libCw.{so,la}
+
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
+/sbin/ldconfig
 umask 022
 # check if the command is already present:
 if test -z "`grep coolicon %{_libdir}/X11/xinit/Xclients`" ; then
 # estimate the speed of this machine:
-    BOGOMIPS=`cat /proc/cpuinfo | grep bogomips | sed -e 's/^[^0-9]*//' -e 's/\..*$//'`
-    BOGOMIPS="$BOGOMIPS"
-    if test -z "$BOGOMIPS" ; then
-       BOGOMIPS=50
-    fi
-    if test "$BOGOMIPS" -gt "500" ; then
-       BOGOMIPS=500
-    fi
+       BOGOMIPS=`cat /proc/cpuinfo | grep bogomips | sed -e 's/^[^0-9]*//' -e 's/\..*$//'`
+       BOGOMIPS="$BOGOMIPS"
+       if test -z "$BOGOMIPS" ; then
+               BOGOMIPS=50
+       fi
+       if test "$BOGOMIPS" -gt "500" ; then
+               BOGOMIPS=500
+       fi
 # add use of shape extension if this is a fast machine:
-    if test "$BOGOMIPS" -gt "80" ; then
-       COOLICON_OPTIONS="-s -X $BOGOMIPS"
-    else
-       COOLICON_OPTIONS="-X $BOGOMIPS"
-    fi
+       if test "$BOGOMIPS" -gt "80" ; then
+               COOLICON_OPTIONS="-s -X $BOGOMIPS"
+       else
+               COOLICON_OPTIONS="-X $BOGOMIPS"
+       fi
 
-    cat > temp.Xclients <<EOF
+       cat > temp.Xclients <<EOF
 #!/bin/sh
 
 # coolicon needs an existing mail file, even if it is empty
 MAILFILE=/var/mail/\$LOGNAME
 if test -f \$MAILFILE ; then
-coolicon $COOLICON_OPTIONS -M \$MAILFILE 2>&1 | coolmessage &
+       coolicon $COOLICON_OPTIONS -M \$MAILFILE 2>&1 | coolmessage &
 fi
 EOF
-    cat temp.Xclients %{_libdir}/X11/xinit/Xclients > temp2.Xclients
-    cp -f temp2.Xclients %{_libdir}/X11/xinit/Xclients
-    chmod 0755 %{_libdir}/X11/xinit/Xclients
-    rm -f temp.Xclients temp2.Xclients
+       cat temp.Xclients %{_libdir}/X11/xinit/Xclients > temp2.Xclients
+       cp -f temp2.Xclients %{_libdir}/X11/xinit/Xclients
+       chmod 0755 %{_libdir}/X11/xinit/Xclients
+       rm -f temp.Xclients temp2.Xclients
 fi
 
+%postun        -p /sbin/ldconfig
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS BUGS FAQ INTERNATIONAL
 %doc MAILING_LIST NEWS PROGRAMMING README TODO VERSION ChangeLog
 %doc cooledit.lsm coolicon.lsm coolman.lsm
 %attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/libCw.so*
-
-%{_libdir}/libCw.la
-%{_libdir}/libCw.a
-
-%{_libdir}/coolicon
-%{_libdir}/cooledit
-
+%attr(755,root,root) %{_libdir}/libCw.so.*.*.*
+%{_datadir}/coolicon
+%{_datadir}/cooledit
 %{_mandir}/man1/*
This page took 0.201545 seconds and 4 git commands to generate.