]> git.pld-linux.org Git - packages/cook.git/blob - cook.spec
a21db76df301b2b942d4095fec5de204a4b21b6f
[packages/cook.git] / cook.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make test"
4 #
5 Summary:        A file construction tool
6 Summary(pl):    Narzêdzie do konstrukcji plików
7 Name:           cook
8 Version:        2.25
9 Release:        1
10 License:        GPL
11 Group:          Development/Building
12 Source0:        http://www.canb.auug.org.au/~millerp/cook/%{name}-%{version}.tar.gz
13 # Source0-md5:  fd116da31c59c04abe41519fc131b504
14 URL:            http://www.canb.auug.org.au/~millerp/cook/
15 BuildRequires:  bison
16 BuildRequires:  gettext-devel
17 BuildRequires:  groff
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Cook is a tool for constructing files. It is given a set of files to
22 create, and recipes of how to create them. In any non-trivial program
23 there will be prerequisites to performing the actions necessary to
24 creating any file, such as include files. The cook program provides a
25 mechanism to define these.
26
27 When a program is being developed or maintained, the programmer will
28 typically change one file of several which comprise the program. Cook
29 examines the last-modified times of the files to see when the
30 prerequisites of a file have changed, implying that the file needs to
31 be recreated as it is logically out of date.
32
33 Cook also provides a facility for implicit recipes, allowing users to
34 specify how to form a file with a given suffix from a file with a
35 different suffix. For example, to create filename.o from filename.c
36
37 - Cook is a replacement for the traditional make(1) tool. However, it
38   is necessary to convert makefiles into cookbooks using the make2cook
39   utility included in the distribution.
40
41 - Cook has a simple but powerful string-based description language
42   with many built-in functions. This allows sophisticated filename
43   specification and manipulation without loss of readability or
44   performance.
45
46 - Cook is able to use fingerprints to supplement file modification
47   times. This allows build optimization without contorted rules.
48
49 - Cook is able to build your project with multiple parallel threads,
50   with support for rules which must be single threaded. It is possible
51   to distribute parallel builds over your LAN, allowing you to turn your
52   network into a virtual parallel build engine.
53
54 If you are putting together a source-code distribution and planning to
55 write a makefile, consider writing a cookbook instead. Although Cook
56 takes a day or two to learn, it is much more powerful and a bit more
57 intuitave than the traditional make(1) tool. And Cook doesn't
58 interpret tab differently to 8 space characters!
59
60 %description -l pl
61 Cook jest narzêdziem do tworzenia plików. Podaje mu siê listê plików do
62 utworzenia oraz regu³y wyja¶niaj±ce jak je utworzyæ. Ka¿dy nietrywialny
63 program wymaga podjêcia pewnych dzia³añ koniecznych do utworzenia
64 ró¿nych plików, jak np. plików nag³ówkowych. Cook udostêpnia mechanizmy
65 pozwalaj±cy je zdefiniowaæ.
66
67 Tworz±c i rozwijaj±c program zazwyczaj modyfikuje siê pliki, z których
68 siê sk³ada. Cook bada daty ostatniej modyfikacji sprawdzaj±c, czy
69 zmieni³y siê zale¿no¶ci; je¶li tak, pliki powinny zostaæ zaktualizowane.
70
71 Cook umo¿liwia równie¿ definiowanie niejawnych regu³, pozwalaj±c
72 u¿ytkownikom wyszczególniæ metody tworzenia plików o podanym
73 rozszerzeniu z pliku o innym rozszerzeniu (np. jak utworzyæ
74 plik.o z plik.c).
75
76 - Cook jest zamiennikiem tradycyjnego narzêdzia make(1). Jednak przed
77 u¿yciem plików Makefile z cookiem, nale¿y wcze¶niej przekszta³ciæ
78 je do formatu rozumianego przez cooka przy u¿yciu narzêdzia make2cook
79 dostarczanego wraz z dystrybucj±.
80
81 - Cook posiada prosty lecz potê¿ny jêzyk opisowy, z wieloma wbudowanymi
82   funkcjami, dziêki czemu mo¿na podawaæ i manipulowaæ skomplikowanymi
83   specyfikacjami nazw plików bez utraty czytelno¶ci i wydajno¶ci.
84
85 - Oprócz daty ostatniej modyfikacji, cook pozwala korzystaæ z fingerprintów.
86   Dziêki temu mo¿na zoptymalizowaæ proces budowania nie uciekaj±c siê
87   do nienaturalnych regu³.
88
89 - Cook potrafi przeprowadziæ proces budowania w wielu równoleg³ych
90   w±tkach, obs³uguj±c prawid³owo regu³y jednow±tkowe. Mo¿na
91   przeprowadziæ rozproszone budowanie w sieci LAN, przekszta³caj±c
92   lokaln± sieæ w wirtualn± maszynê do budowania równoleg³ego.
93
94 Je¶li tworzysz program od zera i planujesz napisaæ Makefile,
95 przemy¶l mo¿liwo¶æ wykorzystania zamiast niego pliku cookbook.
96 Choæ na naukê Cooka trzeba po¶wiêciæ dzieñ lub dwa, jest to
97 narzêdzie o wiele potê¿niejsze i znacznie bardziej intuicyjne ni¿
98 tradycyjne make(1). Poza tym Cook nie traktuje inaczej TAB-a i
99 o¶miu spacji!
100
101 %package doc-ps
102 Summary:        Cook documentation, PostScript format
103 Summary(pl):    Dokumentacja do cooka w formacie PostScript
104 Group:          Development/Building
105
106 %description doc-ps
107 Cook documentation in PostScript format.
108
109 %description doc-ps -l pl
110 Dokumentacja do cooka w formacie PostScript.
111
112 %prep
113 %setup -q
114
115 %build
116 %configure \
117         NLSDIR=%{_datadir}/locale
118 %{__make}
119
120 %{?with_tests:%{__make} sure}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 install -d $RPM_BUILD_ROOT%{_bindir}
125 install -d $RPM_BUILD_ROOT%{_libdir}/cook/en/LC_MESSAGES
126 install -d $RPM_BUILD_ROOT%{_datadir}/locale
127 install -d $RPM_BUILD_ROOT%{_datadir}/cook/en
128 ln -s $RPM_BUILD_ROOT%{_mandir}/man1 $RPM_BUILD_ROOT%{_datadir}/cook/en/man1
129 install -d $RPM_BUILD_ROOT%{_mandir}/man1
130 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
131
132 %{__make} install \
133         RPM_BUILD_ROOT=$RPM_BUILD_ROOT
134 mv $RPM_BUILD_ROOT%{_libdir}/cook/en $RPM_BUILD_ROOT%{_datadir}/locale/
135 rm -r $RPM_BUILD_ROOT%{_datadir}/cook/en
136 install -D cook.gif $RPM_BUILD_ROOT%{_pixmapsdir}/cook.gif
137
138 %find_lang %{name} --with-gnome --all-name
139
140 %files -f %{name}.lang
141 %defattr(644,root,root,755)
142 %doc README lib/en/*.txt
143 %attr(0755,root,root) %{_bindir}/*
144 %{_datadir}/cook
145 %{_mandir}/man*/*
146 %{_pixmapsdir}/cook.gif
147
148 %files doc-ps
149 %defattr(644,root,root,755)
150 %doc lib/en/*.ps
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
This page took 0.065021 seconds and 2 git commands to generate.