]> git.pld-linux.org Git - packages/conkeror.git/blob - conkeror.spec
- new
[packages/conkeror.git] / conkeror.spec
1 Summary:        Conkeror Web Browser Conquers Small Screens
2 Name:           conkeror
3 Version:        0.9
4 Release:        0.2
5 License:        MPL v1.1 or GPL v2+ or LGPL v2.1+
6 Group:          X11/Applications
7 # http://repo.or.cz/w/conkeror.git?a=snapshot;h=master;sf=tgz
8 Source0:        %{name}.tgz
9 # Source0-md5:  9e00720680f9cbdd0a98bbd20b9a8d95
10 Requires:       xulrunner >= 1.9
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %define         _appdir %{_datadir}/%{name}
14
15 %description
16 Conkeror is a keyboard-oriented, highly-customizable,
17 highly-extensible web browser based on Mozilla XULRunner, written
18 mainly in JavaScript, and inspired by exceptional software such as
19 Emacs and vi.
20
21 Conkeror features a sophisticated keyboard system, allowing users to
22 run commands and interact with content in powerful and novel ways. It
23 is self-documenting, featuring a powerful interactive help system.
24
25 %prep
26 %setup -q -n %{name}
27
28 %build
29 %{__make} \
30         CC="%{__cc}" \
31         CFLAGS="%{rpmcflags}"
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35 install -d $RPM_BUILD_ROOT{%{_bindir},%{_appdir},%{_desktopdir}}
36
37 install conkeror-spawn-helper $RPM_BUILD_ROOT%{_bindir}
38 cp -a branding chrome components content contrib defaults  \
39    locale modules search-engines help style         \
40 $RPM_BUILD_ROOT%{_appdir}
41
42 # Add generated Build ID and PLD Linux to version output
43 sed -e 's/BuildID=git/BuildID=${BUILDID}/;s/^Version=\(.*\)$$/Version=\1 (PLD Linux)/' application.ini \
44 > $RPM_BUILD_ROOT%{_appdir}/application.ini
45 # Use PLD Linux version for M-x version output
46 sed -e 's/\$$CONKEROR_VERSION\$$/${UPSTREAM_VERSION} (Debian-${DEBIAN_VERSION})/' components/application.js \
47 > $RPM_BUILD_ROOT%{_appdir}/components/application.js
48 cat <<'EOF' > $RPM_BUILD_ROOT%{_bindir}/%{name}
49 #!/bin/sh
50 exec %{_bindir}/xulrunner %{_appdir}/application.ini
51 EOF
52 cp -a debian/conkeror.desktop $RPM_BUILD_ROOT%{_desktopdir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %attr(755,root,root) %{_bindir}/%{name}
60 %attr(755,root,root) %{_bindir}/conkeror-spawn-helper
61 %dir %{_appdir}
62 %{_appdir}/application.ini
63 %{_appdir}/branding
64 %{_appdir}/chrome
65 %{_appdir}/components
66 %{_appdir}/content
67 %{_appdir}/contrib
68 %{_appdir}/defaults
69 %{_appdir}/help
70 %{_appdir}/modules
71 %{_appdir}/search-engines
72 %{_appdir}/style
73 %{_desktopdir}/conkeror.desktop
74
75 %dir %{_appdir}/locale
76 %{_appdir}/locale/en-US
77 %lang(sv) %{_appdir}/locale/sv-SE
This page took 0.065118 seconds and 3 git commands to generate.