]> git.pld-linux.org Git - packages/composer.git/commitdiff
fix output of composer --version auto/th/composer-1.0.0-15.alpha11
authorElan Ruusamäe <glen@delfi.ee>
Thu, 26 Nov 2015 11:32:41 +0000 (13:32 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 26 Nov 2015 11:32:41 +0000 (13:32 +0200)
composer.spec
version.patch [new file with mode: 0644]

index 94f74aa5244ead79ad41d6488518f97bc62b4ecb..4b1fe204ee1e81be09162ebb2167f5a75a11b798 100644 (file)
@@ -1,7 +1,7 @@
 # NOTE
 # - release tarballs: http://getcomposer.org/download/
 
-%define                rel             14
+%define                rel             15
 #define                githash 5744981
 # $ git rev-list 1.0.0-alpha11..%{githash} --count
 #define                commits 216
@@ -23,6 +23,7 @@ Source3:      autoload.php
 Patch0:                autoload.patch
 Patch1:                update-memory-limit.patch
 Patch2:                svn-ignore-externals.patch
+Patch3:                version.patch
 URL:           http://www.getcomposer.org/
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
 BuildRequires: rpmbuild(macros) >= 1.673
@@ -81,6 +82,7 @@ mv composer-*/* .
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 mv composer.lock{,.disabled}
 # NOTE: do not use %{__php} macro here, need unversioned php binary
diff --git a/version.patch b/version.patch
new file mode 100644 (file)
index 0000000..69ffb1e
--- /dev/null
@@ -0,0 +1,19 @@
+fix output of composer --version
+
+before:
+Composer version @package_branch_alias_version@ (1.0.0-alpha11) 2015-11-14 16:21:07
+
+after:
+Composer version 1.0.0-alpha11 2015-11-14 16:21:07
+
+--- composer-1.0.0-14.alpha11/src/Composer/Composer.php~       2015-11-14 18:21:07.000000000 +0200
++++ composer-1.0.0-14.alpha11/src/Composer/Composer.php        2015-11-26 13:29:12.626795442 +0200
+@@ -29,7 +29,7 @@
+ class Composer
+ {
+     const VERSION = '1.0.0-alpha11';
+-    const BRANCH_ALIAS_VERSION = '@package_branch_alias_version@';
++    const BRANCH_ALIAS_VERSION = '';
+     const RELEASE_DATE = '2015-11-14 16:21:07';
+     /**
This page took 0.057376 seconds and 4 git commands to generate.