]> git.pld-linux.org Git - packages/composer.git/commitdiff
ignore svn externals when checking out vendors
authorElan Ruusamäe <glen@delfi.ee>
Thu, 10 Sep 2015 10:56:51 +0000 (13:56 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 10 Sep 2015 10:57:18 +0000 (13:57 +0300)
https://github.com/composer/composer/issues/4283

composer.spec
svn-ignore-externals.patch [new file with mode: 0644]

index e83ee7d447dbe70d2817eeb09cab1baae0ae16bf..f1df44521412e3651b5b58ca09d8f6ddcb6f2d72 100644 (file)
@@ -4,7 +4,7 @@
 # Conditional build:
 %bcond_with    bootstrap               # build boostrap
 
-%define                rel             13
+%define                rel             14
 #define                githash 5744981
 # $ git rev-list 1.0.0-alpha10..%{githash} --count
 #define                commits 216
@@ -30,6 +30,7 @@ Patch0:               nogit.patch
 Patch1:                no-vendors.patch
 Patch2:                autoload-config.patch
 Patch3:                update-memory-limit.patch
+Patch4:                svn-ignore-externals.patch
 URL:           http://www.getcomposer.org/
 BuildRequires: %{php_name}-cli
 BuildRequires: %{php_name}-ctype
@@ -104,6 +105,7 @@ mv composer-*/* .
 %patch0 -p1
 %{!?with_bootstrap:%patch1 -p1}
 %patch3 -p1
+%patch4 -p1
 
 mv composer.lock{,.disabled}
 # NOTE: do not use %{__php} macro here, need unversioned php binary
diff --git a/svn-ignore-externals.patch b/svn-ignore-externals.patch
new file mode 100644 (file)
index 0000000..726be5d
--- /dev/null
@@ -0,0 +1,11 @@
+--- composer-1.0.0-13.alpha10/src/Composer/Downloader/SvnDownloader.php~       2015-04-15 00:18:51.000000000 +0300
++++ composer-1.0.0-13.alpha10/src/Composer/Downloader/SvnDownloader.php        2015-09-02 21:37:14.936187207 +0300
+@@ -156,7 +156,7 @@
+             $fromRevision = preg_replace('{.*@(\d+)$}', '$1', $fromReference);
+             $toRevision = preg_replace('{.*@(\d+)$}', '$1', $toReference);
+-            $command = sprintf('svn log -r%s:%s --incremental', $fromRevision, $toRevision);
++            $command = sprintf('svn log -r%s:%s --incremental --ignore-externals', $fromRevision, $toRevision);
+             if (0 !== $this->process->execute($command, $output, $path)) {
+                 throw new \RuntimeException(
This page took 0.111762 seconds and 4 git commands to generate.