]> git.pld-linux.org Git - packages/composer.git/commitdiff
up to 1.0.0-alpha9-216-g5744981 auto/th/composer-1.0.0-11.alpha9.216.g5744981
authorElan Ruusamäe <glen@delfi.ee>
Tue, 17 Feb 2015 23:22:59 +0000 (01:22 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 17 Feb 2015 23:26:06 +0000 (01:26 +0200)
1.0.0-alpha9 fails to parse deps:
Could not load package socalnick/scn-social-auth in http://packagist.org:
[UnexpectedValueException] Could not parse version constraint >=1.2.2 <2.0.0:
Invalid version string "1.2.2 <2.0.0"

composer.spec
no-vendors.patch
nogit.patch

index 07394ac3e37cbb46da31b1c5a14a978fc332c6a8..6639fef0ac23bb78596b1ff083f095a478d17cec 100644 (file)
@@ -4,20 +4,22 @@
 # Conditional build:
 %bcond_with    bootstrap               # build boostrap
 
-%define                rel             10
-#define                githash b23a3cd
+%define                rel             11
+# $ git rev-list 1.0.0-alpha9..%{githash} --count
+%define                commits 216
+%define                githash 5744981
 %define                subver  alpha9
 %define                php_min_version 5.3.4
 %include       /usr/lib/rpm/macros.php
 Summary:       Dependency Manager for PHP
 Name:          composer
 Version:       1.0.0
-Release:       %{rel}.%{subver}
+Release:       %{rel}.%{subver}.%{commits}.g%{githash}
 License:       MIT
 Group:         Development/Languages/PHP
-#Source0:       https://github.com/composer/composer/archive/%{githash}/%{name}-%{version}-%{githash}.tar.gz
-Source0:       https://github.com/composer/composer/archive/%{version}-%{subver}/%{name}-%{version}-%{subver}.tar.gz
-# Source0-md5: f5d0fb132995263ee2783f9e9521acbc
+Source0:       https://github.com/composer/composer/archive/%{githash}/%{name}-%{version}-%{subver}-%{commits}-g%{githash}.tar.gz
+# Source0-md5: d3152cbae030fedb85f5d1ac52dddd4f
+#Source0:      https://github.com/composer/composer/archive/%{version}-%{subver}/%{name}-%{version}-%{subver}.tar.gz
 %if %{with bootstrap}
 Source1:       http://getcomposer.org/download/%{version}-alpha8/%{name}.phar
 # Source1-md5: df1001975035f07d09307bf1f1e62584
index 0f38469164685706a410d1d817dde36498f7fc1f..3459cb9d95a3fb95ef94f18bfed83cb3660e8f36 100644 (file)
  
          $this->addFile($phar, new \SplFileInfo(__DIR__.'/../../vendor/autoload.php'));
          $this->addFile($phar, new \SplFileInfo(__DIR__.'/../../vendor/composer/autoload_namespaces.php'));
---- composer-1.0.0-alpha9/composer.json~       2014-12-07 19:15:20.000000000 +0200
-+++ composer-1.0.0-alpha9/composer.json        2014-12-12 23:37:17.350111453 +0200
+--- composer-1.0.x-5744981/composer.json~      2015-02-17 22:23:05.000000000 +0200
++++ composer-1.0.x-5744981/composer.json       2015-02-18 00:36:27.256517738 +0200
 @@ -22,12 +22,7 @@
          "issues": "https://github.com/composer/composer/issues"
      },
      "require": {
 -        "php": ">=5.3.2",
--        "justinrainbow/json-schema": "~1.1",
+-        "justinrainbow/json-schema": "~1.3",
 -        "seld/jsonlint": "~1.0",
 -        "symfony/console": "~2.3",
 -        "symfony/finder": "~2.2",
index 9c9abe118961533a48919f013ff01ff43c782ce4..84ca65060f4c5a69fa005dd7888f83e294f52d69 100644 (file)
@@ -1,5 +1,5 @@
---- composer-1.0.x-b23a3cd/src/Composer/Compiler.php~  2014-11-28 15:47:34.000000000 +0200
-+++ composer-1.0.x-b23a3cd/src/Composer/Compiler.php   2014-11-28 15:53:21.829773210 +0200
+--- composer-1.0.x-5744981/src/Composer/Compiler.php~  2015-02-18 00:33:55.000000000 +0200
++++ composer-1.0.x-5744981/src/Composer/Compiler.php   2015-02-18 00:34:38.952650516 +0200
 @@ -40,13 +40,13 @@
              unlink($pharFile);
          }
@@ -20,7 +20,7 @@
          $date->setTimezone(new \DateTimeZone('UTC'));
          $this->versionDate = $date->format('Y-m-d H:i:s');
  
--        $process = new Process('git describe --tags HEAD');
+-        $process = new Process('git describe --tags --exact-match HEAD');
 +        $process = new Process('echo $PACKAGE_VERSION; exit $DEV_VERSION');
          if ($process->run() == 0) {
              $this->version = trim($process->getOutput());
This page took 0.165646 seconds and 4 git commands to generate.