]> git.pld-linux.org Git - packages/composer.git/commitdiff
update to 1.0.0-alpha11
authorElan Ruusamäe <glen@delfi.ee>
Wed, 25 Nov 2015 16:30:54 +0000 (18:30 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 25 Nov 2015 16:30:54 +0000 (18:30 +0200)
autoload-config.patch
composer.spec
no-vendors.patch
update-memory-limit.patch

index 9e93e1818d60041bf01e1a3212c1fe1b0ebe138d..c893bff0f324402e7f0858fea50daa1b48382cfb 100644 (file)
@@ -1,6 +1,6 @@
---- composer-1.0.0-0.alpha8.3.ac497fe/vendor/composer/autoload_namespaces.php~ 2014-06-20 16:57:55.000000000 +0300
-+++ composer-1.0.0-0.alpha8.3.ac497fe/vendor/composer/autoload_namespaces.php  2014-06-20 16:58:38.314091739 +0300
-@@ -4,8 +4,15 @@
+--- composer-1.0.0-14.alpha11/vendor/composer/autoload_namespaces.php~ 2015-11-25 18:29:26.000000000 +0200
++++ composer-1.0.0-14.alpha11/vendor/composer/autoload_namespaces.php  2015-11-25 18:29:59.220529712 +0200
+@@ -4,6 +4,13 @@
  
  $vendorDir = dirname(dirname(__FILE__));
  $baseDir = dirname($vendorDir);
@@ -13,6 +13,4 @@
 +    'Symfony\\Component\\Console\\' => array($pearDir),
 +    'Seld\\JsonLint' => array($phpDir),
 +    'JsonSchema' => array($phpDir),
-     'Composer\\Test' => array($baseDir . '/tests'),
-     'Composer' => array($baseDir . '/src'),
  );
index f1df44521412e3651b5b58ca09d8f6ddcb6f2d72..a560a267b42ff3a9cf004df16f8edd5c4261308a 100644 (file)
@@ -8,7 +8,7 @@
 #define                githash 5744981
 # $ git rev-list 1.0.0-alpha10..%{githash} --count
 #define                commits 216
-%define                subver  alpha10
+%define                subver  alpha11
 %define                php_min_version 5.3.4
 %include       /usr/lib/rpm/macros.php
 Summary:       Dependency Manager for PHP
@@ -19,7 +19,7 @@ License:      MIT
 Group:         Development/Languages/PHP
 #Source0:       https://github.com/composer/composer/archive/%{githash}/%{name}-%{version}-%{subver}-%{commits}-g%{githash}.tar.gz
 Source0:       https://github.com/composer/composer/archive/%{version}-%{subver}/%{name}-%{version}-%{subver}.tar.gz
-# Source0-md5: e821eec53cbb98871b4cccfc82a6bae7
+# Source0-md5: 5e4ff16cff75fae31285196c5f51a8f8
 %if %{with bootstrap}
 Source1:       http://getcomposer.org/download/%{version}-alpha8/%{name}.phar
 # Source1-md5: df1001975035f07d09307bf1f1e62584
index 62d140c895358a13225c324f2b5bf056f326f794..2118c89de8ef95347138e88b79b1d91e9bf4db2b 100644 (file)
@@ -1,10 +1,10 @@
---- composer-1.0.0-12.alpha10.216.g5744981/src/Composer/Compiler.php~  2015-08-12 17:36:25.000000000 +0300
-+++ composer-1.0.0-12.alpha10.216.g5744981/src/Composer/Compiler.php   2015-08-12 17:37:00.837855396 +0300
-@@ -96,24 +96,6 @@
+--- composer-1.0.0-14.alpha11/src/Composer/Compiler.php~       2015-11-25 17:43:47.000000000 +0200
++++ composer-1.0.0-14.alpha11/src/Composer/Compiler.php        2015-11-25 17:44:50.973366000 +0200
+@@ -104,28 +104,6 @@
          foreach ($finder as $file) {
              $this->addFile($phar, $file, false);
          }
--        $this->addFile($phar, new \SplFileInfo(__DIR__ . '/../../src/Composer/IO/hiddeninput.exe'), false);
+-        $this->addFile($phar, new \SplFileInfo(__DIR__ . '/../../vendor/seld/cli-prompt/res/hiddeninput.exe'), false);
 -
 -        $finder = new Finder();
 -        $finder->files()
 -            ->exclude('docs')
 -            ->in(__DIR__.'/../../vendor/symfony/')
 -            ->in(__DIR__.'/../../vendor/seld/jsonlint/')
+-            ->in(__DIR__.'/../../vendor/seld/cli-prompt/')
 -            ->in(__DIR__.'/../../vendor/justinrainbow/json-schema/')
+-            ->in(__DIR__.'/../../vendor/composer/spdx-licenses/')
+-            ->in(__DIR__.'/../../vendor/composer/semver/')
+-            ->sort($finderSort)
 -        ;
 -
 -        foreach ($finder as $file) {
  
          $this->addFile($phar, new \SplFileInfo(__DIR__.'/../../vendor/autoload.php'));
          $this->addFile($phar, new \SplFileInfo(__DIR__.'/../../vendor/composer/autoload_namespaces.php'));
---- composer-1.0.0-12.alpha10.216.g5744981/composer.json~      2015-04-15 00:18:51.000000000 +0300
-+++ composer-1.0.0-12.alpha10.216.g5744981/composer.json       2015-08-12 17:37:36.376332853 +0300
-@@ -22,12 +22,7 @@
+--- composer-1.0.0-14.alpha11/composer.json~   2015-11-14 18:21:07.000000000 +0200
++++ composer-1.0.0-14.alpha11/composer.json    2015-11-25 17:45:33.515574668 +0200
+@@ -22,17 +22,7 @@
          "issues": "https://github.com/composer/composer/issues"
      },
      "require": {
--        "php": ">=5.3.2",
--        "justinrainbow/json-schema": "~1.4",
--        "seld/jsonlint": "~1.0",
--        "symfony/console": "~2.5",
--        "symfony/finder": "~2.2",
--        "symfony/process": "~2.1"
-+        "php": ">=5.3.2"
+-        "php": "^5.3.2 || ^7.0",
+-        "justinrainbow/json-schema": "^1.4.4",
+-        "composer/spdx-licenses": "^1.0",
+-        "composer/semver": "^1.0",
+-        "seld/jsonlint": "^1.0",
+-        "symfony/console": "^2.5 || ^3.0",
+-        "symfony/finder": "^2.2 || ^3.0",
+-        "symfony/process": "^2.1 || ^3.0",
+-        "symfony/filesystem": "^2.5 || ^3.0",
+-        "seld/phar-utils": "^1.0",
+-        "seld/cli-prompt": "^1.0"
++        "php": "^5.3.2 || ^7.0"
      },
      "require-dev": {
-         "phpunit/phpunit": "~4.5"
+         "phpunit/phpunit": "^4.5 || ^5.0.5",
index b01bc858978c9921d17bcdb36d5c5ac0198a3a4a..5dbb29331306b3309a75d70f8c1598d1e9b1593d 100644 (file)
@@ -4,14 +4,14 @@ as the memory usage is unexpected, just disable it
 
 https://github.com/composer/composer/issues/1898
 
---- composer-1.0.0-0.alpha8.5.ac497fe/src/Composer/Command/UpdateCommand.php~  2014-06-10 17:13:12.000000000 +0300
-+++ composer-1.0.0-0.alpha8.5.ac497fe/src/Composer/Command/UpdateCommand.php   2014-08-05 04:55:27.855176641 +0300
-@@ -65,6 +65,8 @@
+--- composer-1.0.0-14.alpha11/src/Composer/Command/UpdateCommand.php~  2015-11-14 18:21:07.000000000 +0200
++++ composer-1.0.0-14.alpha11/src/Composer/Command/UpdateCommand.php   2015-11-25 17:46:18.524578082 +0200
+@@ -75,6 +75,8 @@
  
      protected function execute(InputInterface $input, OutputInterface $output)
      {
 +        ini_set('memory_limit', -1);
 +
+         $io = $this->getIO();
          if ($input->getOption('no-custom-installers')) {
-             $output->writeln('<warning>You are using the deprecated option "no-custom-installers". Use "no-plugins" instead.</warning>');
-             $input->setOption('no-plugins', true);
+             $io->writeError('<warning>You are using the deprecated option "no-custom-installers". Use "no-plugins" instead.</warning>');
This page took 0.140349 seconds and 4 git commands to generate.