]> git.pld-linux.org Git - packages/composer.git/blobdiff - composer.spec
- release 5 (by relup.sh)
[packages/composer.git] / composer.spec
index c20af71daa9c6d0a9e8ac1bce93cf9bb6a311fba..bf15303804abd47f92223d1514d7e0dfc3d5ef4c 100644 (file)
@@ -6,16 +6,18 @@
 
 %define                php_min_version 5.3.4
 %define                subver  alpha8
-%define                rel             1
+%define                githash ac497fe
+%define                rel             5
 %include       /usr/lib/rpm/macros.php
 Summary:       Dependency Manager for PHP
 Name:          composer
 Version:       1.0.0
-Release:       0.%{subver}.%{rel}
+Release:       0.%{subver}.%{rel}.%{githash}
 License:       MIT
 Group:         Development/Languages/PHP
-Source0:       https://github.com/composer/composer/archive/%{version}-%{subver}/%{name}-%{version}-%{subver}.tar.gz
-# Source0-md5: a304aecf48b8406730d572e204afd6db
+#Source0:      https://github.com/composer/composer/archive/%{version}-%{subver}/%{name}-%{version}-%{subver}.tar.gz
+Source0:       https://github.com/composer/composer/archive/%{githash}/%{name}-%{version}-%{subver}-%{githash}.tar.gz
+# Source0-md5: 124fe0335a9f61f1ab149d3f8e0616b4
 %if %{with bootstrap}
 Source1:       http://getcomposer.org/download/%{version}-%{subver}/%{name}.phar
 # Source1-md5: df1001975035f07d09307bf1f1e62584
@@ -26,15 +28,16 @@ Patch0:             nogit.patch
 Patch1:                no-vendors.patch
 Patch2:                autoload-config.patch
 URL:           http://www.getcomposer.org/
+BuildRequires: %{php_name}-ctype
+BuildRequires: %{php_name}-hash
+BuildRequires: %{php_name}-json
+BuildRequires: %{php_name}-openssl
+BuildRequires: %{php_name}-phar
+BuildRequires: %{php_name}-program
+BuildRequires: %{php_name}-zip
+BuildRequires: %{php_name}-zlib
 BuildRequires: /usr/bin/phar
 BuildRequires: /usr/bin/php
-BuildRequires: php(ctype)
-BuildRequires: php(hash)
-BuildRequires: php(json)
-BuildRequires: php(openssl)
-BuildRequires: php(phar)
-BuildRequires: php(zip)
-BuildRequires: php(zlib)
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
 BuildRequires: rpmbuild(macros) >= 1.673
 %if %{without bootstrap}
@@ -72,9 +75,10 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _appdir         %{_datadir}/%{name}
 
 %description
-Composer is a tool for dependency management in PHP. It allows you to
-declare the dependent libraries your project needs and it will install
-them in your project for you.
+Composer is a tool for dependency management in PHP.
+
+Composer helps you declare, manage and install dependencies of PHP
+projects, ensuring you have the right stack everywhere.
 
 %package -n bash-completion-%{name}
 Summary:       Bash completion for Composer
@@ -111,7 +115,7 @@ if [ ! -d vendor ]; then
        %{__patch} -p1 < %{PATCH2}
 fi
 
-COMPOSER_VERSION=%{version}%{?subver:-%{subver}} \
+COMPOSER_VERSION=%{version}%{?subver:-%{subver}}%{?githash:@%{githash}} \
 %{__php} -d phar.readonly=0 ./bin/compile
 
 # sanity check
This page took 0.088235 seconds and 4 git commands to generate.