]> git.pld-linux.org Git - packages/composer.git/blobdiff - composer.spec
up to 1.5.4 (2017-12-01)
[packages/composer.git] / composer.spec
index 90e543c094246ba0c1eeea895c84c0d217b99ab0..3324d98fb75096a721b567158aee26956e748fdf 100644 (file)
@@ -1,34 +1,34 @@
 #
 # Conditional build:
-%bcond_without tests           # build with tests
+%bcond_with    tests           # build with tests
 
 %define                php_min_version 5.3.4
 %include       /usr/lib/rpm/macros.php
 Summary:       Dependency Manager for PHP
 Name:          composer
-Version:       1.2.0
+Version:       1.5.4
 Release:       1
 License:       MIT
 Group:         Development/Languages/PHP
 Source0:       https://github.com/composer/composer/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 197f275abe0bfb42b21dba3c4c1c46c7
+# Source0-md5: a8e55e0033014a088329d7c20fad65bc
 Source2:       https://raw.githubusercontent.com/iArren/%{name}-bash-completion/86a8129/composer
 # Source2-md5: cdeebf0a0da1fd07d0fd886d0461642e
 Source3:       autoload.php
 Patch0:                autoload.patch
 Patch1:                update-memory-limit.patch
 Patch2:                svn-ignore-externals.patch
-URL:           http://www.getcomposer.org/
+URL:           https://getcomposer.org/
 BuildRequires: php-devel
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
 BuildRequires: rpmbuild(macros) >= 1.673
 %if %{with tests}
 # instead of filling duplicate deps for running tests,
 # update composer version that have neccessary runtime dependencies
-BuildRequires: composer >= 1.1.0
+BuildRequires: composer >= 1.4.0
 BuildRequires: git-core
 BuildRequires: phpab
-BuildRequires: phpunit
+BuildRequires: phpunit >= 4.8
 %endif
 Requires:      php(core) >= %{php_min_version}
 Requires:      php(ctype)
@@ -37,6 +37,7 @@ Requires:     php(filter)
 Requires:      php(hash)
 Requires:      php(json)
 Requires:      php(openssl)
+Requires:      php(pcntl)
 Requires:      php(pcre)
 Requires:      php(phar)
 Requires:      php(posix)
@@ -47,7 +48,7 @@ Requires:     php(zlib)
 Requires:      php-composer-ca-bundle >= 1.0.2
 Requires:      php-composer-semver >= 1.0.0
 Requires:      php-composer-spdx-licenses >= 1.0.0
-Requires:      php-justinrainbow-json-schema >= 1.6
+Requires:      php-justinrainbow-json-schema >= 3.0
 Requires:      php-psr-Log >= 1.0
 Requires:      php-seld-cli-prompt >= 1.0.0
 Requires:      php-seld-jsonlint >= 1.4
@@ -105,25 +106,6 @@ ln -s src/Composer/res
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
-# needs newer phpunit:
-# missing method PHPUnit_Framework_MockObject_Builder_InvocationMocker::willReturn()
-rm tests/Composer/Test/ApplicationTest.php
-rm tests/Composer/Test/EventDispatcher/EventDispatcherTest.php
-rm tests/Composer/Test/IO/ConsoleIOTest.php
-rm tests/Composer/Test/Package/Loader/RootPackageLoaderTest.php
-rm tests/Composer/Test/Package/RootAliasPackageTest.php
-rm tests/Composer/Test/Package/Version/VersionGuesserTest.php
-rm tests/Composer/Test/Repository/ComposerRepositoryTest.php
-rm tests/Composer/Test/Repository/Vcs/GitBitbucketDriverTest.php
-rm tests/Composer/Test/Util/GitHubTest.php
-rm tests/Composer/Test/Util/GitLabTest.php
-# method PHPUnit_Framework_MockObject_Builder_InvocationMocker::withConsecutive()
-rm tests/Composer/Test/Util/BitbucketTest.php
-# Call to undefined method Composer\Test\Repository\Vcs\GitLabDriverTest::prophesize()
-rm tests/Composer/Test/Repository/Vcs/GitLabDriverTest.php
-# Mocked method does not exist.
-rm tests/Composer/Test/Installer/LibraryInstallerTest.php
-
 %build
 %if %{with tests}
 phpab -n -o src/bootstrap.php -e '*/Fixtures/*' src/ tests/
This page took 0.085665 seconds and 4 git commands to generate.