]> git.pld-linux.org Git - packages/compiz.git/blobdiff - compiz.spec
- updated gettext BR
[packages/compiz.git] / compiz.spec
index ee2674a86c777fe938ee107e822256088cf848f5..d9cb8c7386663d038cfb5777ac7e77d8051e30cc 100644 (file)
@@ -2,33 +2,36 @@
 # Conditional build:
 %bcond_without gconf           # gconf plugin
 %bcond_without gtk             # gtk window decorator
-%bcond_without gnome           # gnome settings module
+%bcond_with    gnome           # gnome settings module
 %bcond_without metacity        # metacity theme support
 %bcond_with    kde             # kde-window-decorator and kconfig
 %bcond_without kde4            # kde4-window-decorator
-#
+
 Summary:       OpenGL window and compositing manager
 Summary(pl.UTF-8):     OpenGL-owy zarządca okien i składania
 Name:          compiz
 # note that even versions are STABLE
-Version:       0.8.4
-Release:       1
+Version:       0.8.6
+Release:       3
 License:       GPL or MIT
 Group:         X11/Applications
 Source0:       http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: 03fa78ce0c464f3a413b2a3b74f09559
+# Source0-md5: 1e284eade99ff310551d5919b6ba57c1
+Source1:       %{name}-gtk
+Source2:       %{name}-gtk.desktop
 Patch0:                %{name}-kde4.patch
+Patch1:                %{name}-no-gdk_display.patch
 URL:           http://www.compiz.org/
 %if %{with gconf} || %{with gtk}
 BuildRequires: GConf2-devel >= 2.0
 %endif
-BuildRequires: OpenGL-devel >= 2.1
 BuildRequires: OpenGL-GLU-devel
+BuildRequires: OpenGL-devel >= 2.1
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake >= 1:1.7
 BuildRequires: cairo-devel >= 1.0
 BuildRequires: dbus-glib-devel
-BuildRequires: gettext-devel
+BuildRequires: gettext-tools
 BuildRequires: glib2-devel >= 2.0
 # <sys/inotify.h>
 BuildRequires: glibc-devel >= 6:2.4
@@ -37,8 +40,8 @@ BuildRequires:        libfuse-devel >= 2.2
 BuildRequires: libpng-devel
 BuildRequires: librsvg-devel >= 1:2.14.0
 BuildRequires: libtool
-BuildRequires: libxml2-devel
 BuildRequires: libxcb-devel
+BuildRequires: libxml2-devel
 BuildRequires: libxslt-devel
 BuildRequires: libxslt-progs
 BuildRequires: pkgconfig
@@ -48,8 +51,8 @@ BuildRequires:        xorg-lib-libXcomposite-devel
 BuildRequires: xorg-lib-libXdamage-devel
 BuildRequires: xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXrandr-devel
-BuildRequires: xorg-lib-libXres-devel
 BuildRequires: xorg-lib-libXrender-devel >= 0.9.3
+BuildRequires: xorg-lib-libXres-devel
 %if %{with gtk}
 BuildRequires: gtk+2-devel >= 2:2.8.0
 BuildRequires: libwnck-devel >= 2.20.0
@@ -64,14 +67,14 @@ BuildRequires:      metacity-devel >= 2.24.0
 %endif
 %if %{with kde}
 BuildRequires: dbus-qt-devel
-BuildRequires: kdelibs-devel
 BuildRequires: kdebase-devel
+BuildRequires: kdelibs-devel
 BuildRequires: qt-devel >= 1:3.0
-BuildRequires: qt4-build
 %endif
 %if %{with kde4}
-BuildRequires: kde4-kdelibs-devel
 BuildRequires: kde4-kdebase-workspace-devel
+BuildRequires: kde4-kdelibs-devel
+BuildRequires: qt4-build
 %endif
 Requires:      %{name}-libs = %{version}-%{release}
 Obsoletes:     compiz-opacity
@@ -79,16 +82,19 @@ Conflicts:  filesystem < 3.0-20
 Conflicts:     xorg-xserver-xgl < 0.0.20060505
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# for gconf subpackage
+%define        plugins annotate blur clone core cube dbus decoration fade fs gconf glib gnomecompat ini inotify minimize move obs place png regex resize rotate scale screenshot svg switcher video water wobbly zoom
+
 %description
 Compiz is a compositing window manager that uses 3D graphics
-acceleration via OpenGL. It provides various new graphical effects
-and features on any desktop environment, including Gnome and KDE.
+acceleration via OpenGL. It provides various new graphical effects and
+features on any desktop environment, including Gnome and KDE.
 
 %description -l pl.UTF-8
 Compiz jest menedżerem okien obsługującym składanie, który używa
 akceleracji grafiki 3D przez OpenGL-a. Umożliwia on uzyskanie nowych
-efektów graficznych i możliwości w dowolnym środowisku, nie
-wyłączając Gnome i KDE.
+efektów graficznych i możliwości w dowolnym środowisku, nie wyłączając
+Gnome i KDE.
 
 %package libs
 Summary:       Compiz libraries
@@ -231,12 +237,10 @@ Window decorator for KDE 4.
 %description kde4-decorator -l pl.UTF-8
 Dekorator okien dla KDE 4.
 
-# for gconf subpackage
-%define        plugins annotate blur clone core cube dbus decoration fade fs gconf glib gnomecompat ini inotify minimize move obs place png regex resize rotate scale screenshot svg switcher video water wobbly zoom
-
 %prep
 %setup -q
 %patch0 -p0
+%patch1 -p1
 
 %build
 %{__intltoolize}
@@ -245,8 +249,8 @@ Dekorator okien dla KDE 4.
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-QTLIB=%{_libdir}; export QTLIB
-QTDIR=%{_prefix}; export QTDIR
+export QTLIB=%{_libdir}
+export QTDIR=%{_prefix}
 %configure \
        --disable-static \
        --enable-librsvg \
@@ -270,6 +274,14 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
 rm -f $RPM_BUILD_ROOT%{_libdir}/window-manager-settings/*.la
 %endif
 
+%if %{with gtk}
+install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
+desktop-file-install \
+       --vendor="" \
+       --dir $RPM_BUILD_ROOT%{_desktopdir} \
+       %{SOURCE2}
+%endif
+
 %find_lang %{name}
 
 %clean
@@ -307,7 +319,6 @@ done
 %exclude %{_libdir}/compiz/libsvg.so
 %{_datadir}/compiz/*.xml
 %{_datadir}/compiz/*.png
-%{_datadir}/compiz/schemas.xslt
 %exclude %{_datadir}/compiz/fs.xml
 %exclude %{_datadir}/compiz/gconf.xml
 %exclude %{_datadir}/compiz/svg.xml
@@ -343,6 +354,7 @@ done
 %attr(755,root,root) %{_libdir}/compiz/libgconf.so
 %{_sysconfdir}/gconf/schemas/compiz-*.schemas
 %{_datadir}/compiz/gconf.xml
+%{_datadir}/compiz/schemas.xslt
 # checked by compiz-fusion-plugins-* (with non-default --enable-schemas only)
 %{_pkgconfigdir}/compiz-gconf.pc
 %endif
@@ -375,7 +387,9 @@ done
 %if %{with gtk}
 %files gtk-decorator
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/compiz-gtk
 %attr(755,root,root) %{_bindir}/gtk-window-decorator
+%{_desktopdir}/compiz-gtk.desktop
 %if %{with gconf}
 %{_sysconfdir}/gconf/schemas/gwd.schemas
 %endif
This page took 0.044654 seconds and 4 git commands to generate.