]> git.pld-linux.org Git - packages/compiz.git/blobdiff - compiz.spec
- c/p
[packages/compiz.git] / compiz.spec
index b43a17e7c79c370ac2a3f4af88f1a050b81197d1..7b5ffd8cdc75c3d0528231a65d1130f7ae15ebc6 100644 (file)
@@ -4,27 +4,32 @@
 %bcond_without gtk             # gtk window decorator
 %bcond_without gnome           # gnome settings module
 %bcond_without metacity        # metacity theme support
-%bcond_without kde             # kde-window-decorator
+%bcond_without kde             # kde-window-decorator and kconfig
+%bcond_with    kde4            # kde4-window-decorator
 #
 Summary:       OpenGL window and compositing manager
 Summary(pl.UTF-8):     OpenGL-owy zarządca okien i składania
 Name:          compiz
-Version:       0.6.2
-Release:       1
+# note that even versions are STABLE
+Version:       0.7.4
+Release:       2
 License:       GPL or MIT
 Group:         X11/Applications
 Source0:       http://xorg.freedesktop.org/releases/individual/app/%{name}-%{version}.tar.gz
-# Source0-md5: 7e6edfdbf0dc46b135313440edae7a53
+# Source0-md5: f8329a683e56003a4654484e00facd1c
 Patch0:                %{name}-DESTDIR.patch
+Patch1:                %{name}-kde4.patch
 URL:           http://compiz.org/
 %if %{with gconf} || %{with gtk}
 BuildRequires: GConf2-devel >= 2.0
 %endif
-BuildRequires: Mesa-libGL-devel >= 6.5-1.20060411.2
+BuildRequires: OpenGL-devel >= 2.1
+BuildRequires: OpenGL-GLU-devel
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake >= 1:1.7
 BuildRequires: cairo-devel >= 1.0
 BuildRequires: dbus-glib-devel
+BuildRequires: gettext-devel
 BuildRequires: glib2-devel >= 2.0
 # <sys/inotify.h>
 BuildRequires: glibc-devel >= 6:2.4
@@ -50,7 +55,7 @@ BuildRequires:        gtk+2-devel >= 2:2.8.0
 BuildRequires: libwnck-devel >= 2.18.1
 BuildRequires: xorg-lib-libXrender-devel >= 0.9.3
 %if %{with gnome}
-BuildRequires: control-center-devel >= 2.0
+BuildRequires: gnome-control-center-devel >= 2.0
 BuildRequires: gnome-desktop-devel >= 2.0
 BuildRequires: gnome-menus-devel
 %endif
@@ -64,9 +69,11 @@ BuildRequires:       kdelibs-devel
 BuildRequires: kdebase-devel
 BuildRequires: qt-devel >= 1:3.0
 %endif
+%if %{with kde4}
+BuildRequires: kde4-kdelibs-devel
+BuildRequires: kde4-kdebase-workspace-devel
+%endif
 Requires:      %{name}-libs = %{version}-%{release}
-Obsoletes:     beryl-core
-Obsoletes:     compiz-kconfig
 Obsoletes:     compiz-opacity
 Conflicts:     xorg-xserver-xgl < 0.0.20060505
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -86,6 +93,7 @@ wyłączając Gnome i KDE.
 Summary:       Compiz libraries
 Summary(pl.UTF-8):     Biblioteki compiza
 Group:         X11/Applications
+Obsoletes:     beryl-core
 Conflicts:     compiz < 0.5.2-2
 
 %description libs
@@ -102,6 +110,7 @@ Requires:   %{name}-libs = %{version}-%{release}
 # (by compiz.pc; header requires only: OpenGL-devel, startup-notification-devel, damageproto, xextproto, libX11-devel)
 Requires:      OpenGL-devel
 Requires:      libpng-devel
+Requires:      libxslt-devel
 Requires:      startup-notification-devel >= 0.7
 Requires:      xorg-lib-libSM-devel
 Requires:      xorg-lib-libXcomposite-devel
@@ -142,6 +151,30 @@ GConf plugin for Compiz (GConf control backend).
 %description gconf -l pl.UTF-8
 Wtyczka GConf dla Compiza (backend sterujący oparty na GConfie).
 
+%package kconfig 
+Summary:       kconfig plugin for Compiz
+Summary(pl.UTF-8):     Wtyczka kconfig dla Compiza
+Group:         X11/Applications
+Requires:      %{name} = %{version}-%{release}
+
+%description kconfig 
+kconfig plugin for Compiz (KDE control backend).
+
+%description kconfig -l pl.UTF-8
+Wtyczka kconfig dla Compiza (backend sterujący oparty na KDE).
+
+%package svg
+Summary:       SVG plugin for Compiz
+Summary(pl.UTF-8):     Wtyczka SVG dla Compiza
+Group:         X11/Applications
+Requires:      %{name} = %{version}-%{release}
+
+%description svg
+SVG image loader plugin for Compiz.
+
+%description svg -l pl.UTF-8
+Wtyczka wczytująca obrazy SVG dla Compiza.
+
 %package gnome-settings
 Summary:       Compiz settings for GNOME control panel
 Summary(pl.UTF-8):     Ustawienia compiza dla panelu sterowania GNOME
@@ -184,12 +217,26 @@ Window decorator for KDE.
 %description kde-decorator -l pl.UTF-8
 Dekorator okien dla KDE.
 
+%package kde4-decorator
+Summary:       Window decorator for KDE 4
+Summary(pl.UTF-8):     Dekorator okien dla KDE 4
+Group:         X11/Applications
+Requires:      %{name} = %{version}-%{release}
+Obsoletes:     aquamarine
+
+%description kde4-decorator
+Window decorator for KDE 4.
+
+%description kde4-decorator -l pl.UTF-8
+Dekorator okien dla KDE 4.
+
 # for gconf subpackage
 %define        plugins annotate blur clone core cube dbus decoration fade fs gconf glib ini inotify minimize move place plane png regex resize rotate scale screenshot svg switcher video water wobbly zoom
 
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p0
 
 %build
 %{__intltoolize}
@@ -206,6 +253,7 @@ QTLIB=%{_libdir}; export QTLIB
        %{!?with_gnome:--disable-gnome} \
        %{!?with_gtk:--disable-gtk} \
        %{!?with_kde:--disable-kde} \
+       %{!?with_kde4:--disable-kde4} \
        %{!?with_metacity:--disable-metacity}
 
 %{__make}
@@ -254,15 +302,22 @@ done
 %attr(755,root,root) %{_bindir}/compiz
 %attr(755,root,root) %{_libdir}/compiz/*.so
 %exclude %{_libdir}/compiz/libfs.so
+%{?with_kde:%exclude %{_libdir}/compiz/libkconfig.so}
 %{?with_gconf:%exclude %{_libdir}/compiz/libgconf.so}
-%{_datadir}/compiz
+%exclude %{_libdir}/compiz/libsvg.so
+%{_datadir}/compiz/*.xml
+%{_datadir}/compiz/*.png
+%{_datadir}/compiz/schemas.xslt
 %exclude %{_datadir}/compiz/fs.xml
 %exclude %{_datadir}/compiz/gconf.xml
+%exclude %{_datadir}/compiz/svg.xml
 
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libdecoration.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libdecoration.so.0
 %dir %{_libdir}/compiz
+%dir %{_datadir}/compiz
 
 %files devel
 %defattr(644,root,root,755)
@@ -271,6 +326,7 @@ done
 %{_includedir}/compiz
 %{_pkgconfigdir}/compiz.pc
 %{_pkgconfigdir}/libdecoration.pc
+%{?with_kde:%{_pkgconfigdir}/compiz-kconfig.pc}
 # checked by compiz-fusion-plugins-extra
 %{_pkgconfigdir}/compiz-cube.pc
 # checked by compiz-fusion-plugins-main
@@ -291,6 +347,19 @@ done
 %{_pkgconfigdir}/compiz-gconf.pc
 %endif
 
+%if %{with kde}
+%files kconfig
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/compiz/libkconfig.so
+%{_datadir}/config/compizrc
+%{_datadir}/config.kcfg/*.kcfg
+%endif
+
+%files svg
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/compiz/libsvg.so
+%{_datadir}/compiz/gconf.xml
+
 %if %{with gnome} && %{with gtk}
 %files gnome-settings
 %defattr(644,root,root,755)
@@ -314,3 +383,9 @@ done
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/kde-window-decorator
 %endif
+
+%if %{with kde4}
+%files kde4-decorator
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/kde4-window-decorator
+%endif
This page took 0.072152 seconds and 4 git commands to generate.