]> git.pld-linux.org Git - packages/commoncpp2.git/commitdiff
- as-needed changes
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 10 Nov 2006 10:13:52 +0000 (10:13 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    commoncpp2-Makefile.patch -> 1.4

commoncpp2-Makefile.patch

index cd61dada8170f2bcb2d6c02efee125f0dfba4469..f6b81684ccd6f52360ed7a12f26d927e1ad89023 100644 (file)
@@ -1,9 +1,37 @@
---- commoncpp2-1.3.26/Makefile.in.orig 2006-03-28 14:45:49.000000000 +0000
-+++ commoncpp2-1.3.26/Makefile.in      2006-04-24 21:50:52.064037750 +0000
-@@ -688,23 +688,6 @@
+diff -urN commoncpp2-1.5.1.org/configure.ac commoncpp2-1.5.1/configure.ac
+--- commoncpp2-1.5.1.org/configure.ac  2006-10-07 20:14:28.000000000 +0200
++++ commoncpp2-1.5.1/configure.ac      2006-11-10 11:48:05.995177250 +0100
+@@ -354,6 +354,9 @@
+ darwin*)
+       MODULE_FLAGS="-dynamic -bundle -undefined suppress -flat_namespace -read_only_relocs suppress"
+       ;;
++linux*)
++      BASE_LIB="$SSL_LIBS"
++      ;;
+ esac
+ AC_SUBST(COMMON_FLAGS)
+diff -urN commoncpp2-1.5.1.org/Makefile.am commoncpp2-1.5.1/Makefile.am
+--- commoncpp2-1.5.1.org/Makefile.am   2006-05-03 14:31:58.000000000 +0200
++++ commoncpp2-1.5.1/Makefile.am       2006-11-10 11:51:07.890545000 +0100
+@@ -21,12 +21,8 @@
+ if WIN32
+ SUBDIRS = include src doc
+ else
+-if MSWIN32
+-SUBDIRS = include w32 doc
+-else
+ SUBDIRS = include src doc
+ endif
+-endif
+ macosx:
+       (cd src ; make macosx)
+@@ -34,23 +30,4 @@
+ darwin:
        (cd src ; make macosx)
  
- install-data-local:
+-install-data-local:
 -      @if test -f /etc/ld.so.conf \
 -        -a `echo $(libdir) | grep ^/usr`XXX != "XXX" ; then \
 -              if ! grep -q "$(libdir)" /etc/ld.so.conf; then \
 -                      ldconfig ;\
 -              fi ;\
 -      fi
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
+-
+diff -urN commoncpp2-1.5.1.org/src/Makefile.am commoncpp2-1.5.1/src/Makefile.am
+--- commoncpp2-1.5.1.org/src/Makefile.am       2006-09-30 18:41:53.000000000 +0200
++++ commoncpp2-1.5.1/src/Makefile.am   2006-11-10 12:11:29.986921250 +0100
+@@ -32,8 +32,8 @@
+ scriptdir = $(bindir)
+ script_DATA = ccgnu2-config
+-libccgnu2_la_LIBADD = @THREAD_LIBS@
+-libccgnu2_la_LDFLAGS = $(RELEASE) $(SHARED_FLAGS)
++libccgnu2_la_LIBADD = @THREAD_LIBS@ -lpthread -ldl
++libccgnu2_la_LDFLAGS = $(RELEASE) $(SHARED_FLAGS) -lpthread
+ noinst_DATA = @STAGE2@
+ libccgnu2_la_SOURCES = thread.cpp mutex.cpp semaphore.cpp threadkey.cpp \
+@@ -45,7 +45,7 @@
+       cidr.cpp private.h nat.h
+ if EXTRAS
+-libccext2_la_LIBADD = @BASE_LIB@ @THREAD_LIBS@
++libccext2_la_LIBADD = @BASE_LIB@ @THREAD_LIBS@ libccgnu2.la
+ libccext2_la_LDFLAGS = $(RELEASE) $(SHARED_FLAGS)
+ if GETOPT_LONG
+@@ -64,6 +64,11 @@
+       tokenizer.cpp mime.cpp ssl.cpp
+ endif
++
++else
++
++libccext2_la_LIBADD = libccgnu2.la
++
+ endif
+ # private.h and nat.h are internal headers
This page took 0.104945 seconds and 4 git commands to generate.