]> git.pld-linux.org Git - packages/commoncpp2.git/blame_incremental - commoncpp2.spec
- outdated
[packages/commoncpp2.git] / commoncpp2.spec
... / ...
CommitLineData
1Summary: A GNU package for creating portable C++ programs
2Summary(pl.UTF-8): Pakiet GNU do tworzenia przenośnych programów w C++
3Name: commoncpp2
4Version: 1.6.1
5Release: 1
6License: GPL
7Group: Libraries
8Source0: ftp://ftp.gnu.org/pub/gnu/commoncpp/%{name}-%{version}.tar.gz
9# Source0-md5: 2ebd8eb80996515be0385378da783091
10URL: http://www.gnu.org/software/commoncpp/
11BuildRequires: autoconf
12BuildRequires: automake
13BuildRequires: doxygen
14BuildRequires: libstdc++-devel
15BuildRequires: libtool
16BuildRequires: libxml2-devel
17BuildRequires: openssl-devel
18BuildRequires: zlib-devel
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22This is the second major release of GNU Common C++. GNU Common C++ "2"
23is a GNU package which offers portable "abstraction" of system
24services such as threads, networks, and sockets. GNU Common C++ "2"
25also offers individual frameworks generally useful to developing
26portable C++ applications including a object persistance engine, math
27libraries, threading, sockets, etc. GNU Common C++ "2" is small, and
28highly portable. GNU Common C++ "2" will support most Unix operating
29systems as well as Win32, in addition to GNU/Linux.
30
31%description -l pl.UTF-8
32Drugie główne wydanie GNU Common C++. GNU Common C++ oferuje przenośne
33abstrakcje usług systemowych takich jak wątki, sieci i gniazda.
34Oferuje także poszczególne szkielety użyteczne do rozwijania
35przenośnych aplikacji C++ zawierające silnik trwałych obiektów,
36biblioteki matematyczne, wątków, gniazd itd. GNU Common C++ jest mały
37i przenośny. Oprócz GNU/Linuksa obsługuje także większość uniksowych
38systemów operacyjnych oraz Win32.
39
40%package devel
41Summary: Header files for commoncpp2 library
42Summary(pl.UTF-8): Pliki nagłówkowe biblioteki commoncpp2
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: libstdc++-devel
46Requires: libxml2-devel
47Requires: zlib-devel
48
49%description devel
50Header files for commoncpp2 library.
51
52%description devel -l pl.UTF-8
53Pliki nagłówkowe biblioteki commoncpp2.
54
55%package static
56Summary: Static commoncpp2 library
57Summary(pl.UTF-8): Statyczna biblioteka commoncpp2
58Group: Development/Libraries
59Requires: %{name}-devel = %{version}-%{release}
60
61%description static
62Static commoncpp2 library.
63
64%description static -l pl.UTF-8
65Statyczna biblioteka commoncpp2.
66
67%prep
68%setup -q
69
70%build
71%{__libtoolize}
72%{__aclocal} -I m4
73%{__autoconf}
74%{__autoheader}
75%{__automake}
76%configure \
77 --with-openssl
78%{__make}
79
80%install
81rm -rf $RPM_BUILD_ROOT
82
83%{__make} install \
84 DESTDIR=$RPM_BUILD_ROOT
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%post -p /sbin/ldconfig
90%postun -p /sbin/ldconfig
91
92%post devel
93[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
94
95%postun devel
96[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
97
98%files
99%defattr(644,root,root,755)
100%doc AUTHORS COPYING.addendum NEWS README TODO ChangeLog
101%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
102
103%files devel
104%defattr(644,root,root,755)
105%doc doc/html/*.html doc/html/*.*g*
106%attr(755,root,root) %{_bindir}/*
107%attr(755,root,root) %{_libdir}/lib*.so
108%{_libdir}/lib*.la
109%{_includedir}/cc++
110%{_aclocaldir}/*.m4
111%{_pkgconfigdir}/*.pc
112%{_infodir}/*.info*
113
114%files static
115%defattr(644,root,root,755)
116%{_libdir}/lib*.a
This page took 0.071664 seconds and 4 git commands to generate.